Completely confused with the MIDI routing...

In an other thread i adressed a problem with the MIDI routing into a (multi timbral) synth. But beyond this, i am afraid that i am completely confused about the whole MIDI routing by iteslf.

OK, please let me describe my setting:

  • Cubasis :wink:
  • A Korg microKey Keyboard, sending always on Channel 1
  • A synth app (Korg iM1, receiving on channels 9-16 [or any other 8 channels]- as a multitimbral instrument)

I want to do this:
Cubase should only be used as a MIDI sequencer, the sound should come from the background audio of the iM1.
Therefore i create a MIDI track with no Instrument, switch MIDI out to the iM1 and the desired channel (MIDI in is listening to all channels).
Now this CRAZY THING HAPPENS: When i play the cubasis touch Keyboard, the MIDI signal is routed to the iM1 and everything is wonderful. But when i play the microKey, KEYS ON THE SCREEN ARE LIGHTING UP AS I PLAY THEM - but NO SOUND FROM iM1!! I can record MIDI notes, but i cannot hear anything. When i playback the track, the iM1 does make sound.

Can YOU understand this? I cannot get this into my brain…

I could use iM1 with Inter-App Audio, but the big disadvantage is, that only one instance can be used and i am far away from a multi timbral workstation.
If someone askes why i want to use a ceesy 80s M1 as a workstation on an iPad; it’s because of the thrill to limit myself on ONE soundmodule to be more creative.

However, please can someone help me to solve this puzzle?

Hi pummelfee,

Thanks for your message.

Unfortunately we’re not equipped with the NI microKey.

Gave this setup a short check:
Triggering the iM1 assigned via IAA in Cubasis works as expected, having a CME Xkey Air device connected via bluetooth.

Please give it a try to restart your iPad.
If the problem persists, please get in touch with NI.

We’re able to provide them with a Cubasis promo code for testing purposes, if helpful.


Try restarting your iPad. My JD-Xi doesn’t work at times with Cubasis and a restart resolves it.

Hi Lars,

thank you for your reply! It ist not an issue with the IAA integration of iM1 - this does work. But it is not the way i can use the iM1 multi timbral (afaik).
BTW: the microKey is from Korg :wink:

Cubasis doesn’t automatically forward a track’s MIDI input to MIDI output.

By default, MIDI input triggers the track, which is why you see the keys pressed on the internal keyboard, and MIDI output is only produced by playing the internal keyboard or via track playback.

Activating the MIDI Thru button will forward all MIDI input from the selected port to the selected MIDI output port. However, Cubasis has the known limitation that all MIDI data is forwarded 1:1 without re-routing. In other words, if MIDI Thru is enabled, the channel selection is ignored and everything is routed thru.

MIDI Thru re-channelizing is on our list of future updates. Until then, there are two workarounds:

  1. Enable the MIDI Thru button and configure your hardware keyboard to send on the desired MIDI channel.
  2. Use a MIDI routing app to route the MIDI signals and change their channels. MidiBridge was a good app for that, but the developer does not seem to have updated the app for iOS 11.