Complicated results when Transposed by second minor up


I get very complicated results when transposing a score.

I tried without Keep relative respelled notes and also without Keep relative respelled chords, but get the same result.
I get the same result with other songs.

Any clue of what I missing?

I found a way to do get it done but it’s not very effective.

First, transpose by Major second up and down by a second minor. :confused:


Dorico did what you asked it to do.

If you don’t want double sharps and flats, tick the box that says “Respell to avoid double and triple sharps and flats”.

You should use “augmented unison” if you do not want every note to be respelled with the next diatonic name.

Thank you, Rob Tuley and MarcLarcher,

I don’t know who exactly would expect for double flat and double sharp for chords and notes.
But as a non-superuser, I would be happy with a simpler result.

Also, have to select the “quality” before the “interval” is not logical for me.
I have to select the “Interval” fist in order to be able to select the “quality”.

Switch the layout between “quality” and “Interval” would be an option.

I tried “augmented unison” from an Eb minor song transposed to E minor and got a better result,
but still, get E# Fx

I suppose transposing is a tricky one to program, and I’ll use “augmented unison”

Thank you for your precious help.

Did you try Rob’s suggestion to turn off double sharps and flats?

Here the result with “double sharps and flats” turned off + “augmented unison”

In this case, the technique of transpose by Major second up and down by a second minor get also double sharps even with the “double sharps and flats” turned off.

Oh, it might be connected by the key of the song.

For Pop job chords score, usually, I don’t set the score with the key at the beginning of the song.

Is it necessary to set the key of a piece in order to transpose it?

Now a result from song set in Gm

In this case, augmented second transposition gets the best result.

A little notice.

When I export a song with “#” in the title as PDF I get “-” intead when exported as the name file.
Screen Shot 2020-09-30 at 15.13.01.png

That’s right. Dorico will sanitise your filenames to make sure you don’t include characters that will cause problems with the filesystem.

I’m glad I found this post - I was about to post similar, simply impossible to transpose from C minor to C# minor (OK Eb to E) without getting ridiculous flats everywhere, and I couldn’t find a way to go from a key sig of 3 flats to one of sharps, BUT your solution, up by a second and down by a minor second worked.

Attached are the before and after results of simply upping by a minor second, which you’d think might work, and yes I tried all the tick boxes for spelling, double accidentals etc.

Not sure if this should be achievable by simply transposing up by a minor second, I would think so? Anything I’m missing?
Screenshot 2020-10-23 at 11.15.56.png
Screenshot 2020-10-23 at 11.16.11.png

Dorico treats these intervals literally. “2nd” is always going to mean that the named pitch changes (C to D, E to F etc.)

Try an augmented unison. There’s a calculator on the right side of the dialog to help you cope with Dorico’s sometimes-confusing logic.

Thanks, will try Augmented Unison next time.