Condensed staff label name

I want all my condensed staves to be named in plural with the number before, e.g. “2 Oboi” instead of “Oboe I.II”.

And the horn should be two staves “4 Corni in F” with inner staff labels I,II on top stave and III, IV
on bottom stave.

Is this possible?

It’s not directly possible at the moment, no: Dorico doesn’t yet make use of the plural names defined in the Edit Instrument Name dialog. This is planned for the future. Workarounds are possible, but they’re not necessarily a lot of fun: please search the forum for “plural names” and you should find some previous discussions.

Great to know that it is planned for the future! I found a few workarounds already, a bit tricky but still.

Hi all.

I am trying to achieve exactly what is being asked in the OP.
However, I am not finding any useful enough information. Changing the instrument name from “Oboe” to “2 Oboi” I understand, but how can I get rid of the numbering of the instruments?

Is it at all possible?

The house style I need shows “2 Oboi” on the first system, and only “Ob.” on subsequent ones. Who is playing is apparent from labeling in the actual music, so never any player numbers in the staff labels.

Thanks
LAE

There’s no easy way to do this. If you change each instrument name from “Oboe” to “Oboi” then you will get “Oboi” as the label, but there’s no way to make Dorico show “2 Oboi”: it will show “Oboi 1.2.” or similar. When we add support for plural instrument names, we’ll make sure this is one of the conventions that Dorico will support out of the box.

1 Like

Thanks Daniel. I guess the not so easy way includes graphical editing of the PDFs in some other software – but it might still be worth it. Unless I can convince the others to accept the style with 1,2.

HI, I found a workaround that works well for this purpose.

Rename both oboe parts to “2 Oboi” and then use short name “Ob.” for both.

Then I changed the foreground colour in paragraph styles for “Staff Labels (inner)” to white and changed size and alignment and other stuff to make them sit outside page margin. They are still there but hidden.

See attached image.

Hope this helps anyone who wants to achieve this.

1 Like

Perfect! Thank you!
I should have known to ask you directly… :wink: Next time.

Just one remark. When I tried this method, I could not get the Staff Labels (inner) setting to change anything in the score, unless the engraving setting for condensing was like this:

image

With the left box selected, the numbers do not change at all.

Oh that’s true, I fiddled around with so many settings that I´m no longer sure of which ones I needed to change for this one to work.