Condensing and Bracket Question, Condensing Change Controls stay disabled

This are two questions, but they came up together.

I do not understand the way brackets are treated when condensing is on.

I made some bracket changes - a main bracket for Trumpets and Trombones, a sub bracket
for each instrument group. Custom condensing groups exist for trombone 1/2 and trombone 3/4.
(1. in jpg)


After condensing, the Trumpets (condensed as expected to one stave, nothing to condense btw.)
lose their sub-bracket and are thrown out of the main bracket with the trombones.
No bracket at all. It does not matter if there is a custom condensing group override for Trumpet 1/2/3 or not.
(2. in jpg)

-> I tried to extend the main bracket in engrave mode manually (selected the trombones brackets and dragged the upper
end up to the trumpet stave) but dorico won’t let me do that.
-> On the other hand, the subbrackets of condensed Flute 1/2, Oboe 1/2 don’t get lost (as expected).
So whats wrong with the trumpets?

When I define only Trumpet 1/2 as custom condensing group, everything’s seems fine.
(3. in jpg)

I was wondering if I could find a workaround with a condensing change but found that

  • not only in the location shown in 4. in the jpg, but along all flows in the complete project -
    the controls will get enabled only for the first condensing group in the project, the flutes.
    Could not find a bar where it would be otherwise. No other checked checkbox will enable them.
    Here in the example, the default trumpet group (N.B. strange: ordered 1-3-2) is selected, and the controls stay disabled.

I.E. I cannot create condensing changes for none of the condensing groups, default or custom,
with exception of the Flutes, in the complete score.

Bug? Corrupted project file?

I think it’s better that you post a cut-down version of the project that shows the problem.

https://www.steinberg.net/forums/viewtopic.php?f=246&t=185217&sid=ce56a140b5c11d31af0de42cd92cf472
“solves” the second part of this post. Thanks for the hint.

I need more spare time to “cut it down”: to delet a player costs about 2 min of sandclock-watching, can’t be automated,
must be done player for player, so I can’t do something usefull in this time, for I’m not a roboter…
=> That means, reducing it to Trumpets/Trombones only would cost about 40 min. But well, I’'ll do my very best… hoping that the problem
still shows up after such radical incuts…

In Setup mode, select all the players you want to delete, then click delete. Then do something else while Dorico does its thing.

This will work faster if you switch off condensing, close the score layout, and open a part which you are not deleting. Then Dorico doesn’t have to reformat the layout when it deletes the players.

Ok. it did only take me 15 min, but thats only another proof for Einstein:
if you are looking too long at a clock in motion, you get time dilation…

(When I right click on a multiple selection of players in setup mode,
the selection is reduced to one instrument.
I just found out - too late -that a click the paper basket respects the multi selection. )

By the way Dorico gets really fast if the project is not too big!
Wow! I did not remember.

The result is attached.

Some remarks:
-> In flow 2 can be seen that the brackets are perserved
when trumpet is split to 1/2 + 3. A split 1 + 2/3 preserves the
main bracket, the subbracket appeares with trumpet 1, 2/3 loose the
bracket. (Flow 2 bar 62 versus bar 184) Only 1.2.3. looses sub- and main bracket.

-> there is one difference to the original score:
Engrave Mode, Condensing on, goto flow 1, let’s say bar 567.
Drag the upper end of the main bracket up to the trumpet stave.
This is possible, but Dorico reverts the change, the bracket falls back to the trombones,
but - this is different - there is now a signpost for a change that was not accepted.
I did not see/get this signpost in the original project file with the same operation.

-> it seems to me that default condensing is broken near the end of
flow 2. I cannot see any reason why there is no condensing in
Trombones 1/2 bar 139 up to 204, and Trumpets not 1.2.3. in 147 and 187
(Horns also show condensing problemns in the same area, but horns are gone…)
While prior to this part, condensing works like a charm!
ls-reduced.zip (939 KB)

I haven’t looked at the trumpet case in your project, but the trombones at bars 139ff. in flow 2 don’t condense because multiple voices are active there, though it’s hard to see. If you switch off condensing or switch to galley view, switch on View > Note and Rest Colors > Voice Colors and add an eighth note at the start of bar 139 in the trombone 1 part, you’ll see that there is another voice active, because an eighth rest in a pink voice suddenly pops up. Delete that rest, then delete the note you added at the start of the bar, and everything will condense as you expect there. In general you should watch out for having explicit rests unless you really need them, and certainly you need to make sure you only have a single voice active at any point, otherwise that phrase will be ruled out of condensing right away.

Thank you Daniel for this instruction, I found a lot of those lost rests; seems all remaining problems can be solved this way.
Those rests must somehow be remnants from the Sibelius xml export, when I separated the solo players which shared one system in Sibelius;
they were not created intentionally.
But this is tedious. Is there a way to show all of those hidden rests with one command? Some way to eliminate this rest in one cleanup operation?
I tried to select -> voices -> change voice to upstem voice 1, but this did not help, maybe because one can’t select what is hidden.

Btw. any idea in the forum how to solve the bracket problem? How to create the brackets for the condensed score?
May be an issue for a “Discover Dorico”-Session?

In Preferences / MusicXML import there are many options to import the semantics of what the notation means but ignore the exact appearance and layout information in the MusicXML file. In general, things work better if you let Dorico reconstruct the appearance of the notation for itself using the rules in Notation and Engraving Options.

Specifically for rests, there are options to ignore the information about rest duration, vertical position, and visibility. Try unticking those boxes.

You can use View > Note and Rest Colours > Implicit Rests, which will cause all implicit rests to appear in grey: any explicit rests (which are the ones you need to get rid of) will then show in black. You can select them and delete them.

I still have this condensed vs. bracket problem.

The animated gif shows, that the 3 trumpets -> condensed to one system loose their common main bracket with the trombone and their subbracket too.
I then tried in engrave mode to give the trumpets the main bracket back, but this is rejected by dorico, further more, again in uncondensed mode, the first trumpet and the last trombone have been thrown out of the main bracket.

It there a way to get the brackets in condensed mode the way they were setup?
All other condensing groups (a 2 max) do respect the brackets.
Should not Dorico keep track of this, and supply the brackets according to the last bracket change (i.e. in this case: a main bracket for all trumpets and trombones, a sub bracket for trumpets, a sub bracket for the trumpets)( for every condensing situation (1, 2, 3 systems for the trumpets)?

It there a workaround, as a manual correction in engrave mode seems not possible?
Or is this behavior maybe planned for the next update? Then I would wait.
Or is it even better not to request 3 trumpets to condense in one line, and setup a condensing group 1-2 ?
2020-06-14_18-23-04.gif

Hi!
I find that I can give the bracket and sub-bracket thanks to the tool in Engrave mode (which is actually made for it, not a workaround). If I use it at the beginning of the flow, I find the bracketing is retained as wished. To pit the subrackets, make sure there is something uou can select in Engrave mode — you could add a note to the three trumpets and delete this note after you’ve created your bracketing thing. Hope this helps!

Well the behavior is just as shown in the animated gif - I can move the main bracket up to the trupets line - but if falls back and the result is that the previously defined brackets in uncondesed mode suffer unwanted modifications. … I added an identical note to all trupets, selected the resulting “a3” note, and tried to get a subbracket for the line - nothing happens (well without extending the main bracket first, maybe this is normal).

I reduced the score -> attached.
(Two windows open, one in write mode, one in engravemode, take notice of the bracket order in the write mode window, then in the engrave mode window (in condensed mode) try to extend the main bracket to the 3-trumpet system. Won’t work. See what this does on the other hand to the bracket order in the write mode window.)

Still I think, even if the things would work as Marc said, “not as a workaround” … wouldn’t mean that one has to correct the brackets at every systembreak where a condensing change happens? And do it over again, if for some reason the systembreaks must be changed afterwards?
For me, this would be a plausible feature request, that dorico keeps track of the bracket changes which are needed due to condensing changes.
Would be a big time saver, at least in big scores…
bracket-condensing-problem1.zip (735 KB)

@taguluche

I have similar problems, I’ve sent mijn file to John Barron, I hope he can help me out.
I’ll let you know…

Geert