Condensing - 'Hide rests for inactive players' sometimes omits player name

I’m just starting to experiment with condensing, it looks amazingly promising!

Checking ‘hide rests for inactive players’ in the Trumpet 1.2 and Horn 1,2,3,4 and Tuba 1,2 groups works well, except that it omits
the Horn 1 indication that should be present (it works well in the other cases). The picture should make this clear.

Am I doing something wrong or do I need to fix this with a text hack?

Thanks!

In your condensing change, did you change the option for how inactive players should be handled? It looks like you’ve changed the option such that rests should not be shown for inactive players, and I suspect that it’s then not adding a new label because the previous phrase had a label already, but I would need to see the project itself to be sure.

Yes, I checked ‘hide rests for inactive players’. Moving this condensing change to figure 1 in the image worked around the problem,
but this seems to be a bug? Without the part name, there’s no way to know which horn would be playing those notes.

Can you attach the project itself, or perhaps just the horn parts for that passage, so I can take a look?

I’d be happy to. THere’s also an issue with the tubas later :slight_smile: I looked for the FAQ on how to attach a project, but somehow couldn’t find it, can you direct me to that? I remember it was quite detailed.

Look at #4 in this:

https://www.steinberg.net/forums/viewtopic.php?f=246&t=155802

Stew

Thank you, Stew!

Here’s a snippet with the original problem in the horns. There’s also something at 2 if you could comment on - I’d love to have e setting that would give rests for the second tuba part for that measure only, omitting the two 1’s, then continuing in the next measure without the rests. I find that clear. Is such a thing possible?

I also had to include the trumpet part because deleting that removed the two 1’s in the tuba at 2, which was odd.

Thank you so much for your continued assistance!
CondensingIssue.zip (425 KB)

Sorry to take so long to come back to you here. The reason the horn 1 entry in bar 18 doesn’t get an explicit label is because the previous label on the system was also for Horn 1, and Dorico takes the view that it should not repeat identical labels with no other intervening labels. I can’t find the specific combination of options that will cause tuba 2 to show rests in bar 23, but such a combination should be possible, particularly if you create a condensing change on the second beat of that bar, so that Dorico will consider that beat the start of a new phrase.