[Confirmed] [CAN-23727] Midi "Record Enable" notes being reset (10.0.30 Bug)

Just discovered a new bug introduced in 10.0.30 that is not present in 10.0.20 and prior versions(tested).

sound is being cut off when enabling/disabling the Record Enable button on an Instrument/Midi track. This is terrible if you have long midi notes and switch to a different midi track with record enable(preference or manually).

Please take a look at the issue here:
https://www.dropbox.com/s/w0yfy2q4b2btjp0/Midi%20Record%20Enable%20sound%20bug.mov?dl=0

  1. Create an instrument track and load an Instrument.
  2. Record a take with long midi notes.
  3. Play the track and press the Record Enable button on the track.
  4. Midi notes sound gets cut off(no sound).

I’m surprised that no one else has noticed this as it cuts off the sound of the midi tracks completely. The only way to get the sound back is to let it loop or stop and then hit play again.

Confirmed here. I don’t know if it was already happening with 10.0.20 but something is sure : it is NOT happening with 9.5.50. I have just tested it and, with the latter, you can freely select another track without any sound interruption, this, no matter how the Enable record on selected MIDI track option is set. Two additional observations :

  • When there are several notes with a certain durations recorded at different times, if we select another track, this strange sound interruption occurs, but if we select the involved track back again and there are still notes to be read, these will be played.
  • The sound interruption also occurs if we enable/disable few times the record on the same track without even selecting another, this, no matter how the Enable record on selected MIDI track option is set. And this is also NOT happening with 9.5.50…

So, it seems that there is a regression here compared to 9.5.50, as if there were “note off” events occuring on all notes played when the Record button is passing from an enabled to disabled state. It indeed needs a quick fix, IMO. :confused:

Confirmed here too.
This is really unacceptable. There should be an instant patch fix for this - no waiting around for months till 10.0.40.
This is CORE FUNCTIONALITY that is NOT functioning.
Till then, looks like I’m going back to 9.5.50 to actually get some work done.

EDIT - I just checked: this issue was introduced by the latest update. 10.0.20 functions as expected.

Good observations!! Thanks

Exactly! This should have never gotten passed the beta testing.

This needs a fix asap as it interrupts playback big time. I already submitted the issue to support and I highly suggest that we all do to get Steinberg to look into quickly.

I might just have to go back to 10.0.20 until it’s fixed. :frowning:

But enabling record also disables asioguard on that instrument.
What happens if you turn off asio guard, and test again.

I just tested it, deactivating ASIO guard in the Studio setup window : exactly the same results…

Nothing. The issue remains. I spent quite a bit of time testing it out in all kinds of ways with no solution.

It almost seems like there is something in the code that is resetting midi notes to off when disengaging the “record Enable button”.

If one uses the “Reset” under Midi->Reset from the main menu bar, you’ll get the same behavior. Strange

CC123 (All Notes Off) is sent.

Good catch ! Now, I would like someone from the Steinberg team to chime in, just to explain this behavior. Just hope that this isn’t a new hidden ‘feature’… :confused:

Yes, nice!

So now we know what the problem is.

I can’t imagine anyone who would like this to be default, especially those who work with orchestral libraries.

Let’s hope this is not by design, cause it would be a really dumb one.

Yes, same here. This needs to be addressed regardless.

Bump.
Of all the Cubase 10 issues I’ve seen, this is the most disturbing one, as there is no workaround.
I wonder whether Martin Jirsak could confirm this as a bug?

Noticing this same issue as well. It’s very distracting.

Another voice for an option to turn off this feature quickly ! This thing is driving me crazy. Workflow killer.

Can we get an official statement from steinberg?, this is a bug that needs a hotfix ASAP

God i thought i accidently hit something on preference. but good to know it’s happening for everyone. This is no good at all. come on, cubase! it’s driving me crazy. totally messed up my workflow.

It did happen sometimes in previous version. I started with Pro 8 and had there were some minor drop out and timing glitches. Now, nearly every move causes a drop out. IMHO, as it is right now, it is not possible to Produce, Record or Mix in Cubase.

Let’s hope that Mr Hans Zimmer is using 10.0.30, and finds out about this. It might get fixed rather quickly if he does!

Good grief! :frowning:

Have you checked other items – Listen Bus, Solo/Unsolo, Bypass/Unbypass? I’m getting glitches and drop out with nearly every and any move in Cubase Pro 10.0.3

I had not thought to check this with MIDI Monitor. I’ll have a look. :frowning: This is so bad :frowning:

Same issue here. Disappointed.

The same problem, I hope the steinberg team to solve as soon as possible, the current work is greatly affected. :cry: :cry: