Connecting Kontakt tune knob to Cubase pitchbend

I’m new to connecting Kontakt to Cubase so bear with me…

I’ve managed to connect the Kontakt player to Cubase 10 Pro and can happily load an instrument and play using MIDI in Cubase. However I’m wanting to connect the ‘tune’ knob on the instrument in Kontakt to the pitchbend controller in Cubase. I managed to connect the tune knob to one of the other controller lanes (CC1) but the range of the controller lane is too small, making the changes in pitch too large to sound natural.

Is there a way to manually assign the tune knob in the instrument loaded in Kontakt to the pitchbend controller in Cubase? I’m also looking to do the same for the dynamics controller - ideally I’d be able to link that to the velocity controller in Cubase so I can control the velocity of each note (rather than just overall).

I’ve attached a screenshot just so you can see which library I’m working with and its interface (Spitfire studio brass). Any help would be much appreciated, also excuse my ignorance in this area (I’m not very au fait with MIDI and controller lanes…)


As far as I know, you can right-click to the knob in NI Kontakt and choose MIDI Learn. Then move the physical controller (PitchBend). It should be assigned on Kontakt side.

Thanks for the reply Martin. I tried that but unfortunately it wouldn’t link to the pitchbend. I can link it to the other controller lanes (CC1-CC127), but they don’t have the range required to make the change in pitch sound natural - the jumps are too noticeable.


Could you go the way of Quick Controls then?

Click the gear icon on the Kontakt instrument to edit the instrument.

In the Source section, there’ll be a button labelled Mod. Click that and you’ll be able to assign a mod source to Pitch.

I’ve never used these - do you know how I could set them up to alter the tune knob in the Kontakt instrument?

When I try clicking on the gear icon in the top left hand corner of the instrument:

It takes me to the Spitfire Audio settings which doesn’t seem to have any pitch mod:

Maybe try clicking the wrench icon instead.

I’m really surprised that the instrument doesn’t have the pitch mapped to the pitch bend by default. You’d think every instrument should have this done out of the box.

you have to edit the Kontakt instrument itself if the pitch bend controller is not working in an instrument. The main Tune knob range is always from -36 to +36 halftones, which is far too much for PB, so I wouldn’t recommend this.

To access the Pitch Bend Editor in Kontakt:

  • click on the wrench icon to enter edit mode
  • in Group Editor select: Edit all Groups
  • under ‘Source’ open the ‘Mod’ tab
  • if you don’t see a Pitch Bend modulator, click on ‘add modulator’
  • left side: select ‘Pitch Bend’ / right side: select ‘Pitch’, then adjust the slider in the middle to change the PB range.

hope this helps!