Connecting Lexicon Omega to Computer (Cubase 8) with USB all input goes to 1 input bus

It has been a long time since I tried to record (as you can see by the age of my equipment and software) and I am a novice. I believe previously I may have incorrectly been using the rca outputs from Lexicon Omega directly to my onboard sound card, which caused all kinds of issues trying to record multiple channels at one time and with latency, but I could record 1 channel at a time. I am now trying to use the USB connection, which should be the right way to connect, and now my problem is mapping the inputs for recording. No matter what I do, everything goes to bus 1. I am using mono configurations, but I did try stereo, then everything goes to the left channel. It appears that the signal from each input source is going to the same place when routed to the computer and software.

Does anybody know where the problem may lie? I have tried both the Omega ASIO Driver 2.7 and the windows generic low latency asio driver v

I have read about an ASIO4ALL driver that I thought about trying. What driver to you recommend that I use?

I am connecting the Lexicon Omega to the computer with the USB port. For now, I am connecting one microphone to Mic 1 one electric guitar to the instrument input on the front of the Omega interface, which maps to line 3. These inputs appear as Lexicon Win USB 1-2 In/Out (1) and Lexicon Win USB 1-2 In/Out (2) (not sure if this is really on input with a number added or really 2 inputs) in Cubase 8. There is also an option USB 3-4 In (no out).

I can only choose one of either use USB 1-2 In/Out or USB 3-4 In, but I can’t use both 1-2 and 3-4. I am Assigning USB 1-2 on the Lexicon interface for both the microphone and the guitar (which I believe is required for the instrument). If I put the mic on 3-4 I cannot choose both 1-2 and 3-4 in Cubase VST Connection configuration.

Anyone have an idea what I might try or be missing, other than by new equipment? I also tried downloading Audacity and I seem to have the same issue with all signals going to the same input bus, though I do not know Audacity software either.

Thank you for taking the time to read about my problem, I will be grateful to hear from someone with a good idea.

Please use the drivers for your audio interface, which in this case is the Omega driver.

To add more inputs, you have to press F4 and add more input buses. Have you done that yet?

The manual for this interface explains how to use it with Cubase:

Thank you, yes, I did the configuration as described. I did add the two separate inputs. The microphone to a mono bus using the port for line 1 (microphone) and the guitar to a separate mono bus using port for line 3 (guitar in the instrument input on Omega). I added 2 tracks to my projects. In the inspector I assigned the microphone track to use the Omega device port for the microphone and the guitar track to use the Omega device port for the guitar. Both input busses display in the mixer (microphone and guitar) as expected, but the input signal for the guitar and for the microphone both send to the input bus for the microphone when recording. I would expect the signals to be directed to their respective input busses.

I figured it out, seems all I had to do was to assign the microphone to use bus 3-4. All is well, thank you.