Connecting Yamaha YDP-142 to Cubase for recording


I’m sorry if this is not the right place to post this question. I also searched the forum for possible solutions but I couldn’t solve my question. I have a Yamah YDP-142 and I want to connect it to my laptop for recording. The piano gets connected to the laptop via an A-B USB connector. The laptop recognized the piano and installed the required drivers from the Internet, but I couldn’t get Cubase to record what I’m playing on the piano. My first question is, do I need any other sound card or something to record? And the second question is, how can I record the song? Any help is highly appreciated! :slight_smile:

You really need to supply some more of your system and software specs to get a detailed answer but… I will assume you are using a version of Cubase 7.5 on a windows PC.

I don’t have your exact model keyboard but this procedure should hopefully get it going.

  1. With the Laptop started, CB not started, keyboard off… Connect the midi cable (AB/USB) to the proper connections.
    Hopefully you will hear windows recognize the device (keyboard) when you plug it in.
  2. Start CB
  3. Open a project or start a new project that has an “Instrument Track” (or midi track but use an Instrument Track for this try). Add the Instrument Track if you don’t already have one. Also make sure the project has a Stereo input/output channel(track).
  4. Highlight the instrument track and press the track number near the top left of the inspector to see the input routing (which should drop down and be visible when you press that track number button). Select “All MIDI Inputs”.
  5. Just below that choose the vst instrument you want to use. Choose Halion Sonic SE for this setup and choose any instrument (but choose GM 006 Electric Piano for this try). Don’t forget to activate the effect by pressing the button in the upper left of Halion. It needs to be blue colored.
  6. Turn on your keyboard
  7. Now the tricky part. The keyboard has to be set to send just the midi signal to your computer and not send the tone signal generated from your keyboard. To do that you need to set the “Local” control on the keyboard to “Off”. That means pressing a button or combination of buttons. The procedure to make this setting is found on page 2 of the “Midi Reference” manual for your keyboard. You really should refer to the “Computer-related Operations” manual and the “Midi Reference” manuals to become familiar with these things.
  8. Now press a keyboard key. Hopefully it is working and you can hear a delightful electric piano.

That’s it. Hope it is now working.

Regards. :sunglasses: