Constant Audio Dropouts, AMD Threadripper 3970x

Hi everyone,

I’ve recently discovered the article where Steinberg has said AMD Threadripper 3970x and 3990x are “not recommended” for use at this time. Unfortunately, this article came out fairly recently, and I built my new PC using an AMD Threadripper 3970x over a year ago now…

I’m constantly getting audio dropouts from the likes of Omnisphere, Keyscape, Dune3, and even heavier Kontakt Instruments (Output is horrid)! Simple playback in Cubase at 256 buffer is SUPER bad, and if I raise the buffer to 512/1024, it only mildly fixes the problem. The biggest concern I have is that under Task Manager, my CPU is at 4% utilization total when these dropouts occur! Pretty ridiculous. If I switch the graph to “Logical Processors” I can see CPU 63 is basically pegged between mid80’s percentage and 99%. The rest are floating comfortably between 0-9%.

Virtualization = Disabled
*Hyper-V support = Yes

Does anyone have any suggestions as to what things I could try?

Thank you so much - I’m about at wits end trying to figure out a “sweet-spot” for playback.

*I know Steinberg’s official recommendation is to have Hyperthreading on, but I’ve heard some folks say that turning off SMT/Hyperthreading has worked better for them.

I don’t know about those specific CPUs, but AMD had some bad history with USB ports.
Maybe you could try with different USB ports? What mobo model# are you using?
You did not mention your audio interface, or even if you are using any.
You could make a test without any audio interface (asio4all) to check if it solves the issue?

On another track:
Can you reduce the number of active cores in your BIOS setup?

imo, and I’ve built my own rigs this sounds more like a harddrive/soundcard issue. only because you mention those vst’s which are notorious.
Please add your system specs incl HDD/SDD and your audiocard.

Considering that the AMD ZEN3 Threadripper will be my next build I’d like to make sure that’s where the blame is…lol

I just have a Ryzen 7 3700X/X470 combo and experience no drop out of any kind, using a 256 samples latency (RME USB2 driver, system working at 44.1 kHz). OK, my projects are usually rather small but I do use VSTis such as BFD3, Emulator X or alchemy, among others…

So, the first thing that comes to mind is that something (a setting in the BIOS/UEFI or in Windows, an added real time adapter working in the background) is crippling the audio capability of your system : it could be the power management, the USB one, wi-fi, added adapters, etc. The first thing I would do is to test my system with Latencymon and see the results (it would also be interesting to see them here, as a screenshot).

Yeah, try turning it off. If I were you and was stuck in that situation I’d rather turn it off and run ‘only’ 32 threads at a time on one core each than sell/build new.

Hopefully someone solves whatever the issue is. I would guess it involves software more than hardware, i.e. either Steinberg or Microsoft has to change something.

Well Ryzen is a slightly different topology even though the actual cores are the same so they don’t really compare.

1 Like

I don’t have an audio interface plugged into a USB port.

My Motherboard is a Gigabyte TRX40 Designare rev 1.0

My audio interface is an HD MADI card (PCIE internal). Aiso4all crashes my computer, so I don’t use that driver.

System specs are as follows:

Win 10, latest build.
Cubase 10.5.20
RME HD MADI interface
In terms of drives, they’re m.2 for a boot drive, m.2 for a “Cubase Projects” drive.

Steinberg says the Threadripper is a different architecture entirely in terms of CPU development, its just a shame that they waited this long to say something about it. Evidently, they’re testing it as we speak. Currently not recommended, but I’ve had this system built for over a year.

1 Like

Yeah, unfortunately this is apples and oranges because our architectures are entirely different (or so they say). The Threadripper is just a beast with 32 or 64 cores, and Cubase doesn’t know how to handle it. Just great to have a behemoth of a system and it’s choking on software.

I’ll run Latencymon here in the next couple of days and see what it yields and post the results here. Any tips or tricks with what to have running or what I need to have open when I run Latencymon?

1 Like

AFAIK, and I have used LatencyMon recently in its 7.00 version, as I have a recurring problem with my driver at 128 samples latency which I can’t explain, the test should be done idle (IOW, no other program opened beside LatencyMon itself).

And yes, it would be interesting to see what a threadripper based system delivers with it.

1 Like

Do you have an nvidia GPU?

1 Like

I downloaded LatencyMon last night and let it run all night. I’ve attached screenshots of my results!

I’d be curious to see what others think…

I sure do…Nvidia GeForce RTX 2070 Super.

…but I’d be happy to get rid of it if you know about issues caused with those cards (see the LatencyMon results above for the driver attached to my Nvidia) . Do you know something specifically related to Nvidia and how it behaves with Cubase/AMD Threadripper(s)?

Right Eric this stuff is a minefield but I had the same issue with dropouts and very similar Latencymon results as you. The following fixed it for me but don’t get your hopes up!

Run the nvidia control panel.
In Manage3D Settings go to the Program Settings tab.
Click Add. Filter by Recently used and scroll down to find your Cubase file.
In the settings for this program list go to Power management mode and set it to Prefer Maximum Performance.
Apply it.

Reboot, cross fingers.

I don’t have a Thread ripper but a Ryzen 3950.
This seems to be common with AMD cpu’s and nvidia cards.


Thanks so much, R - I did this fix and Omnisphere is still giving me dropouts, believe it or not. My hopes weren’t high, but I’m still pretty sad over here.

I will say, I’ve noticed that when the Omnisphere midi track is selected (record enabled obviously), Cubase is really jumpy and is a bit sporadic. When clicked off of the track (and therefore the Rack instrument in the VST Instruments panel), it’s a bit smoother. Same thing with Keyscape, so it certainly seems like a Spectrasonics issue at first glance.

Then (unfortunately)…I’ll get the same jumpy-ness in a heavy Kontakt as well (Audio Imperia, Output, etc.) - the only fix I’ve found so far is to lay down a part as filler, freeze it, and move on. Obviously this is a terrible workaround because if I need to change the midi part, I have to unfreeze, re-freeze, etc.

My guess is Cubase has some bug when you have more than 32 threads.
Might be they stuff a bitmask into a uint32 or something, and then you run a 48-thread or 64-thread CPU, and, whoops! They don’t all fit. Bugs ensue.

If you have the ability to halve the number of threads, by turning off hyper-threading, or turning down the number of cores in the BIOS, I would highly recommend trying this. If you can get the number to 32 or 24, it could work just fine, and the loss of hyperthreading is like a 15% loss, not a 50% loss in overall performance of the system. (Somewhat depending on workload specifics.)

1 Like

OK. There is a problem with your setup, as the comment on top is more or less suggesting it. FWIW, here is the one I made three days ago (from which, my latency problem with the RME driver is somewhere else…). Sure, I didn’t let it run as long as you, far from it, but everything was already stable something like 20 seconds after having launched it :

I guess that you tested it idle. if so, your ‘pagefault’ count is enormous, compared to mine, so something is obviously taxing the ability of your system to processs audio in real time, and it’s probably your graphic card : the very little amount I got on this criteria was 80% due to radeonsoftware.exe (directly related to mine).

I remember when hyperthreading and turbo and all these other settings used to wreak havoc in DAW’s when they were 1st implemented. Since it’s threadripper check the BIOS for anything that may be on and influencing the system.
Also, mobo bios updates…etc.

People used to pull out their hair when Steinberg’s solution a few times was to turn off multiprocess or power scheme because certain DAWs would just not work right.
Just throwing stuff out there cause you never know.

I just wanted to chime in again. I braved the BIOS and found where to turn of SMT and…


Night and freaking day. I suggest anyone with a 3970x / 3990x turn off SMT as well. The peaks at 256 are negligible, and I haven’t had any dropouts (someone knock on wood for me).

Thank you everyone for the suggestions and Latency Mon, etc. I’m going to run it again after I’ve finished today and repost the results tomorrow to see if they’ve changed now that SMT is off.


In Cubase 12 there are now changes to high core-count CPUs, TR is mentioned…

Just fyi…