Constrain Delay Compensation gives more punch in my drums

Hi

I’m wondering what happens exactly when you turn on the Constrain Delay Compensation?
When I do here in my studio, the sound gets louder, and it happens although I don’t have plugs in the signal path to the output.
It also seem as if my drums (BFD3) gets much punchyer :wink:
Anyone have an explanation?

Hi

It disables plugins that are causing latency.

You set the limit in preferences. I think it’s 0 samples by default. Once you click Constrain delay compensation, it disables all plugins that have proccessing latency higher than your limit.

It probably sounds different, because your compressor, saturation or whatever plugin have been bypassed.

Hi
This is the funny thing, there are no indication of anything beeing bypassed, but it definitely sounds different.

Hi.
Not bypassed they are disabled.It is quite different.When you bypass the indicator turns from white to yellow.When you manually disable it you will see it stays white.Same with delay compensation when you press it the indicator saty white so you will not see at first look any difference.
Test it.

Hello
Weird one this - i cant find the Constrain Delay button??? its normally up by the top left next to activate project button but mine isn’t there in CUBASE 8.0.10. i use this button often when tracking midi drums hmmm anyone know where the mystery button is?

Hi Pliktro

Yes I have been sitting watching the indicators when I press the Constrain Delay Compensation (CDC)
I have tested the mixer thoroughly and I found only a few channels where the plugs was disabled. Whether it’s disabled or bypassed the sound should be the same right?
Nevertheless the level of the output is about 2 to 3 db louder when I engage CDC, and that is with NO plugs in the output chain! :wink:

Maybe you have to right click the tool bar and select it to make it appear?

Nevertheless the level of the output is about 2 to 3 db louder when I engage CDC, and that is with NO plugs in the output chain!

Do you use control room?..maybe you have one hidden away in the control room inserts??

Aloha m,

Very nice explanation. Tanx for that.
{’-’}

Hi there,

just something to add to that: It only disables the latency inducing plugins on record armed tracks and their whole signal path (FX tracks, Groups tracks, etc.) all the way to the master output bus.

All other plugins that induce latency but are inserted on tracks where no real time signal is being processed, will not be disabled by the CDC.

Hope this helps

Hello Steinberg et al.,

hate to disapprove, but in cubase 8.0.10 this is unfortunately not valid for all tracks! All plugins inducing latency are disabled when pressing “constrain delay compensation” in the main window, not only the ones on the armed track but an all tracks. Only if you use AUDIO-tracks+plugins that induce latency this is valid, not for INSTRUMENT tracks. But why not for instrument tracks, as long as they aren’t record enabled it should work too - but it doesn’t. are you sure your quiet good idea of disabeling only the latency-inducing-plugs on the armed track works also for instrument tracks and not only for audio tracks? what settings do we need to make in order to achieve that? Thanks in advance for clarification!


just something to add to that: It only disables the latency inducing plugins on record armed tracks and their whole signal path (FX tracks, Groups tracks, etc.) all the way to the master output bus.

But seems like plugs on groups and Master are always disabled…regardless of any track being armed. Is this correct?

Hi there,

actually all plugins that are being used in tracks that are in “Real time” mode, e.g. when record armed, will be disabled. I’m not entirely sure about Instrument tracks though, on my previous post I was referring solely to audio tracks. But I will find out and post back.

Regards

Hi guys,

so the info I received from our dev is that CDC always acts on Instrument tracks, but not on the instruments themselves.

Hope this helps!

Dear Steinberg,

could you please clarify this, because to me it is not understandable and not reproducible.

It was suggested, that the nice behavior of using cdc on unarmed tracks does still use the inserted plugs without bypassing them. This sounds very good in theory but seems ONLY to work on audio tracks.
When pressing the CDC-button on a instrument track - be it instrument track or instrument in the rack with a corresponding midi track, i disarm the midi-track or instrument track (or arm another track), the used inserts get bypassed - bad behavior. Unlike audio tracks, when doing that there, they DONT get bypassed, because the track is not armed- very good behavior :slight_smile: So the intended behavior ONLY seems to work for audio tracks.

So what does it mean, that “CDC acts on instrument tracks but not on the instruments themselves”? Are there any VST-Instruments that have latency themselves?

Summary: CDC behaves differently on audio and instrument tracks - unfortunately. It works very well on audio tracks, where when a track is not armed the inserts still stay active/not bypassed - which is highly desirable that way! On Instrument tracks inserts are always bypassed/switched off, even though the track is not armed. Wouldn’t it make sense to instrument tracks to behave nicely as audio tracks do with regard to the CDC function and arming? Is that technically difficult to do or just something that hasn’t been thought through yet? :wink: maybe in the next version? should i file a issue or request or what would be the correct approach to enable that function? :slight_smile:

Kind regards

Steve