Controller chatter on faders

I just added an X-Touch controller, wondering if anyone else using Mackies or other control surfaces with physical faders is encountering this.

Whether I play back automation or am moving VCA faders to control children in real time, the automated faders chatter as they move, i.e. instead of a smooth motion they jump in tiny increments.

I watched a number of videos before buying the Xtouch and don’t recall seeing this jittery behavior, so I’m wondering if I just don’t have things set up properly.

Is anyone else experiencing this with their MC protocol controller (I’m in Cubase mode), and if so is there some sort of granularity setting or other such thing I’m missing to keep the control surface faders from being so jittery?



I don’t think that should be happening. I don’t use X-Touch, but QconPro that uses MCU.

The vibrating of pots has happened for me in the past. The issue I experienced was very specific parameters where Qcon couldn’t “decide” on which parameter to land, therefore the pot vibrates until you touch it.

I think you are saying it vibrates or chatters while continuously moving from point A to B? That shouldn’t happen.

The solution was a firmware roll back on the Qcon which solved the problem. I highly doubt this is normal behavior on the X touch or X touch-Cubase users would be screaming.

You have selected Devices>mackie control then either Cubase or Compatibility mode. That should make no difference regarding a vibration issue, but I believe you get additional features from your controller when in Cubase mode. The drawback of Cubase mode, at least on the QconPro is a few button commands don’t work quite like they indicate on the QconPro, but there are shift functions that achieve the same.

I assume you have read the Cubase Remote Control Devices pdf that explains how to set things up, plus setting up the remote control editor for every VST? I have never experienced a new VST where I didn’t have to change the controls in the remote control editor…usually due to long parameter names.

I don’t think there are any additional options in Cubase other than what is mentioned above.

I would also ask at gearslutz. There are lots of XTouch users there.

Thanks, man. Yeah, I went down the laundry list of stuff on setup. I’ve posted on the Behringer site. No real answers there as yet but I just posted today, and it’s Sunday. I should really get on gearlutz, don’t know why I’ve never gotten around to it as it’s a great resource.

By the way, thanks for the remote control editor mention. I’ve never had a control surface before with scribble strips so that wasn’t even on my radar and I didn’t realize you could change the parameter names. That’s going to be a huge help in readability. Much appreciated. Always more to learn about this stuff.

Without editing the parameters, its a huge useless mess. The problem is the old Mackie protocol that only allows 6 readable characters assuming you want 1 space between tracks. 6 isn’t nearly enough, so get used to doing a lot of abbreviations.

The other huge issue for myself is that when using the mouse to select a channel…for example channel 1 on Cubase is selected, and you now with the mouse select channel 9 on Cubase…the hardware controller, since it’s in banks of 8, will not shift to the next bank. You have to do that manually. I’m assuming that is true for the X-Touch?

Yeah, the auto touch on the controller works like on any other MC device, but it has no clue what the mouse is doing.

I have a Mackie D8B mixer, which supports HUI on the far right 8 faders. I had given that a try, but you only get four channels in the readout. That, plus abbreviations, was clumsy enough. However, in my setup I have a qwerty keyboard / mouse centered on the monitor, and channel 24 of the mixer is a good foot to the left, meaning the first of 8 faders is almost two feet. Trying to go back and forth off and on center was more disruption than the benefit I got from HUI.

The Xtouch is small enough to fit in the center section between my keyboard and the back of the console, so I’m centered on my work and can easily glance up to see which 8 are current in Cubase. I have the Xtouch propped at about a 10 degree angle because the scribble strips are flush with the surface and otherwise you can’t read them.

Spent the first day today working on a song and getting a feel for the wheel. So very many things in the world of control surfaces could be improved, but this is still an improvement on the previous setup, so I’ll take the win. That, and the fact that the first one I was eyeing was the SSL Nucleus. Very nice. Also $6k versus $600. I have some SSL pres which are definitely worth it, but for a control surface? I think the Xtouch will do. :slight_smile:

Did you do the firmware update?

Thanks, forgot to mention that. Yeah, I updated to v15, which is their latest & greatest.

Well I just checked mine again – and yes depending on how fast you move the VCA there is some chatter

Thanks, Max. I appreciate you checking.

Behringer’s claim to fame is bang for the buck, not quality. A Mackie Control runs $1100. The X-Touch is $600. If they cheaped out a bit on fader motors (or engineering effort to do a better job) in the service of a more affordable unit, I can live with the tradeoff. Overall it’s still a very cool contraption.

By the way, which button do you use for Shift, and does it work? Mine doesn’t, so I’m not able to use any of the Shift + Button functionality (e.g. mapping F keys to Shift+F1, etc). I’m sure I’m just missing something, but I can’t figure out what.

I just looked through the regular manual as well as the remote control pdf and I can’t seem to find the section where it talks about editing vst parameter names. Could you point me to the right place in the documentation so I can read up on it?

This is done in Cubase.

Select any VST.

Upper right corner click on the square and it drops down with lots of options.

Choose Remote Control Editor.

Now you already have names of every parameter but probably need to change them due to the character length. Click learn. Then double click over the parameter name just like you would when re-naming a track. The Behringer should reflect what you just typed.

Excellent, thanks! Just brought up a plugin and that couldn’t be easier.

Are these changes stored in the file system somewhere (I’m in Windows 7) so that I can do it on one machine and just copy the configurations over to the other one, or do you have to do it manually on each box?

This is good to have on hand.

c/user/user name/documents/vst xml/ =where its stored. you should also have a steinberg folder in there for the steinberg factory VST’s.

Bookmarked, many thanks. I’ve used that before but couldn’t remember where it was.

Once I get through updating all the plugins things are going to be that much cooler. Now if I could just get the freakin’ Shift button to work on the X-Touch I’d be all set.

Thanks for all the help, man. Much appreciated.

I I have been unable to get the shift working – I have been able to program the function keys however

I think I have everything shifty working that will work. Here’s what I’ve learned thus far.

I can map to F keys, but not Shift + F. My understanding is that this has been a Cubase bug with MCU in the past, so perhaps it’s a holdover of this problem.

I finally got Cues working. The confusing thing on the xtouch is that there is a Send button at the top, but the Trim button is also mapped to Send. I was trying to use the top button for sends, which in fact doesn’t bring up levels but rather the send edit pages. So, Shift + the top Send didn’t bring up Cues. Pressing Trim brings up the send levels, so Shift + Trim brings up Cue sends (FX Send for sends, FX Studio for cues, on the display).

With the exception of the F keys, I think Shift is working as expected now. If you have specific Shift scenarios where it’s not working for you, I’ll test on mine and see if we can get it sorted out.

Hmmm that’s weird because my setup trim deletes the current track!

I was also disappointed with the scribble strips - and was wondering if it would be possible to use prisms so that I could lay the unit flat and still read the strips…

I’m using the Cubase mode for the MCU setup. Maybe you’re using the legacy setting? Can’t think of any other reason we’d get different results.

Yeah, they’re useless unless you look at them head on. That would have been a deal breaker for me if I hadn’t found a workaround.

What I did was mount it so that it’s at about a 15 degree angle, which allows me to read the strips. That worked for me, don’t know if that kind of solution would work for your environment.