Controller, quick controls, mackie and more- issue

Hey everybody.

I’m having an issue with a few of my midi controllers.
I run a NanoKontrol2 and it’s setup as Mackie Control just fine and it allows transport control. But it also wants to dominantly control the first 8 faders of the mixer and the pan, how can I get rid of that? if I want to use those specifically for quick control.

Also, I added a Doepfer Pocket Dial controller and set that up correct to run my 8 quick controls for VST’s, but that creates a problem, because if I set quick control 1 of say NI Massive Macro 1 it will control that just fine.
But if I then go to another synth and want quick control 1 there to control some other thing then it automatically names it like the Massive one and will now control the old one.
Meaning that if I go to whatever synth and touch my controller, it will controll CC on the Massive synth, which is definitely unintended.

How can I get rid of that ? so that it just controls QC and CC’s on the track currently active?
Been looking up a lot of videos and forums about NanoKontrol2 and there are several issues with Cubase on that one, but apparently only to get it up and running in the first place, not on specific knob and fader setup.

The problem with the way that the NanoKontrol2 runs right now is that it automatically controls the first 8 faders and pans, now if I had just as many faders and knobs as I would have channels in Cubase then cool, but that’s simply not the case. and I would very much like to use the NanoKontrol to control my VST Quick Controls and use the transport option as well.

Anyway, any help is appreciated as this is driving me nuts and I was hoping for a much easier way to control all this instead of (as I have done for years) manually drawing my automation.


If you don’t want to use your NanoKontrol as a full Mackie Control, remove the Mackie Control Device from the Remote Devices folder. And then use Generic Remote to map the Transport buttons.

There are 2 different Quick Controls: Track, and VSTi. If you want to use VSTi Quick Controls, make sure, the right VSTi is selected in the VST Instruments Rack, while sending the MIDI data.

Myself, I prefer to use Track Quick Controls over VSTi Quick Controls.

Let me try out that generic setup instead. :slight_smile: Thanks.
But I’m curious as to why the VSTi controls, suddenly take over the normal track controls and still affect the VSTi when a different track is selected.

Is the VSTi (the new one) selected in the VST Instrument Rack?


If I add another VSTi and select that one, then it’s like this specific knob eternally controls that parameter on the first VSTi.

Also, If I do the generic remote thing I get a problem that I previously had when controlling both QC and Mackie, that it only fades at either 0 or 127, nothing in between.
So all channels suddenly become on / off switches with the nanoKontrol2,

I’m sorry, I still didn’t get the answer… Is the instrument selected in the VST Instrument Rack? There is a white frame in it.

I haven’t selected it anywhere.

by instrument rack, you the F11 VST Instrument list where I can add and remove instruments?

Just by testing it out right now, I noticed a small bottom right icon in the list of used instruments and the rack instruments (what is the difference between a track and a rack instrument anyway?)

But this Icon says “quick control focus”.
Which will definitely explain.

But this seems counter intuitive to me, aren’t I supposed to click any track and the controls will then be for that track, as well as any instrument track?
To me that kind of removes the purpose of quick controls really.

Ok, so now I got it working with the Doepfer Pocket Dial only controlling VSTi QC’s. Found out that if I want to use the same controller for just normal QC, then if I only have ONE VSTi running in either track or rack, then that one will never disable when I switch a different track, but work fine if I run more than one VSTi.

Now I’m just stuck with the nanoKontrol2, which again only does 0 or 127 values on the fader in regular QC’s.
Takes quite a bit of trial and error this thing. It’s fun as I’m exploring parts of Cubase that I haven’t gotten into yet so it’s cool, just time consuming.

The reason why this bothers me so much is that our composer, who runs Logic, had a nanoKontrol2 and that was really just plug and play and it did as expected on every parameter, and I’m not switching to Logic - but I do find it annoying with my favorite love-hate relationship with Cubase shows :smiley:

Are you sure, your nanoKontrol 2 sends Continual data?

What parameter do you want to control?

It works fine if I use it as a mackie control and fades on the channels.

I have just been testing it out with controlling QC 1 which I then assigned to Volume / fader of the channel, I did also try to assign it to front / back pan of the 5.1 mix which did the same result.

let me check some of the nanoKontrol2’s setup, you may be on to something with the continuous data, though also not since it does as intended under mackie control.

If you kept your nanoKontrol in the default mode (Mackie Controls), the faders send PitchBend data. Maybe would be better to switch it to send MIDI CCs.

Couldn’t get that work, cubase for some reason always set the incoming parameters as “unknown”.
Anyway, decided to ditch the idea and switch it back to mackie control and use the doepfer pocket dial only as just a midi parameter controller so I can at least have some knobs to twist and turn and will then have to manully sync up on everything I need to control. But that really doesn’t seem like a hassle compared to my experience with setting up the QC’s anyway.

:slight_smile: Thanks for your help and the whole discussion, it did help a lot and made me dig into a few things that I hadn’t though of.

Massive props. :slight_smile: cheers.

What MIDI data do you send?

It’s set to just send CC. Tried changing the number, but same result.

Where is this set, please?