Converting Midi to Audio recovering soft parts

When I render midi to audio, sometimes the soft parts seem to not render all that well. For instance when I softly fade midi strings (fade in OR fade out), the louder parts seem to render just fine, but as the notes gets softer the sound seems to disappear after its rendered. The net effect is that I can still hear the note when I listen to the midi track, but the rendered version of that same track fades to silence much faster.

Would it be beneficial to increase the buffer size? Or switch to a higher resolution when rendering midi tracks? i.e., record in 44.1 but render to 48?

Almost all the replies I get in this forum are in a different language (Spanish or German) neither of which I read or understand. I really appreciate you taking the time to respond but unless it’s in English I can’t read it. Thanks

is there any chance you have one ore more note length extending audio plugins somewhere in your audio chain, but it’s not included in the rendering?

Especially dynamics type plugins (compressors etc.) can effectively extend notes to be louder for longer. On lush strings, recorded with lots of room ambience even a reverb may end up not being obvious for being present - but it can extend the note.

Hi Nico5,
Thank you so much for taking the time to respond. I record strings with no effects whatsoever for that very reason. I even turn off the reverb on the plugins themselves so when I later add reverb they all sound like they are in the same room. I keep things very raw so I can get an accurate picture of what they really sound like before I render them. Although it’s a subtle difference it can mean the difference between a soft part being effective or not.

If I experienced something like this, I would create an empty test project and compare the levels of a rendered vs a non-rendered instrument. This is to rule out any other potential causes.


Would not make any difference in this case.

1 Like