Converting time signature

Hello folks

There’s probably a very simple way to do this and I’m just being dense…

I’m writing an orchestral part in 6/8 and I’m suddenly realising it should probably be, at least for the current section, in 4/4.
But if I just change the time signature obviously the notation will all go wrong.
At the moment the phrasing is mainly made of dotted crotchets and quavers, whereas I need to convert it so that its crotchets and quaver triplets.

What’s the best way to do this?

Sorry for the dumb question. Any help very welcome!


First, making sure that all tracks are in Musical Timebase, and that any audio clips are set to Musical Mode in the Pool (with the correct initial tempo), change your time signature at the desired measure, then, at that same position, insert a tempo event that is 2/3 of the first tempo (e.g. if your tempo when in 6/8 was 120 BPM, change it to 80 BPM when in 4/4).
Don’t forget to set the Score Display Quantize to show 8ths triplets during that 4/4 section :wink:
8th Triplets.jpg

Thanks Vic

This is right from the start of the track, so you’re saying I just need to set Musical Mode, change the time signature and tempo from the start of the piece?
I’m away from my PC so can’t try it right now, but won’t this just make the playback sound identical but the notation go all skewed? It won’t convert a dotted crotched to a straight crotchet… or will it?

Two different possibilities (and I think it will in fact be the 2nd that is correct for what you want to do :wink: )…

  1. In the screenshot I posted above, I had first built a 4 bar MIDI Part of 8th-notes in 6/8, then I built a 2nd MIDI Part of 8th-note triplets, starting at bar 5, in 4/4. I then performed the timesig and tempo changes that I described, at the start of the 5th bar. As you can see from the screenshot, it looks correct, and also plays identically from bar 1 to bar 9 :wink:.

  2. If I had simply duplicated the first MIDI Part (so the 2nd section is still 8th-notes, not 8th triplets), then the only difference is that the MIDI tracks should not be in Musical Timebase, but Linear Timebase, and Musical Mode should be “Off” for the audio clips, before making changes to the timesig and tempo tracks.

So, seeing as how you want to make the change at the very beginning, simply switch all tracks to Linear Timebase, and Musical Mode “Off” for audio clips, just change the timesig to 4/4 and change the tempo to 2/3 of its original value.

In the Process Bars Dialog there is also an option to “Reinterpret Bars”.
Just convert the 6/8 to 4/4. Set the range parameter accordingly and the program should do the rest.

Hi Werner,
I did try that, and the results were, to say the least… wrong! :wink:

(Maybe I set “Interpret Bars” wrongly?)… originally, bars 1-5 in 6/8, bars 5 to end in 4/4, so i set as follows… (NB. Bars 1-5 were indeed in 6/8… i just reopened the Reinterpret Bars dialog after conversion, to show its setting :wink: )
Tempo Track.jpg
Instead of setting tempo at 80BMP, it set as 160 BPM, and with a strange added event at bar #4.
The Score was therefore wrong (see next attachment, and, even worse, it re-interpreted everything after the start of bar 5 also (therefore destroying that!)
Please compare this screenshot with my original screenshot earlier…