Copy Hidden Signposts


Would there be a way to copy hidden signposts? This is mostly for tuplets. If not, make the banners much less intrusive. When you have a complex piano piece with many tuplets hidden, it can get very difficult/tedious to be constantly hiding and unhiding the banners in order to work properly.



We do not plan to change the program such that hidden signposts will be selected and copied/pasted, I’m afraid. I will look into making it possible to show/hide particular signposts using a key command, which is unfortunately not currently possible.

Thanks for the reply, Daniel. What is the reasoning behind not being able to copy a hidden tuplet?

You can only copy things that you can select. When you hide a tuplet, we show the signpost precisely so that you can still copy the tuplet even though it is hidden. There are use cases that involve both copying the notes within the tuplet without the tuplet itself, and those that involve copying the tuplet as well as the enclosed notes, so it’s important that you can achieve both. If you want to copy hidden tuplets, then keep the signposts visible.

Makes sense. Maybe it’s that I’m copying a complex Rachmaninoff piece and having the banners visible makes everything very cluttered. Hopefully when I’m writing simpler stuff this won’t be a problem.

I’ve also had trouble copy/pasting a nested tuplet. Any suggestions with that?

Provided you have all levels of the tuplet selected when you copy, you should find it works out OK. If you have an example that doesn’t work properly, please attach an example here.

Here is the file. Can’t seem to copy the nested septuplet on page 6 even with the signposts on. Everything else copies.

If copying hidden tuplets is not an option, might I suggest less intrusive signposts? Maybe it’s that this is the first piece I enter on Dorico, and it’s definitely not representative of the music I usually input (band arrangement, lead-sheets, orchestral music) but I find it somewhat difficult to navigate around the signposts without having to constantly hide/view them.

Etude-Tableau (326 KB)

I was able to copy it. You need to select the 7, the 3, the beam in both tuplets so all the notes are selected and then do the copy.

See the image for the selection and the result copied tuplet in the last bar.

Maybe it’s a Windows problem? I can’t seem to copy it. I’ve clicked on every note and tuplet individually, selected the whole bar, selected just the tuplets and it’s nested tuplets, but nothing seems to work.

Okay, it seems to be a problem copying to that particular bar. I tried copying to another bar and it worked. Just a minor glitch.

On another note:

Sometimes I click the 1st or last note of a voice and it doesn’t let me enable Starts/End voice. Is there a particular way to have it enabled? For me it works whenever it want’s, not following any logical reasoning behind it. Might be the piece I’m copying is fairly complicated, but I don’t think that should affect it.

Just added 10 measures at the end of that page and the bass clef has nothing in it. I can input, but I cant select anything on it before inputting.

I agree that start and end voice buttons act confusing at times. I have resorted to only using remove rests from the edit menu. Has worked in every case I care about so far.

On you 10 bars with no rests showing it’s likely that the end voice is turned on for that staff. You can turn it off to get the rests to show up again. Or you can just try to enter some music in those bars and it will work as expected.

Thanks. I’ve also resorted to using the remove rests, but then I have no means of adding them back if I need them.

Will check out about the end voice. I did add some music and the rests appeared again.

To restore rests you have removed, find the last visible note or rest in the voice in question, and switch off the ‘Ends voice’ property.