Copy Paste - buggy behaviour

Hello, I still have a strange behaviour with the latest update 4.0.31.
If I select a passage, then copy, after I release the keys, everything gets selected.
If I - despite of what happens - paste the content of my clipboard, I get this (this must be from another piece I did the other day):

If I - instead of using the CMD-C shortcut - go to the Edit menu and choose the Copy command from there, behaviour is normal - as expected.
I experimented with Undo, CMD-Z. It seems, once I have used the Edit Menu command, somehow some cache got cleared - as the program works fine now.

1 Like

Yesterday I got Select All repeatedly when I typed ⌘1 for Setup Mode. I tried changing some other things and soon the keyboard command worked again. A couple of weeks ago it was, briefly, ⌘8 for Properties that caused a Select All. That time I quit & relaunched Dorico to solve it. I haven’t been able to find the common thread yet. It does seem quite elusive.

yes, I had other Select-All incidences too. There is still something awkward going on under the hood. It’s not that tragic, but quite surprising…
I am not 100% sure, but with me it might relate to the computer I am using. MacBook Pro=strange behaviour, older MacMini at home = ok. But I might be mistaken. Both computers are on older macOS (10.14.6) for certain reasons, if that plays into it.

FWIW I’m also on a MacBook Pro, 2018, MacOS 10.14.

I had the problem on my 16" 2019 MacBook Pro. I’ve had been working quite a lot on a score, so maybe it’s got to do with buffer overload… Had to quit and restart. The esc key would select all :scream:

Is this only occurring on Mac computers?

It seems so, though of course testing and reporting on other hardware is always useful.

At least it’s not disastrous; you can just deselect and try again, etc.

Here’s a different odd behavior:
I highlight with my pointer, the part I want copied.

Then I copy with Cmd-C, after which I choose where I want this section pasted:

Finally I use Cmd-V, or Paste from the pulldown menu, and this is what I get:

I don’t have this issue with other projects so far, and I don’t know what I’m doing wrong.
Here is the file copy and the diagnostics report, in case anyone can use it to figure out what’s going on:
Just Thinking About Peace v.02.1.dorico (1.1 MB)
Dorico (1.6 MB)
Thank you.

The following method worked for me.
After highlighting the notes to be copied, I chose Edit > Notations > Cross Staff > Reset to Original Staff, then copied the notes and pasted them in the manner you described.

Maybe of interest to the Dorico team if they investigate this odd behaviour - when I followed your steps exactly then clicked on a note in the pasted voice, the sound was that of the player selected for pasting. For example, if I had chosen the Oboe staff as the target for the paste operation, the pasted notes sounded like an oboe, even though they had ended up being pasted into the piano staff. Those notes also showed up as being in Up-stem Voice 1.

I’m getting similar issues. Has @dspreadbury confirmed it?

Looks like your suggestion help fix the problem.
Thank you so much for your help.
I need to remember what I did that caused this.
Sincerely, thank you.

This issue has been bugging me, and haven’t seen anyone from Dorico team responding on the thread, so bumping it to @dspreadbury and @Ulf . Thanks!

dyross, I am also a contributor to this thread, but, believe me, bumping a thread is pretty useless (and impolite) - as everything has been read by the developers anyway…

1 Like

Fair enough, not trying to be impolite.

Was just surprised not to see response on a pretty clear bug in pretty standard functionality.

Just wondering… instead of selecting that rest before pasting, have you tried invoking the caret at that place? I think I didn’t aswer that the first time I read your post because I assumed someone else would suggest you just that. Everytime you feel some content is not on the staff on which it should be, the caret is the answer (I’m thinking 8va lines on cross-staff material, for instance).

[Edit] I was baffled by the behavior on the oboe line (no rests, as if the paste thing were a cross staff phrase) so I tried your file in 4.1. The behavior is no longer what you’ve shown, so the team has probably resolved this bug in 4.1. You probably should update :wink:
I notice that in page 17 of Version History document for 4.1, there are several issues that have been resolved and were about pasting. Although I don’t know how they are linked to what your file exhibits, a simple test shows it now works as expected.

using the example score, if I do as @algae592009 does and either highlight the first note of the sequence or double-click to enter the caret and then paste at that position, then it works perfectly. However, if I use the system track to copy everything and try the same, the result is that the music is overwritten with nothing at all as below:

Can anyone else reproduce? I have to say that when simply starting with an empty document, it works as expected – the problem is with “Just thinking about Peace”

The notes in @algae592009’s project have been crossed to the staff above, which of course has no visible effect, but which leaves things in a funny state. In the general case we obviously have to preserve this information when copying and pasting to other instruments (e.g. when copying from one piano to another). Even in some other cases where copying and pasting to multiple instruments held by the same player it would make sense to preserve that information. Obviously in this specific case it would be helpful to reset the cross-staff state automatically, but it’s non-trivial to do this for the above-stated reasons.

Hi again. I’m having copy/paste issues again in a piano & voice project.
Most of the flows are for piano alone, except for one that has a singer part. I’ve taken the singer part off all but that one flow.
After inputting the piano part, I started doing so with the singer part, but for some reason I can only get notes pasted by using the “Paste Special–>Paste Into Voice–>Up stem Voice 1”. In the words it’s a pain in the …
In any case, I’m using the latest version of Dorico Pro.
Has anyone also experienced this issue, lately?
Here’s a Diagnostics Report, in case that helps.
Dorico (915.5 KB)

Thank you for your time and consideration.

Unfortunately a diagnostic report won’t help here, but thank you for thinking to include it. We need to see the project itself, together with a set of steps that we should follow to reproduce the problem.

OK, here’s the project Sample.
It’s flow “La Randera Tucumana”
Here are the steps I’ve done to input singer melody:
1- copied a note from either the singer or piano part. (notes in singer part were added only by “Paste Special–>Paste Into Voice–>Up stem Voice 1”)
2- Selected the place I want the note to be pasted into.
3- I do Cmd+V to paste. (Nothing happens)
4- I try paste from the pulldown menu (Nothing happens)
5- I choose “Paste Special–>Paste Into Voice–>Up stem Voice 1”. Then and only then I get the note pasted into the place I need it.
Here’s the project:
Primer Album Musical Santiagueño Sample D4.3.11.dorico (1.7 MB)