Correct audio connections with Control room?

I’m using Sonarworks Reference plugin as an insert on the CR (which has made a big improvement, even in a treated room and Adam A2 monitors).

In “Studio” - “Audio connections” -“Control room” monitor one (I have only one) shows left-right connected to Raydat ADAT 1 & 2.
“Studio” - “Audio connections” -“Outputs” show as not connected. Is this the corrected configuration in my case? One problem I have in this case is that I can’t hear the click !

I can assign the same Raydat 1 & 2 to the outputs, which then allows me to hear the click, but that setting doesn’t get saved when quitting.

Any suggestions? Thanks in advance

Yes it’s correct.

Control room has it’s own click button to turn it on/off

If it’s correct with the outputs not connected (but control room yes), then why can’t I hear the click?

Do you have the click enabled (in control room) and volume turned up in control room?

https://steinberg.help/cubase_pro_artist/v9.5/en/cubase_nuendo/topics/control_room/control_room_channel_r.html

Many thanks, hadn’t seen the click button there in the control room!

Cheers!!