[Corrected -- not an issue] Cross-platform automation editing bug when more than one point is selected.

EDIT: NEVER MIND! I was used to the old way of working, and it turns out that when you move a multiple selection up or down by one of the nodes instead of trimming it, then it doesn’t create new points. It DOES create new points if you trim it up or down instead of dragging one of the nodes. This is a GREAT feature that incorporates the Trim tool in a great way that actually speeds up workflow. Well done, Steinberg, and please ignore this particular request here!


  1. Select two or more points on an automation line.
  2. Move all selected points up or down as a unit, and you will see that instead of only moving the selected points up an down, it also creates new additional automation points where the original ones were, which should only happen if you’re using the Trim Automation tool. I’m guessing it was accidentally implemented when the Trim Automation tool was introduced in 9.5.

Please see this, which clearly shows what I mean: View My Video

This is NOT using the trim tool, it’s something very different: This is selecting more than one automation points that already exist, and then moving those selected points up and down. It’s an issue that hurts workflow in a major way. Thanks for fixing!

I’m surprised nobody mentioned it until now. This thing is driving me crazy since day 1. I mean this clearly isn’t working as intended, it’s in plain sight and it wasn’t fixed in the testing phase? I’m starting to wonder if there was any actual testing, or we paid 60 euros for the “privilege” of being beta testers.

I’m also surprised others are not chiming in here, as well.

It looks like it mistakenly goes into “trim” mode. This is an incredibly important issue that needs to be fixed, so I’d like to see it become an official issue. Can that please happen, mods? The same thing happens on a fellow composer’s Windows version of C9.5, and also when I checked it out at C9.5 on Mac at Guitar Center yesterday, just to see.


I would like to see this either elevated to a certified issue, or reported that it’s being fixed – it’s a major issue with C9.5 that affects everyone.

Can’t reproduce this, functions here as expected…

Are you on Mac or Windows? I’ve tried it on three other Macs with 9.5 (two friends and one at Guitar center) and the problem was on all of them.

Can others here please try this and see if you experience the same issue? In a nutshell, it’s that the new Trim Automation function happens when it shouldn’t: When you select multiple points individually with the arrow tool and then move them at the same time, up or down.


that additional 2 points shouldnt happen on selection. Aslo they happen when using the little diamond to move a segment.

I’m on Windows 8.1 (as mentioned in signature)

Gotcha – for some dumb reason I didn’t look at your sig last night. :slight_smile:

But it looks like others on Windows are experiencing this, as well (see the post above, and I also just called another fellow composer that is on Windows who confirmed). I wonder why your system is not experiencing this specific issue? Weird. Could be a certain plugin that causes it in 9.5 now that the Trim Automation function has been implemented? Oy. That takes far too much time to test for than I have right now.

We need more users to check on this and report back on this thread, please – it’s a major workflow killer and needs to be fixed. If it’s not in your signature, please report what OS you’re using.

Did today some more experimenting with this. Wrong behaviour confirmed here too!
Don’t know why I didn’t experience this yesterday, was on another old project, but when I load this one now again it also has the wrong behaviour…

Waiting for a confirmation of the issue from Steinberg – it needs immediate attention, costs a large amount of time over a working day with tight deadlines!

Sorry to keep bringing this up, but it’s a deadly issue and is really costing me a lot of time. It’s definitely an issue that’s affecting other users (aside from the few who chose to respond here, I’ve had it confirmed on every other other Cubase user I personally know – four total, on both Mac and Windows) and at a nearby Guitar Center’s Cubase 9.5 that I tried – I just want to hear official acknowledgment of it and that the fix is coming very soon. I wrote to support but haven’t received a reply for days now.

Anthonie, could you edit your original response to say that you confirm the issue? I just want Steinberg to see that this a definite bug, without any doubt anywhere in the thread. :slight_smile: Thanks!

When you’ve selected your points, you click and drag on one of them, to adjust them all. That seems to work fine here and does what you want - with no new nodes made.

Its when you try to hover over the middle of your selection and drag up/down that the two ‘new’ nodes are produced at either end; that’s what I get here anyway.


Ahhhh…thanks so much for pointing that out, man.

That’s actually a great feature - I was used to working the old way. I edited my original post. :slight_smile:

Check out my corrected post, and the posts right above here. It was pointed out to me that it’s done a bit differently now, and I feel that it’s actually well-designed for less key clicks (you need to use the modifier key to keep the points from shifting left or right when you move using a node).