Corrupt files?

Anyone have tips on restoring corrupt files recorded in Cubase 6.05. There was an error message with firewire connection when saving an hour of recording through fireface 800. Had to save to a new project. The files are there, but blank in pool and zero in time. But have 587mb of information?! Any tips of how to get any information out of them?

Could be complicated. Better to contact support on this one.

You can undergo reincarnation by the time support gets back to you. First things first. Are the files there in the OS and can you play them with WMP or whatever?

No, cant play them in finder, iTunes, etc. They are aif 24/44.1. They are zero seconds but still 587 MB… I was told that wavelab could maybe reconstruct files? Anybody know about that…?

Doesn’t sound promising, does it? If you’re getting that time/size mismatch in the OS as well as the Cubase Pool then I suppose you’re in need of one of those little utilities people put up for fixing oddities like this. Perhaps your next step should be your browser…

Are you sure they are AIFF? Does Cubase record as AIFF in Mac? (been a long time since I recorded anything in Mac)

Anyway … maybe it’s time to do some detective work:

  • Open terminal
  • Go to folder containing these files
  • Use file utility to check files’ format
PHINEAS:~/Documents/tmp jtv$ file test.wav
test.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 24 bit, mono 44100 Hz
PHINEAS:~/Documents/tmp jtv$ file test.aif
test.aif: IFF data, AIFF audio

Post your results here.

You can also check file headers with od

PHINEAS:~/Documents/tmp jtv$ od -c test.wav | head -4
0000000    R   I   F   F   |   V   $  \0   W   A   V   E   f   m   t
0000020  020  \0  \0  \0 001  \0 001  \0   D 254  \0  \0 314 004 002  \0
0000040  003  \0 030  \0   d   a   t   a   X   V   $  \0  \0  \0  \0  \0
0000060   \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0  \0
PHINEAS:~/Documents/tmp jtv$ od -c test.aif | head -4
0000000    F   O   R   M  \0   $   V 220   A   I   F   F   C   O   M   M
0000020   \0  \0  \0 022  \0 001  \0  \f 034 310  \0 030   @ 016 254   D
0000040   \0  \0  \0  \0  \0  \0   A   N   N   O  \0  \0  \0 002  \0  \0
0000060    S   S   N   D  \0   $   V   `  \0  \0  \0  \0  \0  \0  \0  \0

And again post results. Maybe someone is able to give you more info about your problem.

IIRC, Wavelab can open an audio file that doesn’t contain proper header information, via a menu item that refers to the file as (something like) “raw” (sorry, can’t check now). (Again) IIRC, you have to specify details about the file format - 16/24 bit, etc, order of bytes, and so on - I suppose the thing to try first is a description that matches the files you’ve successfully recorded in Cubase. If it does actually open, save the file in the correct format.

Perhaps you could give that a try (using a copy of the odd audio file) - if it doesn’t work, ask on the Wavelab forum.

I think, if the file does open in Wavelab, it’s feasible that the start or end of the waveform could arise from non-audio data in the opened file, meaning that you might need to trim that away.

As Chase says, Wavelab will open -any- file and play it, dependent on the settings you give. I’ve had a couple of times when that’s saved corrupted files, so it’s worth a go. Just work on copies and you should get as much mileage as possible. I can’t see support being any help.

Just tried with a trial version of wavelab and was able to open a file, but with lots of distortion and noise which I am sure isnt from my signal path…,!? It looked like levels and content are messed up…? Anym tips of dealing with that?
Thanks for lots of good tips!

It’s possible you are hearing misaligned data. If you import 24-bit file with corrupted headers as a raw file, odds for getting it right is 1/3. You may try to re-align data with some binary editor… or with terminal:

$ echo -n "x" > new.wav
$ cat old.wav >> new.wav

This creates a new file where data is aligned one byte right. If still not ok, repeat:

$ echo -n "x" > secondattempt.wav
$ cat new.wav >> secondattempt.wav

If still not success, there’s 4 possibilitis:

  1. Data itself (not only headers) is corrupted, in which case you’re out of luck
  2. You are trying to open the file with improper bit-depth (file is 24bits and you try to open it as 16-bits or vice versa)
  3. You are trying to open file in wrong format (stereo<->mono, WAV<->AIFF, ect)
  4. File is not PCM audio data