Corrupted track names

Can anyone explain why Cubase Pro 13 has decided to corrupt my track names on my MacBook Pro? As you can see in the screen shot, the clips show the correct names, but the tracks and the mixer channels just show gobbledygook. Some other fields are also showing rubbish.

Looks like a font problem. What version of OSX?

I’m running macOS 12.7.2 … funny thing though, if I double click into the track name field to edit, the name appears perfectly correct. It’s only when I hit return that the rubbish font appears.

My main Cubase machine is an iMac … zero problem with that. The MacBook Pro is simply my travel tool. Nonetheless, frustrating …

Are you using some “unusual” language? It is just a guess since fonts are specific for different locales.

:grinning: … define ‘unusual’? No, all language settings are normal … English … well, Australian English. But it’s been harmless up till now.

There is a list of supported languages. Anything not there maybe?

Languages

User interface languages: Chinese, Russian, Portuguese, Japanese, Italian, French, German, Spanish, English

Documentation languages: English, French, German, Japanese, Italian, Spanish, Russian

If I look in OS preferences, and look at specific app languages, it shows Cubase 13 running ‘System Default: English’ … so that doesn’t seem like the issue.

Apparently, all Cubase UI items are also affected…
From which, I would try to relaunch Cubase in safe mode, using the Disable Program Preferences option.

If this still doesn’t work and you are not experiencing the same issue with other applications, I’m afraid that you are for a complete Cubase reinstallation…

1 Like

Thanks I’ll try that. Could it be a corrupted profile file, somewhere in the system? Because, I tried firing up my previous Cubase Pro 12 installation (which I hadn’t deleted), and the same problem appeared.

Well, blow me down … relaunching in SAFE and Disabling Program Preferences worked. And it sticks. Closed and reopened it, and problem has vanished.

Thank you both, Cubic13 and Cubace, for throwing yourselves at the problem.

Happy New Year to you both!!!

2 Likes

Experiencing the same issue. Thought that was a problem with me using a hackintosh but apparently not… The safe open trick doesn’t seem to work for me, I’ll try again with a computer reboot in between. Disabling gpu graphics is a showstopper as all the UI gets extremely laggy if I do so (like meters updating less than twice per second)…
My config is Intel 10900k/amd 6600xt…
I have a m1 pro as well gonna test there.