Count in uses previous measures tempo and timesignature

Hi,
I’ve been facing with this problem for a while.
I have many projects with varying tempo and time signature. When I try to use count in to record, cubase uses the tempo and time signature from the previous measure rather than using the current measures tempo and time signature. Im not able to find any settings to fix this. I’m starting to think this is some sort of a bug.
Any help on this would be appreciated.
Thank you.

There’s no simple way around this currently. It’s not a bug - having a count in that uses a different tempo and time signature to the music that’s recorded underneath would be very off-putting!

In most cases a simple click precount should be a good enough guide.

If it isn’t, then there’s two easy ways around this -

Either, use Global Insert to insert a couple of empty bars before your drop-in to use for a click, and then remove them afterwards.

Or, bounce a couple of bars of click to audio at the tempo you want, and put them before your drop-in point - use the snap function set to the end of the audio clip to make this a breeze.

Metronome Setup
https://steinberg.help/cubase_pro/v10/en/cubase_nuendo/topics/playback/playback_metronome_basics_tab_r.html

thanks for the reply.
I guess I didn’t go through the options in the metronome settings properly.
I had thought “Time Signature at Record Start Position” referred to the very beginning of the project.
I have set the setting to “Time Signature at Record Start Position” now and it works as intended.
before it was set to “Time Signature at Project Position”.

My bad for not reading it properly, sorry about that.
anyway thank u for taking the time to reply.