Couple of strange things happening in Cubase - ideas?

Working here in Cubase Pro 9 on a Win 10 64bit system. All is good but recently two things have happened that I can’t work out. Presumably I’ve changed a setting in Cubase somehow. Firstly when I’m in the key editor and either record some playing or use retrospective record, the new midi part appears in a new key editor window rather than being added to the old part as before. Quite annoying if you just want to add one note and then have to go back and merger the two parts. Second thing is that when I try to render in place one track from a multitimbral instrument like the UVI player I’m getting the part I want plus multiple blank audio tracks for any other channels in the instrument. Both these things are new and didn’t happen before. Any idea what is going on?

Thanks in advance,


It could be your record mode settings? In this case you’d want to set it to ‘merge’ (midi) and ‘mix’ (audio). I suspect you have it set to something else where a new part is created with every new recording?

Brilliant, I’m sure that’s it. Somehow it was set to new parts rather than merge. Thanks!

Hi, I have been having the same issue since updating to CB 9. Whenever I use retrospective record, it creates a new MIDI region rather than merging with the existing one. I tried changing the record mode settings as Nickeldome suggested, but it still doesn’t work.

Are there any other settings that need to be adjusted or does anyone else have this problem? Thanks!

Hi jcbfoos,
Retrospective record is not meant for standard recording session but rather for capturing what was missed because record wasn’t active at the time it was played. So it makes sense not to merge this in earlier recorded parts because it was not intended as such. However you can manually merge this part into another existing afterwords of course.

I actually figured out what my issue was. Turns out the red record button in the key editor was turned off. It’s call the “record in editor” button. With that on I can now record directly into the key editor. However it keeps turning off for some reason, and I can’t figure out why. used to always stay on.