CPU Efficiencey Query

Hi there does anyone have any understanding about why Im getting poor utilization on my cpus.

When Im maxed out on ASIO Ive still got at least 70% of my cpu idle according to tak manager.

Ive been on all sorts of missions to balance things out

Cubase 6 - 7
-using 32 & 64 bit mode
-setting priority to high and affinity to use all cores
-ASIO guard and multi core support disabled just makes things run worse obviously
-Fresh install of operating system

Im using Dell XPS17 L702X, Cubase isnt exactly underperforming but sometimes Im sure theres more power available.
Does everyone experience this readout in task manager? Im using the Reaktek Onboard but cant beleive that it has anything to do with anything.

Heres a screenshot hope someones got some theories


I’m not an expert, but the audio driver latency and available CPU processing power aren’t necessarily tightly related… It’s more down to how well ALL your PC components work together, and this becomes more chaotic at lower audio driver latencies because when they introduce random delays you’ll notice. With higher latencies the system as a whole can absorb the random delays and catch up, but at lower latencies it can’t. All it takes is one less than ideal component and you’re scuppered. You’ll probably never find out definitively what’s causing this and it’ll undoubtedly be different on a different system I think.

For example, I can’t run at 6ms at all, sometimes a fresh project at 12ms, so mostly I run at about 50ms. But I can run enormously complex projects with plenty of CPU headroom because I’ve got a 6 core CPU and 2 UAD quads.


The audio driver will have a large influence on how well the system will perform. Realtek internal card being possibly the absolute worst choice.

ASIO performance and CPU utilisation are loosely associated, but a good ASIO driver and card will see significant improvements over realtek.


try disabling the first core prior to start up then re-enable after. I do this and it improves things no end. There are various threads on here about it if you do a search

Im using ASIO4ALL. Woudnt work without it!

I might try disabling the first core idea, be interesting to see if it works.

Thanks for the help and would be open to other solutions, was wondering if anyone else has similar problem in Cubase.

I have had all sorts of problems with usb and firewire audio interfaces before, the Realtek has ran flawlessly and sounds great actually. Ill get a interface soon anyway but would be surprised if there was any difference though.

I suppose if you don’t need good AD and just use samples and VSTi’s then the need for a good interface may be less important.

It looks like you are using wireless networking (I think) from that screenshot - turn it off, never plays well with audio drivers & DAW programs.

my wireless is usually off, no problem there. Not sure how to disable the first core before I boot Cubase, I would just use set affinity in task manager but you cant do that till program stars. Or do you mean before I load individual projects. Disabling cores requires reboot??

I disabled core parking as resource monitor showed a bit of parking. At least the loads are now evenly distributed but all are only at 20%. All other apps use processor cores fine. Or at least I get higher readouts.