cpu load keeps increasing by itself

Hi anyone know what could be up? i open my template and cpu load says about 50pc. Then as time goes by whilst im working on a tune the cpu load gradually creeps upto almost 100pc (with no additional plugins added). I I’ve got no 32bit plugs in the template. I’ve got a couple of Omnisphere, Trillian and Kontakt instances Midi side and the rest is Audio.

Asio Guard is OFF (i get so much more processing power with it off)

Multi Processing is ON.

Any ideas what’s happening ???

typical buggy hopeless cubase 8 behavior. If you muck around with buffer and asio guard settings the problem will temporarily disappear until next time you load the project. having tracks armed for record can cause the same issue. turn off record arm selected track in the settings. cubase will be great when they finish it.

Thanks man, good to know im not alone, will give those temp tweaks a go. May explain why when i turned off Guard the Cpu consumption dropped by about 30/35pc. Have Steinberg acknowledged this then? It’s a pretty big bug, basically halves my processing power. Im so tired of being sold half baked products.

Cubase 8 seems to be a curious beast - for some people (me included at first) it was much faster and more efficient - however my system has become more and more unstable with more and more spike issues - to the point where I upgraded to Windows 10 out of desperation just in the hope that things got better. Cubase 7.5 strangely seems to have got “infected” with the same issue since CB8 was installed! Steinberg will not admit to any of these problems even though so many people suffer the same issues. They are more interested in stuffing more and more half-baked “me too” features into the product for marketing reasons rather than fixing it.

I have always stood by Steinberg and Cubase but am seriously considering switching to another DAW - I can live with fewer features - I just want stability and CPU efficiency. I could easily run hundreds of tracks under Cubase 5 on primitive hardware - now I have to struggle to get even medium sized projects to run at all. I’m an extremely technical user with over 35 years computer programming experience and a complete understanding of the hardware - if I can’t make it work then god forbid the casual user - I even bought a Steinberg interface in the hope of minimising possible issues. Cubase 8 works brilliantly for some users. I just wish Steinberg would release an officially sanctioned list (hardware/software stack) so system builders have half a chance of putting something together that works. But in reality I don’t think they have a clue about what’s causing all these CPU spike issues - I really am close to just saying “stuff it” If I want a badly supported flaky product I may as well use a free one. Thank god I make music for pleasure - coz if I was trying to make a living out of music, Cubase would have bankrupted me by now.

I simpley don’t understand how you can have any problems with c8 with you pc ? you got a much stronger pc as I have and I dont have that problem that you say. some issues now and then but only minor ones. I don’t have any issue with the cpu I and got 8 ram, 3.4 ghz . I got some problem with mediabay but otherwise c8 works like a clock for me. of course if you have a 1000 tracks loaded up with vst instrument with an instrument in every slot, then no pc would be good enough. am not an extrem technical user but i do get to fix some issues with or without the support form steiny. if you got so much problems something is seriously wrong :open_mouth:

Alas this is often the case with pc’s because there are so many combinations of hardware ad their drivers and software that it is impossible for a developer to test them all. I guess if anyone is to blame it is the OS maker

this is not an OS issue, my gut feeling is there’s a serious bug in the core audio engine which has been introduced and worsened with the introduction and development of ASIO guard.

Just to chime in for comparison sakes:

I am using ASIO Guard and my performance meter is really quite healthy and low.

I have had that meter creep up into the red though, so I can relate.

It also happened once recently, only because I introduced a 32 bit plugin into a current project.

Then after a restart of Cubse it went away.

I have also had it in the past a few times - but it never seemed to last.

It may take some tweaking to get your system to ‘play nice’. As mentioned there are a lot of different systems and configurations out there.

I’ve noticed that Cubase can be a bit finicky, but for me [specs below] both 7.5.4 and 8.0.30 are really stable with low performance/CPU usage even with half a dozen instances of Kontakt 4 and 5, other VST instruments, some 50 tracks both MIDI and Audio and numerous effects - all processing live without anything bounced. 3 of those K5 's are quite intensive as well - Kirk Hunter’s Solo Strings.

Something that helped was to right click on the Cubase shortcut icon in the quick launch, and in ‘Properties’ uncheck ‘Run In compatibility with Windows 7’ [in my case].

One other thing I can suggest you try is the ‘Audio Power Settings’ given free by a member named Motoko on the Presonus forums.

I’ve been running that for a while now with no issues [other than that 32 bit plug].

I can give it to you to try if you PM me for it.

Additionally, I helped out another guy who was all ready to give up because he was at his wits end.

I gave him a copy of my 7.5 Preferences and he was up and running with that since then and still is.

That was about 6 months ago. I can give you that file for 8 Pro to try as well if you like.

Cheers Jamusic. Im almost certain it’s got nothing to do with Preferences but im willing to give it a shot. Could you upload your pref file please?

Sure - but it won’t be until some time tomorrow until I can get to it.

Hey wcb123,

I tried to upload 2 files for you, but you’ll need to PM me an email address so I can attach them there instead.

James

Sharing ‘Preference’ files will not solve anything here. Actually, a Cubase 7.5 User Data file will cause issues with a new install of Cubase 8. Starting in Safe Mode and creating a new set of preferences is best advice. If one upgraded from previous version of Cubase, then delete all preference folders for ‘each’ version before staring newer version of Cubase. They just do not like each other.

This has been a documented issue for years. Apparently any new version of Cubase upgrade, will attempt to use the old data folder. Problem is that the new versions have other options…

I myself have had ability to save templates and other User Data folder pieces of the prefs folder when upgrading to newer version of Cubase. But the best bet is to create a new prefs folder when stuff goes weird.

Sorry guys, but sharing a prefs folder is not something that is going to help. Allowing Cubase to create a new one will at least find if that is an issue.

This.

https://youtu.be/OHXqPoayo6k

That happens in my projects since Cubase 8. Can Steinberg comment please.

I have had the same kinds of issues. Kontakt has been a culprit for me in many instances. Make sure that it is running with the multi-core setting turned off. I generally render in place now when I have an issue with Kontakt. I find that this works better than freezing. A lot of theses issues have for me been VST related and it has been a pain searching them down.I have tended to use vst plugs as there have been issues with VST3 reported in the past, but I am now beginning to wonder if there might not be some advantage in VST 3 releasing cpu when not being used.

Oh I don’t know, the whole thing is just so bloody confusing!!!