CPU optimisation

Hi guys,

The CPU meter in cubase is running into the red and stuttering, yet the windows task manager says I’m only using 30% CPU and 18% memory.

What do I need to do to free up the rest of the CPU for cubase?

Thanks

Try increasing the buffer size of you audio interface…

Thanks for your reply. It’s already at maximum of 20ms…

Use Windows’ Performance Monitor to see if you are maxing out a single core.

Just checked and they’re all running equally. How do I make Cubase access all of the CPU that’s available? Is there some sort of internal CPU limit I can switch off?

No there’s nothing in Cubase that limits CPU usage. Don’t assume that if the Cubase performance meters are maxing out that it is CPU causing the problem - they are looking at the load on the audio engine which doesn’t necessarily correspond one to one with CPU load. If Windows is saying you’ve got plenty of unused CPU that would imply that CPU isn’t the culprit. Try running Windows’ Performance Monitor and see if any other resources (memory use, disk I/O, etc.) are thrashing when the problem occurs. Also disable most everything in a project and then turn them on one by one to see if something specific is at fault - a rogue plug-in perhaps. Also make sure you only have multi-processing turned on for Cubase and off for any VSTis like Kontakt.

There is a chapter on optimization in the Ops manual you might want to read. Good luck.

Ok so I’ve checked windows performance monitor while using cubase and theres no spikes for anything else. Just cubase. In terms of the project, I only have a single synth open in a new project, no other channels. Still the same issue: max cpu in the red on cubase, only hitting 30-40% cpu useage in windows performance monitor and 18% memory useage. What next?

I have attempted to change these settings in BIOS: Enhanced Intel SpeedStep (EIST), AMD Cool ‘n’ Quiet, Intel Turbo Boost, and AMD Turbo CORE, C-states, and hyper threading. However not a single one of them appears in my BIOS menu. I’ve also updated the BIOS driver and still no options there to change those things… I’m completely bamboozled.

Sounds like you’ve covered most of the obvious performance related stuff. Interesting you are seeing this on a small project. At this point I think you should go to My Steinberg and open a real support request. Document the situation from both the Cubase & Windows perspective plus what you’ve tried so far. One thing you might try before that is resetting your preferences file & letting Cubase rebuild it. That often fixes weird mystery problems, although I wouldn’t expect it to help here. Still worth a try.
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Did you try to update your audio interface driver? And if so try to uninstall and reinstall it. Regarding the 30% CPU usage, it is the same on my system, I think, that’s normal, so it really sounds like an issue with your audio interface especially when you say, that you maxed out the buffer settings… Maybe watching this can help https://www.steinberg.net/forums/viewtopic.php?f=198&t=102936

Ive tried disabling the preferences, and also updated my audio interface driver but its done nothing. Somehow, windows just isn’t allowing cubase to access all the cpu. I’ve set the affinity for cubase to all processors and limited all the background ones to 1 processor, and set the priority to real time, and its still in the red in cubase and idling around 30% in windows performance manager.

Like I said earlier, it probably isn’t CPU that’s the bottleneck in Cubase. Does this happen with any project or only one specific project. If only one then maybe the project is corrupted. What kind of graphics card are you using? Some folks report performance issues with NVIDIA cards (but I have one that works fine). Have you submitted a support request?

No it’s not a lack of CPU that’s the issue, it’s how it’s made available to cubase that is, and what I’m struggling to figure out. This is the case with any and every project. My graphics card is a Radeon HD, and yeah I’ve submitted a support request. Apparently this is a common issue as presented by rumlee in the link; its something to do with real time processing apparently and how other devices interrupt threads on shared processors thereby preventing the cpu from calculating the info in time for the buffer, resulting in stuttering/pops/clicks. However none of my fixes have worked so far. I can’t seem to get the cpu to give more priority to cubase.