CPU Overload / Audio drop-out detected (Mac) - only 3 tracks

Hi Guys,

After my previous post discussing a move back to Cubase from Logic, but expressing my concern with latency and running very low buffers on a Mac, I’m now using Cubase 6 and am determined to get the best possible performance I can out of it.

I am concerned that I am getting the “CPU Overload / Audio drop-out detected” message already… my current project has three tracks:

  1. Virtual instrument running Kontakt - using Native Instruments Studio Drummer on this track, to record some drum parts using my Roland V-Drum kit as the input device.

  2. Acoustic piano (audio) track, with compression (the standard compressor that comes with Cubase 6)

  3. One MIDI track, sending data to an external synth (my Prophet 08, in this case).

So we’re not looking at a very complex project at all!

Here is some other info that may help diagnose the problem:

  • I am using a RME UFX interface, over USB
  • I have set the buffer at 64 samples, to get low-latency performance for inputting the drum track (virtual instrument, as above)
  • My Mac is a Mac Pro Quad 2.66, with 12 GB of RAM
  • I have tried using “constrain delay compensation”, but this turns of the drum compression.

So we’re looking at a very very small project, with only a couple of effects running. Admittedly I am using a very low buffer, but with only one VST, one audio and a MIDI track, this should really not be a problem!

What I am hoping for is some advice from other Mac users regarding any of the Cubase 6 preferences I may be able to tweak in order to get better performance at this low latency.

I am really concerned that as the project gets more complex, I will have even more of these error messages and won’t be able to keep working.

Thanks in advance for any suggestions you might have!

Cheers,
Mike

I did a test on my mac using a MOTU 828mkII @ 64 samples. I made the project like yours although I have no external synth. It seems the CPU killer is Kontakt’s Studio Drummer. I replaced the instance of Kontakt with Addictive Drums and my ASIO meter went from 40% with some spikes all the way down to 5% with no spikes.
I would look into how to optimize Kontakt, specifically with Studio Drummer too see if you can get the latency down.

Thanks - this is great advice!

As a previous BFD user, I hadn’t thought that Studio Drummer might be the culprit! Based on this, I will try freezing the Studio Drummer track tonight, to see what the impact is.

On a related note, therefore - when freezing a virtual instrument within Cubase, does Cubase “disable” the virtual instrument in question so that it is not draining resources while the track is frozen? Or would I need to un-load the instrument once frozen to see the benefit?

Thanks again for your suggestion!

Cheers,
Mike

You know I don’t really know that much about freezing, you will have to experiment and see. I hardly ever have latency issues on my PC, and I rarely max out my asio, if I do, I just start bouncing and doing track exports to wav files.
I use my Mac for remote recording , not so much VST work.
Good luck

No problems! And thanks again for picking up the Studio Drummer CPU issue!

Perhaps there are others on the forum who can comment on my question about freezing?

Cheers!
Mike

Hi
I’ve got a strange version of this 'overload problem - on PC. On one project (the rest are fine) I get the “CPU Overload…” message at a particular point in the track and the ASIO Time Overload light flicks on and off at top left in the tramsport bar. The glitch is audible in all audio tracks and some Instrument tracks so it’s a serous problem for this project. It happens almost every time, but just occasionally it’s fine. As I say, always at exactly the same point in playback. The very odd thing is that even if every track in the project is muted, both the warnings still appear! (although of course you can’t hear anything) so it’s clearly not a true overload. I’ve checked precious saved versions of the project, re-booted etc but no clues.
Can anyone advise please?
Andy

is that the first gen Mac Pro, what you call “quad,” actually the Dual-Core Xeon (4 actual cores) or true Quad-Core Xeon (the later generation) with 8 actual cores?

i’m on the first gen, only 4 actual cores, 3.0 ghz, 19 gigs of ram and Cubase performs horribly on it, as compared to Logic (even after taking into account Logic’s playback buffer “cheat.”)

even with the highest buffer settings in Cubase i can only get a couple tracks with anything reasonable on it (a VST and a couple inserts). essentially, i have to freeze every track except the one i’m working on.

it sucks, but i had to switch from Logic as Logic was crashing all the time. and those modal dialog cpu overload messages, that you have to click away faster than they appear, so much that it keeps you from hitting stop, was maddening. that alone, forced me to switch to Cubase. Cubase may not perform as well as Logic on OS X, but it handles overloads more “silently.”

i’m waiting to see if Apple releases a new Mac Pro, if so, I’ll be upgrading, if not, I’ll be forced to switch to Windows 7, which Cubase screams on, as compared to OS X, anyway. So it would be a double boost.

Good luck, and “I feel your pain.” :slight_smile:

This might help:
http://www.youtube.com/watch?v=mI2u4PS2qxg

It’s an older version of Cubase but the process is the same.

Don’t hijack other peoples threads when it’s clearly a different issue.
Start your own thread and/or search for threads on the same topic and post there.

My setup is almost identical to you and since I upgrade from 6 to 7 I’m getting the same spikes. I thought it might be something as simple as the auto backup but disabling it has not solved the problem. Hopefully a resolution will be found soon.

Would love to bring this discussion back up.

VSTi Freezing having no impact on ASIO.

Deleting all VSTi having very little impact on ASIO.

Turning off all VSTfx having little impact on ASIO.

Same projects worked fine before.

Project works ok for 30 minutes, then starts crackling/dropping out tremendously afterwards.

Project will refuse to rewind/forward transport while ASIO dropout is in effect.

Get to certain area of song and dropout/crackle seems to happen more often.

Most importantly, again… happening on all songs now. This was not happening before with the same setup. What happened?

Does it sound like the Mac is dying?
Lets resolve and have this thread be a final resource.

I m running on Windows but the few times that I got this problem the harddisk was to blame. I tested the harddisk, Got a new HDD, installed everything again and the problem would be solved.

Unfortunately you might be close.
I think this sudden behavior must have something to do with reading/writing interference. It seems to break up after I adjust something, anything. It’s like it struggles to update the changes fast enough for anything close to live playback.

I stream a lot of heavy VSTi to a 2nd internal HDD, but I bounced all that stuff down and call the audio files from my local HDD. Now there are no VSTi, a few fx. The ASIO has gone all the way down, but there are still intermittent spikes that eventually lead to Cubase simply not passing clean audio.

Basically my music is at a standstill right now. I loaded an empty project, added 4 VSTi, popped on a few fx, and boom, ASIO meter starts jumping when pressing play with no audio passing, and unable to press a note via a VSTi interface without crackle.

Is there anything else anyone might suggest I try?

Hi :slight_smile:

I am not a MAC user so i cant help much. But i can say that it mostly related to your CPU or RAM. You need to upgrade which ever is not sufficient. If this cant fix the issue then it mostly related to a computer virus which i had experienced one or two years ago. That virus eat most of the CPU power by running hidden programmes or by multiplying the process which you’re currently running. So you need to fix that bug by contacting a professional or by replacing a new HDD. This mostly solve the issue.

Cheers :slight_smile:

the studio drummer is the problem. use modern drummer or other drums library…

I’d like to bring this post up again, since I’m having the same issue, but inside of Cubase 7, Ableton Live 9, Studio One 2, heck even Pro tools 11!

There is something absurd and wrong with this. My processor is i7 2,0GHz with 16GB RAM and an internal SSD disk. I’ve tried everything with buffersize, priority settings, uninstalling. This even occurs when only having 4-5 tracks with AUDIO (yes AUDIO not any VST loaded).

I’m only using bought pieces of FX and stuff btw. It’s insane, I’m longing to fix this problem, but I cant find any info what so ever anywhere. Please help if anyone can. I need to fix this. I can’t produce music like this.

+1

Cubase 9, Windows 7 64bit, QuadCore, 8GB RAM. Several AUDIO tracks, and ASIO drops out regularly.
Buffer set to 512!