CPU Overload / Dropout detected with CPU at circa 5%

Hi

Not much to add - I am using my newly built PC, with a Ryzen 5900X CPU and 64GB RAM, and I’m running, well, a few tracks but certainly not a huge number, maybe 10 at the same time. And all of a sudden Cubase is grinding to a halt with “CPU Overload / Droput detected” dialogue popups. And yet if I watch the Task Manager the CPU usage is around 5-10%. What’s going on here? I just spent a ton of money and a ton of stress to build a rig that could cope with virtually anything and I’m getting this with maybe 10 tracks running at the same time.

1 Like

This is mad…well, weird, whatever you want to call it.
Cubase has become unusable - “CPU overload” dialog box basically every second (or more frequent than that) but according to Task Manager my CPU usage is 4%

If you take as gospel (maybe a stretch… IDK) that Task Mgr’s CPU usage is roughly what it says it is, why the hell is Cubase saying CPU overload? I mean, FFS I have AFAIK the second most powerful CPU that AMD offers and am running maybe 10 tracks at the same time and Cubase is grinding to a halt. There is a reason, and maybe it’s not Cubase’s fault at all, but telling me that there’s a CPU overload when Task Mgr says CPU usage is < 5% is really well not very good at all.

I just quit and restarted Cubase and it’s running fine. This obviously suggests that the issue is in Cubase itself.

I think it’s related to Sampler Track.

Because it’s coming back and it’s Sampler Track that I added most recently and it seems to be stalling on it. Looks like there’s a bug there.

I just quit Cubase, restarted, and I still had solo (S) enabled, on the Sampler Track, and I hit play and I got “CPU Overload” popup. Jesus. I have ONE track! ONE! With a Ryzen 5900X! And I’m getting CPU Overload!!!

Maybe I should just go back to Logic. I hate Apple, but at the moment I hate Cubase more.

And maybe it’s not the sampler track because if I mute it it’s just as bad.

It seems whatever track I solo I get CPU Overload/Dropout Detected. What a pile of cack.

Now Windows is saying Cubase CPU usage is “Very High” despite it not actually playing.

I seriously doubt the CPU is your problem.

What kind of audio interface are you using? Is it what’s on the motherboard, or is it a nice pro audio interface with true ASIO drivers?

Something’s not right. I ran dozens of simple sampler tracks with an old Phenom II generation cpu with just 4 cores, and that’s with DDR2 memory and SATA2 generation drives. Sometimes I needed larger ASIO buffers (512k or larger) but it got the job done.

Run latency monitor without Cubase running first. See if that gives any hint of a driver or something that might be doing interrupts or causing a bottle neck. Common culprits are network interfaces. Here’s a quick over-view of how to run some tests and make adjustments.
Windows: How to set-up and optimize a Digital Audio Workstation – Steinberg Support

I once had some PNY SSD drives that use drivers that would handle massive chunks of data pretty quickly (they were really fast at straight up loading/saving large files from memory), but would always do an interrupt between each data chunk, and this was really BAD for my DAW apps that perfer to ‘constantly stream data’. I stopped using those PNY drives for anything that needs to stream and all was well thereafter. As odd as it seems, I actually got better A/V d2d performance from old platter drives than those PNY SSD units.

Anyway, my point isn’t that your drives are bad…but rather, some driver in your system might be causing the problem. If it’s a network driver (pretty common), then disabling the interface when you want to use the DAW can fix it. Or, you might get and find a different driver that doesn’t do interrupts the same way.

With Cubase 10 or later running, you can run a real-time latency monitor on all the mixer channels. That can help track down individual plugins that might be causing a problem.
How Cubase 10 Can Solve Your Latency Problems Once And For All : Ask.Audio

Also, what instrument(s)/plugin(s) are involved here? I do have some SONIVOX stuff here that just refuses to run on AMD (including my Ryzen 9 3900XT OC at over 4ghz) unless I use HUGE ASIO buffers up to 4mb (and even then it’ll glitch until I’ve played a few times and gotten more of the samples cached into memory). I don’t know what they did with the sample encryption and all for those plugins, but I’ve never been able to use them on AMD builds.

I wish I could get Cubase 11 to run at all. I totally chime with the ‘tons of money and stress’ factor having wasted 2 weeks valuable music production trying in vain to get the dmned thing to work on W10.

I should have stuck with Cubase 8 Pro: at least that worked - most of the time…

Hi Brian
Thanks for posting your reply. In answer to your question I’m using a Steinberg/Yamaha UR24C.
The strange thing is that Cubase was running fine for many hours, and then it seemed to “gradually then quickly” start playing up. Even the first time it happened I thought “uh oh” as I really don’t have many instrument tracks - as I said, maybe 10; and not a lot of plugins on them.
But, I suppose, it all adds up. I will monitor the individual track and plugin latencies as you suggested, and disable things one by one etc until presumably I am able to find the culprit.
Having said all that, the fact that the dialogue box says “CPU Overload / Dropout detected” hints that that popup is shown when one of multiple things goes wrong; if so Steinberg devs could help us all out by disambiguating the different issues and showing the appropriate message, to help point us in the right direction. It cannot be that difficult to give us more information.

Cubase does not work, even on an Intel i9 10980XE processor.
It only works at 30% after that it is the bug.
Cubase does not work on large processors.

Certainly this is not true, since many users are running high end CPUs.

Maybe read the reply above yours: CPU Overload / Dropout detected with CPU at circa 5% - #11 by Brian_Roland

Another thing to check.

Virus scanners…

Set Windows Defender, or any other virus scanners you might have installed to ignore “%SystemDrive%\ProgramData\Steinberg”, “%AppData%\Steinberg”, and most importantly your project directorie(s) as these are where files are constantly changing while the DAW is ‘in action’.

While you’re at it set it to ignore directories for any third party plugins and such that might constantly have new data added/subtracted during a session.

If you can figure out how, you might also tune virus scanner to focus on using a weaker core for its main thread instead of the usual ‘system favorite’.

Some virus scanners are constantly hunting and scanning anything new that hits your data storage.

If you’ve got a pretty new installation going, or have recently added a lot of content to storage it can take your virus software a while to go through it all. On new installations it can sometimes take days for it to scan everything and really settle down…especially if you power down or put your rig to sleep instead of just letting it idle for a long time.

I have an intel i9 10980 XE and use it everyday for music and 3d.
The only software I have problems with is in cubase 11.0.41.
All my other software works like Swiss clocks.
The CPU in 18 threads, because in 32 threads, you don’t even have to think about it in cubase. However, before buying, I asked Steinberg after-sales service if cubase worked beyond 14 threads.
They do not even know the possibilities of cubase on all CPUs!
Instead of advertising, they should be working on working software!

Been using it today. Nowhere near the number of overloads/dropouts as last weekend.
However I also just noticed that, having stopped my creating maybe some 1/2 hour ago, but with Cubase still open, it was showing 10-15% in the Task Manager; middling around 12%. And it still is as I type this.
I’ve got online streaming TV playing in firefox with 73 tabs and that’s only using about 0.2%-0.5% cpu.
What on earth is Cubase doing? I understand it needs to monitor inputs, but this amount of CPU usage when it’s been stopped for over 1/2 hour does not seem right.

Thanks for the suggestion. But I don’t have any AV. Unless you count Windows’ own (Defender/whatever process it is…msmpeng.exe maybe).
Which made me wonder…I have just downloaded sysinternals process manager and running it and filtering on cubase there’s a ton of activity…not sure it’s cpu-intensive stuff but I do wonder what it’s doing eg:

Yes, Windows Defender counts. Half the stuff sold as Security Software these days is nothing more than a fancy and ‘different looking’ UI on top of what comes with windows!

It gets pretty active anytime you install something new, add lots of content to a storage device, etc.

On a fresh windows install it can take several full 24 hour days for it to do the initial full system scans and eventually settle down.

Have it ignore directories that see alot of action with trusted user files. I.E. The DAW project directories.

If you install a bunch of stuff, let the PC stay on and idle for a while. Don’t shut it down right away. Give Defender time to do its scans.

A virus scanner alone shouldn’t be causing the problems you’ve described, but I suppose it CAN contribute to it a bit.

Are any tracks armed for record/playback?

Got ‘inputs’ connected?

Don’t forget that there’s a significant ‘live mixer’ running, even if you’ve got Cubase minimized in the background.

Example: Say ya got 3 inputs active coming off your audio interface. A stereo mic and a mono guitar or something.

This stuff is constantly coming into the Cubase mixing matrix. Meters and stuff are bouncing, even though the transport might be sitting still.

If any of that stuff is connected to armed tracks…it passes on down the line, so add any stuff ya got running in inserts.

Then there’s whatever ‘plugins’ might be doing internally.
Example:
Just now while I type this I have a Cubase Project open that’s idling around 5% on a Ryzen 9 3900XT with stock settings (3.8ghz with occasional individual core boosts up near 4ghz). I don’t have the cores locked to run wide open…this is the typical stock cool and quiet configuration for the CPU, so cores step speeds and voltages on demand. 12 physical cores are active, and another 12 virtual cores are also active.

The only window active is the main project window.

It has one set of inputs connected via my Delta 1010 (PCI Audio Interface) > ASIO Link Pro. There is a Roland Fantom XR tone generator plugged in to this as a stereo pair.

The only output’s active right now is the control room > ASIO Link Pro > Outputs 1 & 2 of my Delta 1010.

NO tracks are armed, and there are no loaded/active slot VST plugins on the Mixer. Only thing running on the strips are the default EQs.

It’s hosting 8 instances of Play 6.1 on instrument tracks, each hosting a Multi variant voice of the Symphonic Choirs. Each instance has internal stereo imaging and built in convolution reverb going on.

Cubase was idling at around 5% according to the Windows Task Manager.

I opened my VSTi plugin rack (Right panel, or F11) and disabled all the Play instances by clicking their power buttons to off.

Idle percentage drops to 1% and less right away, which indicates to me that those East West Play 6.1 plugins are doing something while idle. What, I have no idea.

I tap F4 and disconnect the inputs.

Idle percentage is now between 0.5% and 1% with occasional spikes to 1.5%

I disconnect the control room outputs too.

It settles another fraction of a percent lower.

I hide minimize the window so Cubase isn’t responsible for screen draws.

Now it rarely tops 1%

I could keep going…in Studio Setup, and disable more and more stuff.
MIDI connections.
Awareness of 64 possible ASIO Link inputs/outputs.
Tinker with ASIO Guard.

Other things that might matter:
I’m using ASIO buffer size of 256k. Things are going through ASIO Link Pro, and also routed through an instance of Bidule. Buffers and such are involved with those ASIO back end tasks…which ‘might’ have an effect on Cubase resource demands as well.

Then there is some stuff pertaining to the Graphics Card I could fiddle with as well in Edit/Preferences/General. Stuff like HDPi Application Scaling.

There’s quite a bit going in a DAW, even when it appears to be ‘idle’. Particularly if any Device ports are active.

The important thing is this:
Does Cubase bog and stall or crackle and pop when you’re trying to use it? Does your system bog down in general while it’s running? If not, don’t sweat it. It’s just doing its thing, and the OS and CPU architecture has most of the multi-threading control anyway.

For what it’s worth. I re-enable everything and play my choir project. Cubase never tops 7% CPU while playing it. So, it would appear that there’s not much difference in this particular project with this particular plugin/instrument combo when going from idle to playing (and yes, all 8 instances are constantly going in parallel and making sounds).

As for individual cores. With several browser tabs open, one playing a video, and my Cubase Project going…no cores are maxing out, the highest one gets is 20% (I think that’s the one Edge Browser is using to play my video), and none of the cores are really pegging out and running anywhere near the 3.8gig mark…most aren’t even topping 1ghz. Yes, when I play the project there is activity bouncing around on pretty much all 24 cores.

1 Like

Hi Brian
Many thanks for this. There’s quite a few things there for me to try. I did find before I finished up at the weekend a few things: first, muting the single active input (which for the mic); it made no difference. Second, I tried muting all tracks (easy to do as they are all in a folder); it made no difference. Third, closing the project; that was what made the difference, as I suppose it obvious thinking about it. I don’t have as much stuff going as you do/did in your example, at least, I don’t think I do, but maybe I do have more than I think.
Disabling the plugins one by one is the obvious way to go. I’ll try that.

It is conceivable, in fact quite likely, that I am being quite naive in my expectations as to how many CPU cycles should be pulled when the sequencer is in stop, and has been for a few seconds.
Maybe the plugins need to be always armed…and that takes a lot of CPU cycles. I’m sceptical though; I think if some thought were given to this a lot of CPU cycles could be saved, which would add up to a lot of watts, saving people money and doing a little something for the planet.
And if there would be some downside to saving CPU cycles when the sequencer is in idle eg start-up would take a fraction of a second longer, why not give us the option?

Thinking about it now, when all is said and done, the simplest solution is to just close the bloody project!

You may be maxing out a thread. That is often what is happening when you get dropouts with relatively low %CPU use indicated. Not all audio processing can be spread between multiple cores. For example, if you have a lot of processing on one track, and that track is bussed to another track with lots of processing, and all this is sent to the master which also has a lot of processing (eg: many oversampled plugins) then you can easily get dropouts since this very complex and demanding processing chain can only be handled by a single thread - can’t be processed out-of-sequence as each plugin depends on the output of another.

1 Like

I’ve reread the OP, and I can’t help but suspect some system driver is the problem (if you’re getting audio buffer over-runs and drop-outs’). Seems like ‘something’ is plugged up, and has drivers that don’t get along with smooth/steady audio performance. Could be almost anything! A hub, fancy mouse driver, network card, graphics card, hard-drive…many possibilities.

It’s a ‘repeat’, but I’ll say again that I lost a lot of hair once over those PNY brand SSD SATA3 drives (It was an AMD Phenom II based build…two actually…one was hex core, the other quad). Even a single instance of ARIA playing a very simple sampled instrument (like a solo flute…just one layer of samples) would cause buffer over-runs and the sound would ‘glitch/click’. The CPU itself wasn’t showing much sign of being pushed hard…but ASIO buffer would over-run like clockwork, Cubase would ‘glitch’. About the only thing I could get to sound smooth was HALion stuff (the rompler libraries that come with HALion 5/6…which coincidentally were on the Samsung system drive rather than off one of the PNY drives).

I ran sys-mon dozens of times and the system kept passing with flying colors. I tried 4 different audio interfaces (mother board, one over PCI, two over USB). Even disabled everything on the motherboard (networking ports, onboard audio, etc.) swapped graphics cards around…you name it.

Then one day I decided to try moving those sample libraries to a different hard-drive, and never had problems with it again. Out of curiosity, I moved it back to one of the PNY drives and the glitches came back.

It was the darndest thing. Something about those PNY drivers…they’d do some sort of system interrupt after every single chunk of data that every DAW I tried HATED. Cubase, Sibelius, Finale, even tried out Demos of Reaper, Studio One, and more. Glitched in every one of them. I still have and use the PNY drives to this day, but NEVER for anything that needs to ‘stream’. I keep them in a docking bay, and just reach down and eject them if I want to work with my DAW in a fully ‘glitch free’ environment.

The drives showed pretty darn good benchmarks when it came to quickly opening files and dumping them into memory, but they were just TERRIBLE for streaming apps that read/write nibbles here and there on a constant basis.

CPU wise, with a 5900X you should be able to handle some pretty dense and intense projects without a hitch! Your CPU is at least 20% better than mine across the board, and I get smooth Cubase performance. That rig should be able to do some pretty heavy lifting without even breaking a sweat!

Do you have another DAW to compare? If not, maybe you can get a demo for something ‘non-Steinberg’ and install it to see if the glitches stick around? If ‘other daws’ are also having fits…then you KNOW it’s gotta be something about the system build itself (most likely a driver thing).

If you can, it would not hurt to try installing anything that needs to ‘stream’ from storage to a different brand/type of storage. I.E. Kontakt/HALion/East West/Vienna Pro/Garritan…any kind of sample libraries. You might try isolating just one library to a different drive at first and see how that goes. Seriously…try any half-decent hard drive you can get your hands on (even if it’s not SSD media).

1 Like

Have you tried disabling hyperthreading (your virtual cores), p-states (dynamic power management), and/or speedstep? Try locking your CPU to only physical cores, max turbo, disable power management and see if the pops/clicks go away.

There is a long term, very, very well known issue with hyperthreading + cubase ASIO internal processing + windows multimedia multithreading that causes identical symptoms, and steinberg hasnt been exactly forthcoming or helpful about resolving or documenting the issue properly. Many other suggestions are typically rolled out FIRST, before anyone mentions hyperthreading, for users who come to the forum complaining about this, and so this is something you might look into.

There is some info on steinberg’s own site, but it makes the claim that ASIO Guard helps “the majority of cases”, but that simply isnt true.

I tried to include a link back to steinberg’s own documentation on this, from this site, but the forum says “you cant post links”. Sorry - a quick google will locate the pages in question.

Try googling “cubase Hyperthreading-Simultaneous-Multithreading-and-ASIO-Guard” and you will find the page.

There are other threads, going back years, on this. Looks like I have to use the “link post” mechanism to post links, and cannot simply post links.

Another post about this from the forums.

Service Steinberg told me that hyperthreading does not work on cubase. It is imperative to deactivate hyperthreading for the stability of cubase.

1 Like