CPU overload on tempo changes

I just spent a couple of hours troubleshooting why I get pops and clicks on instruments during simple tempo changes (retard at end). It seems if any midi track is armed, tempo changes cause huge asio spikes, without the track armed everything is fine. That said, as in other posts, arming a track greatly increases cpu usage. I just don’t understand how tempo changes can be so problematic?
Ryzen 3950x, RME Difgiface (64 samples) Cubase 12.0.40, Asio Guard on, normal.
Changing the RME latency doesn’t make a lot of difference.
On a separate note, if I disable asio guard for Vienna Ensemble Pro, things get way worse.

It’s an old known issue, discussed to death, do a search and see for yourself. Some libraries will cause CPU spikes and glitches, some don’t, it’s hit or miss. The only workaround is to use jump tempo changes instead of ramp type.

I know it’s been around forever, particularly with Kontakt libraries (I always have ext sync off) but it just seems so crazy. I’m using “ramp” tempo changes. It goes crazy when ANY VST Instrument is armed.

Wow, I just discovered that Soundtoys “Little Plate” was causing the overloads. I removed it and everything is fine! A shame though because I quite like it…