CPU Speed limiting (no-boost) with Large Projects

I mainly compose orchestral arrangements in Cubase Pro 12.0.52. Lately I have been creating large project templates with over 2000 disabled tracks. Obviously, this takes the work out of composing giving me a massive canvas. I use a variety of sample libraries, vsts and effects; however, as stated above, they are disabled and enabled as needed. The project file/template is 500mb on open.

Relevant Tech and Hardware:
Origin Laptop, i7 8750h, 64gb ram, gtx 1070, Windows 11 home (latest build). Drives: (OS) 2tb 970 evo plus, internal sample 1: 4tb Sabrent Rocket 4 plus, S-drive 2: Samsung 870 (2.5in). Rme Baby Face Pro, various midi controllers and synths.

NOTE: I am undervolting with throttlestop to limit throttling inherent to the 8750h.

The Issue:
Once the project reaches an undetermined (hence my post) number of enabled tracks it locks my cpu at 2.99ghz. At playback of approx 100 instrument tracks with minimal processing it runs 55% at 2.99ghz. As an example, with 50 activated tracks it runs normally boosting from 3.1 to 3.9ghz as configured. I tried tracing each plugin (or quantity of) many many times; disabling/enabling reopening the project template. Tried with and without steinberg scheme enabled… I actually setup my default balanced scheme exactly to the steinberg one many months ago as it works better with it off in the settings for me. Asio medium by default however tried variations. I will say, I am still able to compose and still enable additional instruments. The issue I’ve noticed with a previous project is I “ran out of juice” prematurely as my cpu was not boosting appropriately.

When I exit Cubase or open a normal sized project processor is functioning as intended. Is there something I am missing? Has anyone else experienced a similar issue?

Any help or advice is appreciated!

Just a suggestion - did you track CPU temperature? Maybe it’s simply overheating at some point?
Another suggestion is to try different settings of ASIO-Guard and processing precision. But most probably, those two will allow you to enable just a few more tracks and get stuck at another point.

Yessir, I tracked cpu temp, adjusted asio and processing precession. No throttles or improvements. Also worth noting my issue is noticed at idle (project open) as well.

Thanks for the quick reply!

Unfortunately, I can’t help, but I can kinda confirm that.

One of my laptops has the same CPU and Windows 11 Home with the latest updates, the difference in Cubase - it’s 11.0.41 on my side. I just checked - I loaded different instruments (100 samplers and 20 synthesizers), some with loaded samples and some empty. CPU stayed mostly above 3 GHz, up to 3.8. Then I deleted everything and loaded 200 instances of Serum with the default preset, and hit play without any MIDI events in the project. CPU freq was jumping in the range of 2.84-3.04

I didn’t work with big templates last few years, so can’t replicate exactly the same situation as yours yet. But I’m really curious, why this happens, will try to dig into it, will let you know, if I’ll find something. At the moment, it looks like Cubase, or Windows, or CPU, is trying to spread processor resources evenly across the load. But who knows, maybe it’s a bug.

And a few more tests ahead, this will definitely will let you know soon. Will try to isolate the problem.

1 Like

So the results:

On my main machine (Ryzen 9 5900HX, Win 11 Pro, Cubase 12.0.52) I loaded 400 instances of Serum (don’t repeat this at home :grin:) and one instance of VEP Pro. On the second machine (that with i7 8750H) in Vienna - 115 instances of Synchron player with Apassionata strings patch loaded. All this insane orchestra was playing the same note.
Main machine’s CPU increased its CPU freq from 4.2 in idle to 4.4 while playing. Slave machine - floats from 3.6 to 3.9, independent from playing/idle state.

This is not so relevant test, but maybe this is how Cubase manages Intel’s processors. Hope someone from Steinberg programmers will drop by on this topic and can shed some light on this mystery :slightly_smiling_face:

1 Like

Thanks for testing! The situation is odd enough that I wanted to start this thread. Odd can turn into limitations over the next few months and I have worked very hard at this new iteration of my orchestral template. I’m currently out with the family, however, later I will screen record some tests for you to see specifically when it is working correctly and when the issue occurs. Since I save sequential saves every few minutes, I will go back to when it works.

Probably important to point out my ultimate goal. I would like this template to be the basis of every new project. I want to be able to mix each stem (using vst effects) so I could, if needed send an almost perfect stem or master group buss if/when my imaginary composing career starts​:joy::joy:. I will obviously mix heavily in a separate project however, I want and need certain processing on each track. So, I need to figure out how to solve this regardless of the project size OR specific vsts loaded. I know, I know, I need a new laptop/pc… I’m picking parts but am in no rush to rebuild my system. I9 13 gen with 128gb of ddr5 ram is coming… Someday. Haha

Next step, I will try messing with the Intelppm in registry as it is currently set at 3… I hear that setting this to 4 can sometimes fix similar issues.

Unsure if I’m permitted to do this… Attached a draft link of my current project (the problem child). I first composed it exclusively in bbcso core and imported into my large template - since began layering CSS, opus, and other libraries in top as needed! Check it out if time permits.

Again, any help is greatly appreciated!

That was exactly what I was continuously thinking while reading your post :joy:

I have similar demands - sketching, composing, arranging, and mixing everything in one project, with all the synths, inserts, and sends I needed, without freezing, and with 3-6 heavy mastering plugins on the master bus and with minimum buffer size possible :rofl: Luckily, this Ryzen 9 finally brought me to the point, where I can do all this with the pop songs (even with mastering plugins at the final stage, yes, big delay, but no dropouts at all). But I can’t imagine, what kind of computer would be better for a similar request, but with a 2000tracks template… NASA, SpaceX, Google :wink:

Can’t help with the registry, didn’t dig so deep yet.
Do you have any other machine? Are you using Vienna?

Btw, sounds nice! Well composed, arranged, and programmed (in terms of articulations and overall realism). The only thing, that caught my attention (the rest sounds absolutely fine and quite believable) - is the brasses at 0: 48. All chords have marcato articulation (or how is it called in this particular case). Despite brasses can do that, maybe you should consider using marcato only at the first chord in this sequence? Or maybe pay a little bit more attention to smooth the transitions between chords out. But remember - this is only an opinion from some random guy on the Internet :grin:

1 Like


Thanks for the listen and constructive criticism. I fixed the section you were referring to and even added a few more trumpet patch swells at the end of the line. It turns out I was using a staccato a3 horn articulation instead of marcatto which is why it sounded so abrupt.

The issue:
Tried the registry change which locked my processor at base speed, so I quickly changed back. Per your questions: No other machine besides my work PC. I am not using vienna although based on some additional testing that may fix this issue. I prefer using a separate vi track for each sound/articulation.

Did a few separate tests last night in a blank session.

  1. created 150 empy opus tracks - No Issue
  2. created 150 empty kontakt instance - No Issue

Same test again with a small 25mb perc sample loaded in each (separately). I was only able to get about 30 to 40 tracks before cpu began limiting.

Unsure exactly what this proves, however, I will continue testing.

In windows have you tried setting minimum and maximum CPU speed to 100%, or changing your lower profile?

Windows key >settings > system > power&sleep > additional power settings. (Or you can press windows button + X, then power settings)

Once within the additional power option menu choose a profile or edit one - if you have a “steinberg audio power” plan, then select that. If not then select “high performance”

Then click on “change plan performance” , the “change advanced power settings”.

Scroll down to “processor management” and make sure everything is set to 100%.

You could also check within your bios and see if CPU throttling is enabled

Hello and thank you for your reply! I have already setup a specific profile to the exact settings as the Steinberg preset including the min and max cpu performance speed to 100. I have conducted all my testing using my own power plan and the Steinberg one just to rule out operator error. Results are the same; after hitting X number of VST Instruments my CPU will not surpass 3.00ghz. That being said if exporting or operations like deleting or enabling tracks it will then go up to 3.9ghz as expected during that specific task/operation.

Since I’m using an Origin Laptop (2018) and there is currently no Bios upgrade for my Clevo PA70ES, my BIOS options are limited.

You’re welcome. What options if any do you have within your BIOS?

Glad to be useful :wink:

Yeah, based on what I saw, Vienna uses CPU without limiting clock speed, I’m not promoting them, but maybe you should give it a try. It can be used easily in one machine as well.

I’m also thinking - my laptop with the same 8750h is Asus and it has some software from manufacturer, so maybe you have any utility from Origin running, that can affect CPU?

Looking at your screenshot I see that you’re loading one core 100% it seems. What I would do if I were you is to use a different tool to measure clock speed. At least on my Windows system, using an AMD 5900X, the task manager doesn’t actually show maximum clock speed with that much “resolution”. I think you should consider installing something like HWinfo64 and use its sensors instead.

Modern CPU boosting can be pretty quick and dynamic, meaning that there can be a single core boosting to maximum over a very short amount of time (under a second). So my hunch would be that once you add enough tracks you end up with one core being loaded so heavily that it becomes the bottleneck. Boosting the rest of the cores more doesn’t benefit you in terms of audio performance because things have to be done in a certain order in realtime. When you’re mixing down it’s a different matter.

So try HWinfo64 and see what boost clocks you see.

Thanks for the reply. I do have HWiNFO64. I have tested using this before with the same overall result as HWMonitor and Task Manager. That being said, I will try this again and share the results.

I used to use VEP and I personally wanted to get away from it completely in this new template model. I do agree that it would definitely handle this amount of VSTi’s much better than Cubase alone. That being said, nothing worth doing comes easy! I am willing to work at this!

Only software utility that is Origin specific, and is rather buggy, is the Control Center Software (ccHotkey). This allows me to colorize my keyboard and set fan speed curves. I have had several issues with this software since Intel Extreme Tuning Utility is required to be installed and running for it to work properly. To make matters worse, XTU recently (maybe over a year) locked specific chips (mine being one of them) to not allow undervolting, hence my use of Throttlestop.