Crash on playback going from one flow to another

Hey folks - moving to a second flow the playback first becomes unresponsive (can’t stop it) and then eventually crashes the dorico app. I can provide my file over email if that helps

My file is two flows long for piano and two singers “holding” two voices each… neither flow is particularly long. All instruments are set to “Acoustic piano” using Microsonic.


I’ve had another report of this from another user, though I’ve not had a chance to really dig into it yet. Could you please provide the project itself and specific steps to reproduce the problem?

Can’t seem to do it using the forum messages on my iPad (won’t accept file type) - email address?

Following. I’m likely the other user.

Can you attach it to a private message to Daniel via this forum?

It doesn’t work from my iPad - for some reason the files are greyed out when I try to attach - maybe something to do with file type. When I get back to my laptop I’ll do it from there but will be a while

Zipping often works. But yeah uploading files into the forum from the iPad … actually thinking when I tried it doesn’t work on Safari iOS. Seem to want a drag and drop interface or something, so it has to be laptop/desktop.

I sent Daniel a project that crashed like that, so let’s see if the team can replicate the behavior.

@rubberfingers, your project was a set of canons, yes? And if I remember rightly it crashes when moving from the ninth flow (the penultimate one) into the tenth (the final one)? I’ve tried playing the project back from start to finish several times, both in the shipping App Store version and our development version, and I can’t reproduce the problem.

Can you tell me again precisely how to reproduce the problem? I’m opening your project, and playing it back from start to finish, starting at the beginning of the first flow, and letting it play through to the end.

Thanks, that’s the one. The project crashes when I start playing at the beginning of flow 9. Play continues into flow 10, then no tapping of anything works, or Dorico crashes.

Trying it in Dorico for iPad 1.1, I find that Dorico does appear to hang when it gets to the end of the final flow and is unresponsive for a few seconds, but after about 5-10 seconds it seems to come back to life. Does that match your experience?

I think sometimes it does come back to life now that I think of it - usually have lost patience with it by then and forced a restart. Does crash though as well.

No, Daniel. I touched many icons with no response for more than 30 seconds. Then the app closed down. I’m on the latest version, 1.1. I can try later to time it if you like.

Steve, what kind of iPad are you running Dorico on?

iPad 5th generation, ios 14.7.1


Right, I wonder whether the age of the device could be significant. I’ll give this a try on the iPad 6th generation that we have here at home to see if I can reproduce the problem there.

1 Like

Sounds good. I forgot to say that the last flow plays all the way through, but at no point in that flow can I activate the stop play icon (square) or any other icon. The stop play icon stays square after it plays, and again no touches do anything, until it finally closes the app.

FYI: the 1.2 update behaves the same.

That’s not a surprise: we haven’t been able to yet reliably reproduce the problem, hence we have not yet been able to fix it.

1 Like

FWIW I’m experiencing the same hanging playback issue with this file - originally started on the iPad, then finished on laptop. I’m using a 2015 iPad Pro 12.9"; only the iPad exhibits the hanging playback.

PoulencGloriaSATB.dorico (1.1 MB)