Create Chord Track Finds only One Chord

I have a problem where using the Create Chord Track function only detects one chord across multiple measures/bars. I have a simple 4-bar passage with one chord per bar. They are all 3-note basic chords in C major and all notes are whole notes, active for the duration of each single measure. So there should be 4 chords detected, 1 per bar.

Instead, only the first chord is detected. Now, if I instead highlight each bar of notes 1-by-1 and detect chords 1-by-1, then it successfully detects them.

Is this an issue with the chord track generation feature? It seems it is unable to parse out the chords as separate events, and instead only detected the first chord.

I tried doing this in two ways and they both produce the same result. The first way was to select the 4-bar clip in the project view and go to the Project menu to create the chord track. The second way was to go into the key editor and select all notes of the 4-bar clip, and then detect the chords from there. Both ways produce only one chord. The only way I could get 4 chords detected was to select each bar’s notes 1-by-1 and detect the chords for each.

If you select a bunch of notes across multiple measures it assumes your selection indicates what you deem is a chord. So it will create one single chord out of this long beyond-jazz arpeggiated chord you’ve selected.

Instead don’t select any notes and let Cubase find the changes.

Thank you! This works.