cresc. – – – –

I’m working with a pre-established style guide and need to input “cresc.” with trailing hyphens or preferably an en-dash. I can manually do this with a suffix but would prefer an option that automatically adds the preferred character when stretching the cresc using its handles.

May I ask for an extension to the Gradual style option?

Thank you…

I think this is something you can change in engraving options, Dynamics page. In an Advanced option, you can change the dash length or the points thickness. Hope it helps

Marc,

Thank you for the reply (and for all the other help you give – you are very generous with your time).

Unfortunately, the Engrave Mode options are only for dotted continuations and so don’t help me. Back to the developers, I think…

You can set the style to ‘dashed’ in the properties panel, and even adjust the exact length of the dash and the spaces between the dashes.

This is a hidden one… because if you don’t look closely, the cresc. and the cresc… look very similar to me, and I had this issue. It can be done, you just have to look closely and select the one with the multiple dots following it in the properties panel.

Robby

I’m just not getting this, I’m afraid.

I know about the cresc… option, I have selected Dashed and, in the example below, set a ridiculously large line dot size and line dot gap and yet I still get the default behaviour.

I’d be grateful were someone to try this to see whether they get the same result. My output is attached below…

Either I’m missing something blindingly obvious or it’s a bug…

Thanks!

I do not think this is a bug. Maybe if you could send a picture of the expected behavior, in a real score, it would help D’s team to guide you.

@Marc: I was only suggesting it may be a bug if vilnai and Robby Poole can do this but I can’t. However, file attached, as you suggest. I have tried this on different machines and different operating systems (El Capitan and High Sierra). Still the same… or should I say “still the same – – –”

@fkretlow: You can get customised spaced dashes in Engrave mode? I can’t do it there either. How did you do it?
Cresc dash original.png

Now that I see what you are looking for, I understand I gave you the right answer the first time. Only with not enough details, I think.

This result

is achieved with these values in Engraving options, Dynamics, advanced options

Hope it helps !
Capture d’écran 2017-10-03 à 16.15.48.png
Capture d’écran 2017-10-03 à 16.15.55.png

Marc: thank you, that is a solution which certainly helps in this case. Problem solved, at least for this score.

However, if I’m not mistaken that’s going to apply to the entire file (i.e. for all gradual dynamic texts with lines). What confuses me somewhat is that we can change text with dots on an individual basis in the parameters box at the bottom of the screen but not for text with lines.

I guess this is a little like being able to manipulate stems in the parameters box but direction of stems via context sensitive mouse menus. Inconsistencies such as these still cause me some confusion…

Beechside, just tried it myself. There seems to be something missing in the proterties panel. When switching to dashes, there should be options to adjust the dahses, but you can only adjust the size and the space between points.


Perhaps Daniel can explain this.

If you’ve clicked on a specific “cresc.----” line and make the adjustments, it should only pertain to that particular mark. It would only affect the entire score if you were adjusting things in the notation options dialogue.

Well, Romanos401,
Since I was changing settings in the Engraving options to achieve the desired result, Beechside is right to think it will affect all those gradual dynamics using dashed lines in the document. On the other hand, I do not know why it would be a problem.
HeiPet is also right to think something is missing in the properties panel. If you want to fine tune your gradual dynamic with dots, it’s perfect, but impossible with dashed lines. Looks like this has not been completely finished there… :wink:

I agree that the difference between “cresc.” and “cresc…” in the dynamic gradual style property is easy to miss at first glance, especially as engraving options can be set which mean “cresc…” doesn’t actually produce dots in your score.

Elsewhere on this forum it has been argued that the fact that enabling a different SMuFL music font also changes the Dorico UI to match is a feature, because it means that what users see in the UI closely matches what is actually created in the score.

Following that argument, the display of the dynamic gradual style property should reflect the current engraving options.

You’re quite right, Heiko: there’s a little bug in the code that hides and shows the properties so that only the most relevant properties appear. We’ll take care of this in the next update, all being well. Thanks to all in this thread for reporting the problem.

I missed the fact that you were in engraving options… I guess you’re right lol! :stuck_out_tongue: