Crossfades not working

Hi, I am not that used to editing audio but have been trying for the last hour or so do do a simple crossfade.
I have watched you tube videos to verify but I cannot get the crossfade to happen. In key commands I have confirmed that “x” is allocated to the task.
In the Audio drop down menu it shows X for crossfades, yet I have never seen it highlighted like for example A for fades. fades I can do all day but crossfade I cannot get to work. Is it just my system or is this a bug or am I too angry for my crossness to fade?

Definitely a bug as have reallocated shortcut “X” to another command and that worked. Reallocated back and not working.
Maybe something to do with preferences somewhere…

Absolutely not a bug!

Untick Delete Overlaps in Preferences - Editing