Cuabse 5 Hanging on Initializing VST 2x Plugin

I believe this problem was discussed in the archived forum, but I don’t think anybody came up with a solution (at least, not one that’s working for me). Here’s the problem:

For some reason, when I start up Cubase 5.53 (or earlier 5.x versions), 32 bit (this isn’t a problem with the 64 bit version), it hangs as it attempts to scan my entire computer for plug-ins, attempting to load programs that clearly have nothing to do with music. It gets stuck here:


Initializing VST 2x Plugin -> (any random program)

How can I make this stop, or at least get Cubase to only scan the appropriate directories?

I’ve tried uninstalling and re-installing the program, but this isn’t working. Now, I was able to set the program up on a whole new partition – essentially a clean install – -- but I have so many programs that I’d have to reinstall on that new partition that I’m really hoping I don’t need it.

Incidentally, I’m only having this problem because when I upgraded to Cubase 6, I made the mistake of uninstalling Cubase 5, thinking I wouldn’t need it any more, but then found a serious bug in Cubase 6 which has made it pretty unusable (see my post about audio lanes multiplying out of control every time I save and re-open a project).

Anyway, any help would be appreciated.

TIA

Alan

Check your VST search paths. I’m guessing something like C:\ is listed therefore searching all of drive C:\

Ron

1 Like

Thanks. But how do I change those settings when I can’t even get Cubase to open? Is there a way to do it from outside the program itself?

I believe you want to “trash preferences”

See
https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/removing-the-preferences-of-the-sequencer/kb_back/2020.html?tx_p77sbknowledgebase_pi1[o_system]=1&tx_p77sbknowledgebase_pi1[productfamily]=2

You will need to login to see this page.

You might be able to edit the xml directly but I’ve not checked.

Ron

OK - you might try this:

Edit (make a backup first) the file Vst2xPlugins.xml

Search for Vst2xPlugManager

Mine was at the end of the file.

I have an entry that looks like this:

      <item>
         <string name="Group" value="Vst2xPlugManager"/>
         <member name="Values">
            <member name="PathList">
               <list name="paths" type="obj">
                  <obj class="FNPath" ID="277017056">
                     <string name="Name" value="VST2" wide="true"/>
                     <string name="Path" value="C:\Program Files (x86)\Common Files\Steinberg\" wide="true"/>
                     <int name="Type" value="1"/>
                  </obj>
                  <obj class="FNPath" ID="277011808">
                     <string name="Name" value="Instruments" wide="true"/>
                     <string name="Path" value="C:\Vstplugins\32-bit\" wide="true"/>
                     <int name="Type" value="1"/>
                  </obj>
                  <obj class="FNPath" ID="277012064">
                     <string name="Name" value="Plugins" wide="true"/>
                     <string name="Path" value="C:\Vstplugins\32-bit\" wide="true"/>
                     <int name="Type" value="1"/>
                  </obj>
                  <obj class="FNPath" ID="277016928">
                     <string name="Name" value="Vstplugins" wide="true"/>
                     <string name="Path" value="C:\" wide="true"/>
                     <int name="Type" value="1"/>
                  </obj>
               </list>
            </member>
         </member>
      </item>

Check those paths as those are the paths that it searches for the dlls. Notice that the full path is a combo of two lines:

= C:\VstPlugins

Ron

Thanks for the help, Ron – I’ll try it all and let you know how it went.

Have a great weekend.

Alan

Hello,

I’m having this same issue as of last week, spontanously. It looks like Cubase 5.5.3 32bit is scanning my entire C: for dll’s that might be plugins. In this proces it crashes. Cubase 5 64bit just runs without any problem.

Can’t find much about this on the web. What was your solution?

I understand it was a long time ago… Cheers.

im having the same problem,

i deleted vstplugmanger.dll in components then its loads up
but you can change the path back to there original settings.
as u can click on the path option!

i even try downloading a new vst plugin manager dll, still no luck, still scans the whole c drive…

im starting to believe there no way to revert this :frowning:

I’m having exactly the same problem jenny. Did you ever find a solution?

Also did you mean to write “you can’t change the path back to their original settings as you can’t click on the path option”?? This is what’s happening to me also…

Hi Ron. Should C:\ always have something after it or does it just look at the line above? I’d really, really love to know what’s going on here as I have exactly the same problem…

I tried this but it just re-creates the app data\cubase 5 folder after trying to load cubase!!??

Follow the troubleshooting procedure outlined here in the “Solving VST Plug-in Troubles” section.

https://helpcenter.steinberg.de/hc/en-us/articles/206618850-Troubleshooting-for-Cubase-Nuendo-and-Sequel-on-Windows#plugins

BTW, I took a guess at your system specs so this link is for a pc running windows os.

Regards. :sunglasses: