Cubase 10.5.12 - windows minimizing on loading plugins

Hi,
I’m having an issue with Cubase Pro 10.5.12 whereas when I load in a VST plugin, my Cubase windows minimize and I can’t switch back until the plugin is loaded (which is taking around 5 to 10 seconds, so longer than on previous versions).

This is coupled with the common issues people are having, with heavy performance loads etc.

Has anyone else experienced this and found the culprit?

Thanks!

(This isn’t happening on Cubase Pro 10 / I am running Cubase in Administrator mode)

Hi,

Could you try in Cubase Safe Start Mode, please?

Hi, thanks for the reply! Yes, I have tried running Cubase in Safe Mode (disabling preferences and also third party plugins)

The only difference is that the stock plugins seem to load quicker than 3rd party (except for Groove Agent SE), but when loading the stock plugins, Cubase still minimizes until they have loaded.

Hi,

What exactly do you mean “until they have loaded”? Do you mean when you open the plug-in GUI?

Yes, so when I add an Instrument track, I select the VST and hit “add track” and then Cubase minimizes until the plugin has loaded, and then Cubase pops up again.

I have the same issue. Everytime I load a virtual instrument, the Cubase 10.5 window minimizes/disappears in the background behind other windows. Sometimes it maximizes again after the plugin has loaded, sometimes I have to maximize it manually. Started happening after upgrading to Cubase 10.5, super annoying.

Having a similar issue: https://www.steinberg.net/forums/viewtopic.php?f=286&t=183155

I have a similar issue- Cubase minimizes/dissapears when clicking apply/ok button on modal windows. Also happens with plugin windows. Started with version 10.5, same in 10.5.12

The most likely to happen is when dealing with the preferences window

I also have the same issue, Win10. Every time I add any type of track, cubase minimizes and whatever other application happens to be open (e.g spotify) pops up and takes focus. I then have to click on cubase again to regain focus. Super annoying. Are there any solutions to this? I’ve tried everything I can think of, including trashing prefs.

I have the same issue here. Just when creating new sessions and loading vsti.

10.5.20 did not solve this. Come on Steinberg, this is the kind of stuff that should be fixed before release. It looks very clumsy.

Just updated to 11 from 10. Started having this issue.

Still no fix for this in the latest version of Cubase Pro 11.

Probably the most annoying bug I’ve experienced in Cubase.