Cubase 10.5.20 Update Crashes

I just updated my Mac Cubase 10.5.0 Pro to v10.5.20 via the Steinberg Download Assistant. With v10.5.20 having been released on 05 May 2020, I felt it was reasonably safe to install this minor maintenance update. Unfortunately, it now refuses to load even in safe mode. Also, an additional vst2xscanner error message appears, which never appeared prior to this update. Please see the attachments.

Despite trying both to deactivate all third party plug-ins and to disable program preferences, Cubase 10.5.20 Pro refuses to load. During its attempt to load, I also noticed that it tried to blacklist Kontakt, even though I had no issue with Kontakt in Cubase Pro version 10.5.0. Strange. The same happened with another plugin (do not recall which one), and, again, this other plugin also caused no issues with v10.5.0. I did not capture at what point during the attempted load Cubase quit unexpectedly. I tried the “reopen” and “ignore” options in the “unexpectedly quit” dialog box. Neither option helped.

I have a crash report, which I will send to Steinberg directly. I’ve rebooted my system several times, but the Cubase application fails to load.

In the meanwhile, I am trying to figure out how to revert back to Cubase 10.5.0 Pro. I have the “Cubase_10.5_Update_Installer_mac.dmg” file that I had downloaded in the past via the Steinberg Download Assistant, after I purchased an update from v10.0 to v10.5. However, I am hesitant to run that installer, as I do not know if the v10.5.20 update will impede the installer from producing a “clean rollback”. My guess is that running this installer will not remove all the v10.5.20 files, which may exist in total across multiple folders.

Maybe I’ve overlooked a simple solution? Your feedback is greatly appreciated. Thank you.


2020-10-03 vst2scanner error.png

[UPDATE]

I’ve been doing some investigating and have some additional information that may be helpful for discovering and then resolving the issue. I generated Cubase & vst2scanner crash reports. Cubase crashed first based upon its 1900-second “time awake since boot” value, as opposed to the 9400-second vst2xscanner “time awake since boot” value. After several attempts I was able to load Cubase in “safe mode” with all third-party plugins deactivated. The plugin report that I generated from the VST plugin manager reported a list of all the native Cubase VST3 plugins only plus one Voxengo VST3 plugin, which makes sense.

Next, I rescanned my plugins from the VST plugin manager, which loaded all the remaining third-party VST3 plugins but no VST2.x plugins. I know later versions of Cubase do not support VST2, although I’m not sure if this means Cubase does not allow VST2 plugins at all or it does not provide technical support for any issues that may entail (64-bit) VST2 plugins. With Cubase 10.5.0 Pro, I recall the VST plugin manager displayed all my VST2.x and VST3 plugins. Unfortunately, when I regenerated a plugin report, no VST2.x plugins were listed, but the remaining third-party VST3 plugins were listed. My guess is that “safe mode” prevents the list from including VST2.x plugins.

Regarding the Cubase and vst2xscanner crash reports, here are snippets from each:

======
Cubase

Crashed Thread: 2 Dispatch queue: com.apple.root.user-interactive-qos

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000014785e220
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

VM Regions Near 0x14785e220:
WebKit Malloc 0000000117100000-0000000117800000 [ 7168K] rw-/rwx SM=PRV -->
JS JIT generated code 000043d202800000-000043d202801000 [ 4K] —/rwx SM=NUL

Application Specific Information:
objc_msgSend() selector name: retain

…and a portion of its backtrace…

Thread 2 Crashed:: Dispatch queue: com.apple.root.user-interactive-qos
0 libobjc.A.dylib 0x00007fff7ce1cea9 objc_msgSend + 41
1 com.apple.QuartzCore 0x00007fff612f2c30 _XImageQueueDidComposite + 118
2 com.apple.QuartzCore 0x00007fff611a0b42 invocation function for block in CA::Context::client_port() + 211
3 libdispatch.dylib 0x00007fff7d9ddd50 _dispatch_client_callout + 8
4 libdispatch.dylib 0x00007fff7d9f0e76 _dispatch_continuation_pop + 472
5 libdispatch.dylib 0x00007fff7d9e0018 _dispatch_source_invoke + 620
6 libdispatch.dylib 0x00007fff7d9f2f02 _dispatch_root_queue_drain_deferred_wlh + 332
7 libdispatch.dylib 0x00007fff7d9f6d16 _dispatch_workloop_worker_thread + 880
8 libsystem_pthread.dylib 0x00007fff7dca2033 _pthread_wqthread + 980
9 libsystem_pthread.dylib 0x00007fff7dca1c4d start_wqthread + 13

===========
vst2xscanner

Crashed Thread: 0 Dispatch queue: com.apple.main-thread
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000115f25a38
Exception Note: EXC_CORPSE_NOTIFY
Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]
VM Regions Near 0x115f25a38:
WebKit Malloc 0000000114100000-0000000114800000 [ 7168K] rw-/rwx SM=PRV -->
MALLOC_LARGE_REUSABLE 0000000116617000-0000000116817000 [ 2048K] rw-/rwx SM=PRV

…and a portion of its backtrace…

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 libobjc.A.dylib 0x00007fff7ce1bbe4 search_method_list(method_list_t const*, objc_selector*) + 1
1 libobjc.A.dylib 0x00007fff7ce1dec6 lookUpImpOrForward + 287
2 libobjc.A.dylib 0x00007fff7ce1d914 objc_msgSend_uncached + 68
3 com.apple.WebKitLegacy 0x00007fff645c95e8 +[WebHTMLView initialize] + 104
4 libobjc.A.dylib 0x00007fff7ce2ce3c CALLING_SOME
+initialize_METHOD + 19
5 libobjc.A.dylib 0x00007fff7ce1e3b8 _class_initialize + 288
6 libobjc.A.dylib 0x00007fff7ce1de8b lookUpImpOrForward + 228
7 libobjc.A.dylib 0x00007fff7ce1d914 _objc_msgSend_uncached + 68
8 com.apple.WebKitLegacy 0x00007fff645c92a2 +[WebFrameView(WebInternal) _viewTypesAllowImageTypeOmission:] + 98
9 com.apple.WebKitLegacy 0x00007fff645c902a +[WebView(WebPrivate) _viewClass:andRepresentationClass:forMIMEType:allowingPlugins:] + 74
10 com.apple.WebKitLegacy 0x00007fff645c8fcb + [WebFrameView(WebInternal) _viewClassForMIMEType:allowingPlugins:] + 43
11 com.apple.WebKitLegacy 0x00007fff645c899a WebFrameLoaderClient::transitionToCommittedForNewPage() + 106
12 com.apple.WebCore 0x00007fff636b0859 WebCore::FrameLoader::transitionToCommitted(WebCore::CachedPage*) + 409
13 com.apple.WebCore 0x00007fff630f8dc5 WebCore::FrameLoader::commitProvisionalLoad() + 341
14 com.apple.WebCore 0x00007fff63580621 WebCore::DocumentLoader::finishedLoading() + 353
15 com.apple.WebCore 0x00007fff630f850b WebCore::DocumentLoader::maybeLoadEmpty() + 891
16 com.apple.WebCore 0x00007fff630f7355 WebCore::DocumentLoader::startLoadingMainResource() + 597
17 com.apple.WebCore 0x00007fff630f62f7 WebCore::FrameLoader::init() + 599
18 com.apple.WebKitLegacy 0x00007fff645c7c47 + [WebFrame(WebInternal) _createMainFrameWithPage:frameName:frameView:] + 327
19 com.apple.WebKitLegacy 0x00007fff645c5ff0 -[WebView(WebPrivate) _commonInitializationWithFrameName:groupName:] + 3104
20 com.apple.WebKitLegacy 0x00007fff646fa092 -[WebView(WebPrivate) _initWithFrame:frameName:groupName:] + 162
21 com.apple.WebKitLegacy 0x00007fff645d691b -[WebView initWithFrame:frameName:groupName:] + 187
22 com.apple.WebKitLegacy 0x00007fff645ea73c -[WebView initWithFrame:] + 60
23 com.apple.AppKit 0x00007fff53603709 -[NSView init] + 62
24 vst2xscanner 0x000000010f6c5ed9 0x10f6be000 + 32473
25 vst2xscanner 0x000000010f6c0ac0 0x10f6be000 + 10944
26 vst2xscanner 0x000000010f6c0f5e 0x10f6be000 + 12126
27 libdyld.dylib 0x00007fff7da17115 start + 1

Lastly, if this is relevant, I have the latest version of iLok installed on my system. Also, I tried unlocking the System Preferences privacy setting. Note, I tried this after generating the crash reports, which is why the crash reports both contain the following statement:

System Integrity Protection: enabled

Aside from this, I am running a mid-2012 Retina w/2.7 GHz an Intel i7 processor, 16 GB 1600 MHz DDR3 RAM, and NVIDIA GeForce GT 650M 1 GB graphics card plus the native Intel HD Graphics 4000 1536 MB integrated graphics chip. My operating system is OS X v10.13.3 (“High Sierra”). Not having done anything on my system from the time I had Cubase v10.5.0 to the time I updated to v10.5.20, I assume the issue lies possibly with vst2xscanner or something in the v10.5.20 update which side effect is to crash vst2xscanner. The only two things I did after the update were (1) to update my iLok manager software and (2) to update my Native Instruments software.

I hope this provides some additional insight that leads to resolving this issue. Thank you.