Cubase 10.5 and Mackie MCU Pro w 2 extenders not working

Please could someone help me – I have a Mackie MCU Pro with 2 extenders that always worked amazing in Cubase 8 but since I moved to Cubase 10.5 I can not get it to work – I have copied over the settings exactly and the extenders and the Mackie Pro respond – I just can’t get them to work in the right order for example they all seem to start and work from fader 9 - 16 . I have tried everything and scoured the net so if anyone has any suggestions Please write me back OR even better call me my name is Frank 647-996-0210
Thanks in advance – I do appreciate any help that anyone can give me - I really do :slight_smile:


You have to take care that you are really using 3 unique MIDI Ports (In and Out). If you would couple some, the devices would couple.

If I remember right, the order in the Studio Setup > Remote Devices is from bottom to top. So the bottom is the most left device (even though it’s probably named Mackie Control 3 in your case).

HI Martin , thanks for replying – I joined the forum probably 10 years ago and haven’t used it in probably as many years – I have a question – do you have a Mackie unit , and even better do you have the 3 units all together ?
If so could you take a screen shot of the midi set up for each Mackie please . I know I am asking alot but I have tried everything and am at my wits end and don’t want to stop using my beautiful 24 channel surface .
Thanking you in advance :slight_smile:


I don’t have Mackie units now. But I was using 3 units in one studio in the past. How are the built only our table? And how are they connected? I expect they are build like this:
Fader Control 1, Fader Control 2, Master Control.

If yes, then the setup in Cubase, in the Generic Remote fodder, would be:
Mackie Control | MIDI Ports: Master Control
Mackie Control 2 | MIDI Ports: Fader Control 2
Mackie Control 3 | MIDI Ports: Fader Control 1

Yes that is exactly the layout – they worked fine on Cubase 8 Pro – and I have set them up exactly so I really do not know what happened here


Are you on Mac or windows?

PC- so last night when I assigned the Mackie Head Unit ( the one to the right ) to the first MCU pro tab in the device manager under Midi Ports the unit responded but ONLY did tracks 17 - 24 – and I did try to move the Fader Banks to the left , but no moving – but when I move the Fader banks to the right it moves to the over 8 and 8 tracks – so something is off in Cubase I think


Could you attach a screenshots of the 3 Mackie Control settings in the Studio Setup, please?

This is working 100% at my side:



Thank you for the screenshots @delta. This confirms that the most left unit is at the bottom in the list.

Hello delta. I’ve got 10.5 and was thinking of getting a mackie mcu. Are they pretty seemless with cubase ?