Cubase 10.5 creates events when you play certain keys on my controller keyboard

Buenos días,

For a few weeks when I use a vst or midi instrument through my piano controller, certain keys of the instrument create different events, such as: open mix console, automatically create several versions of the current project with numbering 1, 2, 3 … or other types of varied events.

I would appreciate if you could help me and tell me what I can do to avoid this, since it prevents me from being able to play the piano normally using vst or midi instruments, because multiple different events are created when doing it. Thank you!

Buenos días,

Desde hace unas semanas cuando utilizo un instrumento vst o midi a través de mi controlador de piano, determinadas teclas del mismo crean eventos distintos, como por ejemplo: abrir mix console, crear automáticamente varias versiones del proyecto en curso con numeración 1, 2 ,3 … u otro tipo de eventos variados.
Os agradecería pudieras ayudarme y decirme qué puedo hacer para evitar esto, ya que me impide poder tocar con normalidad el piano utilizando instrumentos vst o midi, porque se crean múltiples eventos distintos al hacerlo.
Muchas gracias!

https://steinberg.help/cubase_pro/v10.5/en/cubase_nuendo/topics/setting_up/setting_up_midi_inputs_setting_up_t.html?hl=all%2Cmidi%2Cinputs

Hola Jorge! Me gustaría poder escribirle en español, pero todavía es demasiado difícil para mí. Es muy probable que su problema se resuelva en el enlace que he publicado, específicamente en la “Nota”, sobre “Todas las entradas MIDI”. (Traducción de SpanishDict)

Hi, Jorge! I wish I could write to you in Spanish, but it’s still too difficult for me. It’s very probable that your problem is solved in the link I posted, especially in the “Note”, about “All MIDI Inputs”.

Hi ggmanestrakiuch
Thank you very much for your quick reply. However, if I do what you indicate, I am afraid that the sound of the vst will not be heard.
You may need to investigate this for a longer time.
Again, thank you very much!

If you have just one keyboard that you wish to use both for playing, and for sending macros through the piano keys, there are some options:

  • If your keyboard has special pages that switch with the press of a button (VST control, DAW control) use them.

  • If you don’t have this on your keyboard, you can either change to a different MIDI channel when you want to play normally (so that the generic remote will not “listen” to the notes it expects to), or you can use a MIDI Insert Transformer, to automatically change the channel of the notes you play.

Already solved! the problem was that within the Studio Settings, by mistake, I had my digital piano configured as Cubase’s remote controller. I changed the settings and added the nanoKontrol2 as a Cubase remote controller and finally solved!
Thank you very much for your help.

1 Like

Perfect!