Cubase 10.5 - E-licenser & plug in license issues

Hi All,

This is my first post today, I bought Cubase 10.5 a few weeks ago as an upgrade and wondered if anyone could help or advise me please?

I installed the plugin/vst’s yet when I run them I have similar messages saying no valid license detected etc… yet I have the correct physical e-licenser, everything as I purchased it is running. Ive uninstalled them, and reinstalled them.

I have sound banks saved on a larger hard drive and the plugins on my c drive, which is an SSD.

I cant work out where I’ve gone wrong here, and debating whether to uninstall the lot inc cubase and put everything on c drive, even though the drive is much smaller.

Very stuck/lost at the moment as it doesnt see the e-licenser at all but did on first install.

Thank you in advance, J

Hi and welcome,

If you open the eLCC application, can you see the USB-eLicenser there? Can you see Cubase 10.5 license there? Is it 10.5 or just 10?

Thank you Martin, much appreciated!

In my licenses I see Cubase pro 10.5, which seems correct. I have an expired Cubase elements 8 trial in there, and a soft e-licenser in there too. Im unsure how to get rid of those, or if they’re interfering.

I had some installed on another drive, linking to them which may have been an issue (Halion was one of these) I uninstalled and re-installed on my main ssd c drive, which has sorted it for that one. Not all though, frustratingly (in an ideal worl I’d have everything on the c drive but the ssd isnt big enough)


You can keep the Trial licenses there. That’s not a problem.

So what licenses issues do you have now?

I would recommend to install all plug-ins to the system drive. Actually it’s not supported to install to other drives. But, you can move the sound libraries (these are the really big files) to other drive. To do so, use the Steinberg Library Manager, please.

Thank you Martin, that does make a lot of sense as you mention & I think on it (I was being over-cautious, as I thought the soundbanks needed to be there too)

I have the cubase pro 10.5 physical e-licenser in the eLC software.

Im going to try again shortly to see what runs, what doesnt & install the software itself into the c drive (I had iphone backups etc… in there which were eating space too, all gone now so Ive bought some flexibility)

I did an update a few weeks ago and afterwards I cannot get access to Padshop 2 presets. I cannot use them. the message I get is ‘Some content could not be loaded. Either, licenses are missing, or trial licenses have expired. Padshop presents 2. find out more on how to activate your trial licenses permanently, or remove expired licenses.’ I have updated my e licenser. I had tried to download 10.5 thinking it was an update as in maintenance which could have caused a problem, not sure. tried to connect it to cubase 10 again .not coming right, please help?


Padshop 2 is part of Cubase 10.5 license, but not Cubase 10.0 license. Uninstall the Padshop 2 library, please.