Cubase 10.5 Pro: audio loop falls out of sync with tempo changes

Hi there,

I can’t get one of the audio loops to be in sync with the project tempo changes. It is perfectly in sync with the rest of the MIDI events of the adjacent tracks if the tempo is FIXED throughout the entire project. But as soon as I bend that straight tempo line, the loop falls out of sync. :frowning:
Is it some kind of specific quality of this particular loop that accounts for its stubbornness, or have I overlooked some adjustments and tricks which are required in similar settings?
PS. All of the loops are in Musical Mode, and the note and curved line symbols are present in the upper right corners, the Tempo Track is activated (please take a look at the attachment).

Thank you for your comments in advance.
Windows 10/64bit, Cubase 10.5 Pro

Hi,

The loop cannot be aligned to the grid, as you expect. You have 2/4 Time Signature until the bar 28. The bar 28 is 3/4 therefore 1 beat is missing in the loop, therefore the loop stops at 28.2., as expected.

Martin, thanks for your prompt response! The loop you refer to is actually in PERFECT sync. I have attached that screenshot just to demonstrate my project settings. The problem is NOT with the loop stopping unexpectedly, but with the loop falling out of sync when the tempo changes. Let me put it this way, if I set any fixed tempo from the start to the end (be it 50bpm, 90bpm, 200bpm or whatever), the loops get synced and follow the tempo seemlessly. But as soon as I make any tempo changes within the project, the first loop falls out of sync - it keeps playing back, but playing back asynchronously. The rest of the loops (the one with ‘115bpm’ tag you referred to included) follow the tempo changes perfectly.
https://filecloud.me/5xok1t3p5bq5.html - this is my ‘rogue loop’ labelled PUSHER_drum_loop_casual_8_7_time_150bpm

Hi,

Could you link to a video screen capture, please?

Martin, below is the link:
https://www.youtube.com/watch?v=hJ2H1BKKwxo&feature=youtu.be

Hi,

Thank you for the video.

Interesting, I have never met this. My guess is, it’s because of the specific audio file and the way, how can the the engine handle it.