Cubase 10.5 Still Has A Memory Leak

Every month I take time away from Nuendo and try to work in Cubase 10.5. There are so many great features, and I especially like that the clip of any audio or midi I am currently editing gets highlighted in black, instead of circled in gold or red like in Nuendo, which I cannot see (being partially colorblind)

Anyway, my latest foray yesterday resulted in the same bugs that I have found from the first release of 10.5, in my opinion the most buggy version of any Steinberg software ever. I worked on my arrangement for many hours without any issues, but all of a sudden the CPU spiked so high that the song wouldn’t play, it kept stopping. I started turning off VSTi’s, plugins, etc. Nothing helped. I disabled instruments, muted folders, etc. Nope, CPU still spiking to the edge. I even turned the latency for my Scarlett Interface up to 2048. Nope. I closed Cubase and opened the exact same song in Nuendo 10.2.20. With the latency set to 256, the song played fine. CPU was down where I expected it, around 40%.

And so ended my yet again monthly visit to Cubase 10.5. Oh yeah, the song played fine in Cubase 10.0. Of course, that’s the last Cubase version that was reliable and stable for me. I’ve said it before and I will repeat myself ad infinitum - something is inherently wrong with Cubase 10.5 and it never gets really fixed with the updates, just smoothed over for a bit like a bandage on a broken arm. The arm is still broken, just like this version.

Yes I agree with you. I even get more spikes when soloing an instrument which stops the song, than when playing the whole song. Turning off “suspend Vst3” is not a solution. I am very disappointed with this program in its current form. Even Cubase “tool tips/options” within their preference windows etc are written in yellow on a white background, which is unreadable.In effect I feel I have wasted the last 6 months or so messing around trying to fix problems.

Partly apple is part of the problem. They have removed stable interfaces for applications, and they also have stated that they prioritize stability over performance. It effects audio and graphics and mostly USB and they are enforcing vendors to comply.

Ahh, you’ve touched on another problem I’ve encountered in Cubase 10.5 that nobody seems to mention- you can’t read certain dialogue text. In the notepad view, the cursor is invisible if you are using the “dark” mode in the OS. If I switch back to “light” mode, other text becomes invisible. Really?? Like I mentioned, I go back to Nuendo 10 or Cubase 10 and none of these problems occur.

Yep…just had the spike today. Cubase 10.5.12 going along fine and dandy and then out of nowhere sputters/stutters/chokes and will not play with a corresponding CPU overload. Then, just as strangely, it will “release” from the CPU choke hold, but, then again into overload.

Yes. Exactly. That’s what happens here too. I am serious, there is something inherently wrong with 10.5, and it’s been there from the initial release. All the updates do is make it a little better for a little while, but the disease never really goes away. Throw this version out and make 11 a straight successor to 10.0, with nothing of 10.5 included. I am terrified that Nuendo 10.5 will have all the bugs of Cubase 10.5. I am running Nuendo 10.2.20 now, and like Cubase 10.0 it runs great. No leaks.

+1

Been doing some tutorials. One synth, one track, no midi. Performance meters at around 25%. After a while Cubase starts spiking away even while I’m in Safari watching a video.

Edit: To be clearer, it’s not constant overload. It’s just one shot spikes that trip the red indicator light and sometimes trigger the warning dialog. When I look, the performance meters are still at around 25%.

:frowning::frowning::frowning::frowning:

I have to agree with you that this is one on my biggest issues with Cubase. The memory leak is a constant headache for me when working on multiple tracks. After about 5 project opens (and closes) the memory is full. The only way to claim it back is to restart Cubase. Then I’m good to go for another hour of glitch free

Please please find a solution steinberg.

The program “Clean my Mac” helps too. (We have to buy a program in order to successfully run a program!!)

Going back to Cubase 10.0.60 solves the problem too.

I would wager this isnt a memory leak unless you confirm with 3rd party tools. What you describe sounds exactly like the hyperthreading issue that plagues so many people/platforms, Mac and Win.

I may have mentioned this in front of some of you before, but my threads always get derailed by several arrogant users who mock the issue and try to obfuscate it – have you tried disabling all virtual cores on your CPU via your BIOS? Turn them all off and make sure everything is stock (voltages, freqs, latency values, etc), and then try cubase again using the same projects that are giving you spikes eventually. What you describe sounds EXACTLY like what I dealt with for a couple months until figuring it out. Steinberg is not being forthcoming or helpful about this at all.

Agree with Milkman76, this isn’t a memory leak but more likely the cpu spike issue on Mac.

Cubase 10.5 update should have been free :man_shrugging:

I didn’t know we could adjust anything to do with hyper threading on a Mac. I knew how to disable that in the bios on a PC - how do you disable it on a Mac? Do I want to disable it? Will it affect my other programs? What does hyper threading do?

Soooo many questions. Thanks for helping.

Sadly I do not have a mac in my possession right now to test along with you, and am all windows and linux at home. I have actually never needed to turn off/on virtual cores on a mac, even when I supported them in a mixed environment at the office, so I genuinely do not know how to disable HT on Mac.

This article is related to another issue, but contains instructions on how to turn off HT from the OS. I am not 100% sure this disables them physically…

https://www.laptopmag.com/articles/apple-disable-hyper-threading-zombieload

This feels like its related to Intel SGX and etc, which was turned on a few years ago to protect 4k/HDR media and make it exceedingly difficult to perform enclave computing… but who knows.

Well…this thread is disappointing. I just bought 10.5 and boom… spikes like crazy. Too bad I didn’t see this sooner. I’m new to Cubase so I didn’t come from an upgrade. I don’t think I can go down to 10 so I’m stuck. Looks like I just have to get used to recording 8 bars at a time. /sadface

Spikes all over here after upgrading my I7 to an I9 and updating Cubase 5 to 10.5. Thought I would gain something with that but instead it’s gotten worse…
Already did everything I could think of: turn off the suspend vst3 plugin processing, disabed hyperthreading in BIOS, activated/deactivated ASIO guard, different buffer setting etc etc.

Older projects, made with C5, seem to do better but I haven’t really messed around with effects in it so it’s really hard to tell. However, a project which was made with C5 but which I have adjusted a lot in 10.5 and saved with 10,5 is almost unworkable, can’t even repeat a few bars with just a kick and a bass without audio dropping every few seconds…

This is really ridiculous and should be fixed by Steinberg. Already thinking about re-installing Cubase 5 or going Sonar :angry:

Sonar is not better than anything. Nothing.

I have found in Cubase 10.0.60 that sometimes when i open a project, i get crazy spikes. I have also found that this is caused by a midi track being record armed and as soon as i disarm the midi track, the spikes stops.

Why do you think this issue is a memory leak?