Cubase 10.5 sysex send/receive


I already searched the forum for threads, but I didn’t really find a solution yet.

I want to remote control a synthesizer via an iPad sysex App (Patch Base) over the CME WIDI uhost - a bluetooth midi interface. I plan on using the iPad app as a real time remote for all supported synth parameters.

The setup is as follows:

  1. I use the App Patch Base for sysex commands on iPad
  2. I connect the iPad via Bluetooth with the CME WIDI uhost
  3. I add and activate a new midi track to cubase, but no sysex commands are coming in.
  4. I send out all incoming midi to another Midi device being the output.

Some facts:

  • There’s also a pitch/bend command on the app, that works perfectly fine. It is recognized in Cubase and the synth reacts as it is supposed to to. The Pitch command is also displayed via the Midi In indicator in Cubase.
  • The CME WIDI uhost has an indicator that reacts when I send sysex commands via the app, so the app / uhost connection is definitely working. The Cubase Midi Indicator does not react.
  • I already deleted the sysex midi filter in Cubase
  • recording sysex isn’t possible neither. It’s just not “coming in”.
  • I also already tried to send sysex via WiFi with the exact same result - Pitch Bend parameter works, the rest does not!

What am I doing wrong? Why does CB not receive/send sysex? That’s quite a basic thing to do and it has to be possible. Can anybody help?

Thanks a lot for your time :slight_smile:


Just to clarify here. When I do a sysex dump to Cubase it records the sysex just fine and sends it back out to change the patches on my synths. The only thing I do is make sure that filter sysex box in the Cubase Prefs is unchecked. The CORRECT midi channel has to be selected for that track. The track has to be record enabled. Recording on the transport. THEN any sysex you send Cubase should get recorded to that track


thank you for the answer, shanabit.

I unchecked the sysex box in the preferences and recorded the midi while changing parameters, both on the synth as well as on the app. It records midi, so all notes, also bends - from the synth as well as from the app. But no sysex commands. Any idea?

What makes me wonder is that midi and bends are coming through, so the routing is correct, but no sysex is coming in.

I can record a video if that helps!


Also, when I send sysex in, Cubase gets frozen and I need to force it to shut down. WTF :smiley:

So it seems like “sometimes” there is some sysex data coming in… I really don’t get what’s going on.

can someone tell me how to get rid of annoying sysex data, every time i import a midi file?!

  1. What sysex data are you actually recording into Cubase?

  2. Can you make a video with what ya doing there?

**Pitch bend, modulation etc are Global Controller commands not sysex per say

Syysex is like a snapshot in time of an external hardware synths
Patches, Programs, Comninations, effects etc settings.

i don’t record sysex data,
it appears when i import midi files!

Go to your PREFS again.

Under MIDI/MIDI FILE, make sure you have AutoDissolve Format 0 UNCHECKED

and your destination as MIDI TRACK

Anyone anyone. I wonder if the OP has checked that box yet?