Cubase 10 And Frontier AlphaTrack Mac OS High Sierra 2020


Has anyone managed to make AlphaTrack work fully with Cubase 10 on Mac OS High Sierra?

Thanks in advance.


Oh, this very old (but quite nice) device…

I tried to make it working several years ago and it was hard in that time already. I’m afraid the driver is 32-bit only. So it wouldn’t work with 64-bit Cubase.

Not that this is any help but it still works perfectly on Windows 10

But not on OS X ! :frowning:

Have you tried it HUI Mode With Cubase Pro 10?

No, not on Windows because I don’t use Pro Tools


You can use HUI protocol in Cubase too. Just click the + button in the Studio Setup and choose Mackie HUI (or Mackie Baby HUI is enough for Alpha Track too) there.


Thank you very much for your reply!

That’s how I use the Alphatrack! But I can’t select tracks with the track buttons!

Hello guys!

I am using the Alphatrack With Cubase 10 in HUI mode. Transport, Mute Solo Record and Fader (Channel Volume) all work great! Even there is a combination (Shift+Flip) that I can change between project and mixconsole windows! But I can not select any track beside the standard 8 tracks :frowning:.

Has anyone managed to fix this?

P.S Also, I found out that steinberg removed the option with the Alphatrack and Tranzport as control protocols on the controllers drop down menu…:frowning:

As far as I know, you have to switch to other Channel Bank, don’t you?

This is not on Steinberg side. Steinberg never installed it. This is Alphatrack and Tranzport vendors component, they have to tak care the component is compatible. Is it 64-bit component?

Hi Martin!

Thank you very much for your reply!

I do not know how to switch channel banks on Alphatrack. :-/

Alphatrack component is 32bit only. :-/


To switch the Channel Banks, you have to send other MIDI Message than switch a channel. Unfortunately I don’t know the MIDI mEssage for HUI and I doubt Alphatrack sends it in the HUI mode. That was the reason, why they had own component, to be able to control Cubase completely. But as it is 32-bit only… :-/

Hi Martin!

Thank you so much for your hints!

Someone else who is trying to make Alphatrack work with Cubase Pro 10?

P.S. In Cubase 6 works fine! :slight_smile: