Cubase 10 Artist Routing bug cannot route FX channels to groups

  1. New Track (empty)

  2. Add Track Audio Track (kick)

  3. Add Track FX track (VERB)
    4 Add Track Group (Grp1)

  4. Choose Audio track - go to outputs - route to (Grp1) - all is fine

  5. Choose FX track (Verb) - go to outputs - no Grp1 showing

However if i do this

  1. New Track (empty)
  2. Add TrackAudio Track (kick)
  3. Add TrackFX track (VERB)
    4 “Add Group Track (Grp1) to selected channels” and I highlight (Kick+VERB) then both are routed at the output stage to (Grp1)

So I can acheieve this however the track I’m trying to do this on is already half mixed i surely should just be able to see the Groups on the output of
any FX channel (unless maybe like you stated about the sends) but as you can see by my list here i’m not seeing the groups on FX channel outputs on new and empty track with nothing assigned anywhere.

I should be able to do this in Artist surely without doing the “trick”


What exactly is the 1st step, please? New track (empty)… As far as I know, you always have to select a track type Audio/MIDI/Instrument.

Sorry step one 1. New track (Is meant as making a new project so that there isn’t any other interactions I used track instead of “create new project” which would be empty. Sorry my oversight just our studio language when we make music we also call them “tracks” :neutral_face:


I can confirm it.

Reported to Steinberg CAN-23119.

Thanks mate!


Disable Preferences > VST > Connect Sends Automatically for Each Newly Created Channel, please. Then it works as expected. When this preferences is enabled, you cannot route to the Group to prevent a feedback.