Cubase 10 Key Edit Bug

I cannot use key edit if my selection is a folder track and an instrument from another track. All the instruments in the folder track vanish when moving a note in key edit. They will play back even though they cannot be seen in the key edit page.

I will be using my old Cubase 9.5 for key edit work.
The Cubase 10 Key Edit folder-track-bug particularly effects me as I always select my instruments by selecting folder tracks (its much easier and more practical).

Hi and welcome,

It works to me here. Could you try in Cubase Safe Start Mode, please?

Do you mean start the computer in safe mode?

Hi,

No, I mean Cubase Safe Start Mode and disable preferences. Please search in manual.

Actually, Cubase Safe Start Mode is not described in the manual. And it’s currently not found by searching Steinberg Support(*) either.

Anyway, it’s described here (found by using Google):
https://www.steinberg.net/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

(*) All Steinberg Support articles now seems to be linked to helpcenter.steinberg.de, the link above is to steinberg.net

  1. Starting Cubase under Steinberg safe mode, disabling the preferences option, did not solve the key edit problem unfortunately.
  2. “Initialising preferences” does not work because typing in the Run box “%appdata%Steinberg” and pressing return brings up an error screen. Relabelling “Cubase 10…” as “xCubase 10…” using a trial and error method of finding the cubase folder also did not work.
  3. Reinstalling Cubase 10 from my old download file did not solve the key edit problem.
  4. In the same article Steinberg also offers various ad hoc methods for removing problem files but these are suggestions without step by step implementation, and I am not able to implement them.

My key edit problem is looking like, or at least must be treated as a cubase 10 bug which can be solved if the user is sufficiently adept at computer technicalities. Or, if the problem does not arise for others then it might be that my problem has not been presented correctly.

Hi,

  1. Type just %appdata% then click to Steinberg folder, etc.

Yes, I have shuffled my way to the Steinberg folder and renamed Cubase 10 as xCubase 10. No luck though. I will remove my preferences folders once I find them.

Hi,

Could you please make a video-screen capture of the issue?

Here are three screen shots.
The piano is in red, while all the other instruments in the “Strings” folder are different colours (blue, green, etc). (Pic 1)
I select a piano note (pic 2)
then move it (pic 3), whereupon all the Strings immediately vanish from key edit (pic 3). They are still present on the project page however.

Pic 1
piano(red) and Strings folder (different colours).PNG
Pic 2
selecting a single piano note (on the left).PNG
Pic 3

I will try and do a video. I did one before but I can’t remember how I did it.
(The number of crossroads on the route to a solution are increasing exponentially. That’s how it is with computers. )

Can you tell me where the preferences folder is please so I can remove it as Steinberg suggests? Steinberg isn’t clear on this as it refers to it as a “preference” and a “configuration”.

Yes, I get the same issue. Try to edit in key editor and all the notes vanish.

Hi,

Does it mean, you have a Piano as a single track out of the folder, and then you have multiple (String) tracks in the folder? When you show them all, do you select the Folder, or the tracks in the folder? Where do you click at the moment, when the Strings tracks disappear? Do you click to the Piano Note in the Key Editor?

The preferences folder
Windows: Type %appdata% then navigate to Steinberg/ Cubase 10 (this is the preferences folder)
Mac: -User/Library/Preferences/Cubase 10 (this is the preferences folder)

Thanks. See pic of project page with piano single track and string folder selected.

  1. When I select the track folder for the strings, I do not select any of the string tracks separately.
  2. I select the piano as a single track. I sometimes do this before selectinmg the strings folder, it makes no difference. The piano track is not found in the strings folder, see pic.
  3. I double-click the strings folder/piano selection from either the piano track or the strings folder (it makes no difference to the problem, I have found) and key edit opens up normally.
  4. Moving any instrument note in key edit causes the notes from only the folder track instruments to vanish. The piano never vanishes. However, all instruments play back even if key edit is set on solo.

I am not confident about reinstalling Cubase 10 to cure the problem as this may not remove the possibly corrupted preferences folders and my attempt to remove the preferences folder may remove my expression maps which took a long time to configure. The preferences folder also may not be the problem. I am not confident of correctly navigating the file structure to remove and keep files safely, especially after typing in %appdata%Steinberg threw up an error screen (Windows cannot find C:\Users…)

Hi,

Now I can see lots of wired behaviour regarding to open Key Editor while using your tracks/folders structure. I will report them to Steinberg (CAN-19652 and CAN19653).

Can I make a last check in with you on your comment above? -

  • Are you saying that you have observed the same problem in key edit?
    If you have then this means that I won’t need to try and fix it, as it is a bug.
    (also, in your estimation how long does it take for Steinberg to fix something like this?)

Hi,

I don’t know, if my use-case was exactly the same as yours (the video would help).

My scenario:

  • Piano folder
    |- Piano track
  • Strings folder
    |- Vllins 1
    |- Vllins 2
    |- Vlas
  1. Select Piano track MIDI event.
  2. Select Strings folder event.
  3. Double click to the Strings folder event (the same result if I click the Piano event) to open the Key Editor with the Piano data, and all Strings data.
    => Only Piano data has been shown in the Key Editor.

I cannot estimate when this could be fixed. The same behaviour was in Cubase 9.5 already, and probably since ever. And they were no much users complaining about it, so it seems, it’s not a big deal for the users at the end. To knowing this, I wouldn’t expect a quick fix, to be honest. But it’s just my guess.

Did you drag the midi data from the Chord Track onto a midi track by any chance?

Hi,

The display issues I described are without dragging MIDI data from the Chord Track.