Cubase 10 - Mixer window issue - Multiple displays (Windows 10)

I’m having a weird and annoying issue. I’m using Cubase Pro 10 (Version 10.0.60) in Windows 10

I have a 2- displays setup. Since my 2nd display is above my 1st display, I’ve set it up in Windows accordingly (with the 2nd display on top of my 1st, so that I can move the cursor up in to my 2nd display.

In Cubase, I drag upwards and put my Mixer Window in to the 2nd display. Now when I press F3 - the hotkey to open/close the Mixer window, it keeps opening in the 1st display rather than the 2nd, which means that every time, I hide and bring back my Mixer window, I have to drag it to my 2nd display :expressionless:

What’s weird is, if I set up my 2 displays side by side in Windows (which is the default option), I don’t have this issue - meaning if I place my mixer window in my 2nd display (which is to the side now), and press F3 to hide/show the Mixer window, it always pops up in the 2nd display.

Has anybody else had this issue and is there a solution?
I want to be able to set up my displays one on top of the other and have my Mixer Window stay on the 2nd (top) display at all times.

Hi devinpaul,

I didn’t know you could set Windows to behave as though there was a monitor above the first one :).

Your second monitor’s physical position in the real world shouldn’t make any difference. I would think it’s how you’ve told Windows about how to orientate your monitors. Try setting Windows up as though your second monitor is to the right of your first monitor. That should do it.

I run two monitors side by side. If I physically move the second one above the first it shouldn’t matter. After pressing F3, I think the mixer would move to the top monitor. Let us know how you make out.

Thanks for your response.

Yes, if I set up my monitors side by side in Windows it does work fine.

But since I have my 2nd monitor physically above the 1st one, I want to set it up the same way in Windows as well - which I can.

My question is whether or not I set up the monitors side by side or one above the other in Windows,
the Mixer window should stay in the monitor I place it at, right?
That doesn’t happen - it stays if the monitors are set up side by side, but does not stay that way if they’re set up one on top of the other (in Windows).

I have two screens one on top of the other, but the mixer is on the lower one. It works fine here. Could you try the following?

  • Press F3 to show the mixer (in the main screen).
  • Resize it so that the mixer will fit in its entirety in the new screen.
  • Move the mixer to the new screen.
  • Double click on the header so that the mixer window is maximized in the new screen.
  • Press F3, and then F3 again.

What happened? Did it work or not?

Thanks

So, I tried this.

If I don’t maximize the Mixer to fit the 2nd screen and manually size it so that it covers my entire screen, it works fine - I can use F3 to show/hide it and it appears in the 2nd screen.

But if I maximize it to fit the 2nd screen by itself and then use F3 to show/hide, it comes back to my 1st screen.

I guess I’ll just use this work-around - not maximizing it, but manually sizing it in the 2nd (top) screen

It’s strange though

I also tried using like how you have it set up - the Project Window in my top screen and Mixer Window in the bottom one. It works fine that way.

But physically, my bottom monitor is larger than my top one, so I want the Project Window in my bottom monitor and Mixer in my top monitor

Ah, that’s strange. I’m not in front of Cubase right now, but at “Windows” Menu, over to the right, there is a place where you can “Reset Layout” of open windows. Maybe give that a go before thrashing preferences? Also, did you try in safe mode?

So, just to confirm. Your No.1 (according to windows) screen is the big one, at the bottom, and No.2 is a smaller one above.

Edit: Another idea. Could you save a global workspace where you have the mixer maximized as it should be? Then load “no workspace”. Then load your save workspace. Does it work?

I tried different things using the ‘Windows - layout options’ in Cubase that you mentioned. They don’t seem to make a difference.

Actually my bottom monitor is No.2 and top monitor is No.1, but I’ve made the bottom monitor my ‘Main display’ in Windows.
I don’t suppose that would make a difference right?
Cuz Windows just by default makes monitors connected to specific outputs on my video card as no.1 and no.2

In my case, the no.1 monitor (Primary as win10 says) is where I keep the project window, with the menu bar, and I’ve set up the smaller one where the mixer lives as no2. I haven’t tried to see if it makes a difference. I could try, but that won’t be for another 4-5 hours.

Edit: Since you’re trying stuff out, give the workspaces a go. (It’s not that you HAVE to use the workspaces, it’s that loading and unloading them might get the window un-stuck.)

Thanks for your responses.

I tried the workspaces. It still doesn’t make a difference.

I tried with different orientations on Windows. Basically, it seems like, it works fine every other way except the way I want it to work :smiley:

:rofl: :see_no_evil:

Hang in there, we’ll figure it out eventually!

Edit: Ok, I tried your setup and it does the same for me. (I’m on 11.0.10 btw)

I don’t know if it’s Cubase or Windows to blame here. I found it difficult to drag the mixconsole to the screen above, because 3 times out of 4 Windows thought I wanted to maximize the window in the lower screen. Maybe Windows intercept this action? I really don’t know. Let’s wait for someone closer to the development team to offer their opinion. Or you can tag this as an issue, and see how it goes.

Hmmm… Strange.

I guess I’ll just work around it for now then.

Thanks so much for taking the time to test it yourself.

What exactly do you mean by “tagging this as an issue”?

Ah, but you already have tagged it as an issue, sorry to miss that.

I’m with you that something’s going on here. Let’s wait for Martin, he’ll know better.

I think ggmanestraki may be on to something here.

I’m convinced this is still a Windows characteristic. I’m thinking that the shifting of monitor focus in Windows is based on users moving the mouse horizontally, not vertically. Windows can differentiate this action because basically every monitor now is in a 16:9 ratio, therefore, Windows only moves the focus when the cursor traverses the “9” or Y axis, not the 16 or “x” axis.

Which means it shouldn’t work if I swap the project window and mixer window between the 2 screens. It works then even while it’s along the ‘x’ or 16 axis

Update :

It seems to be working the way I want it to if I have Windows set to show the taskbar on my secondary display - which I can live with I guess :slight_smile:

Alright, lovely! But still, I think this issue needs investigating.

1 Like