Cubase 10 problem with Ryzen 5 2400G integrated gpu

hi everyone,
i just build a PC for my friend, he used it for audio production with cubase. the problem is cubase 10 crashed randomly, no dump file on folder Document-Steinberg. i’ve troubleshoot for a week (change windows version, disabled plugin all of them, updating runtime library msvc++, dotnet etc, replace the ssd, updating BIOS (gigabyte B450 Gaming) to F42a, updating latest chipset driver from gigabyte website and amd website) it still crashed even just playing a track.
here’s some info i get from windows applications log:
Faulting application name: Cubase10.exe, version: 10.0.40.284, time stamp: 0x5d5e8df6
Faulting module name: ucrtbase.dll, version: 10.0.16299.1059, time stamp: 0x27fc3e10
Exception code: 0xc0000409
Fault offset: 0x000000000006b0be

yesterday i open task manager and saw gpu usage spiking to 100% when the cubase crashed, so i think its the graphic problem. and now i try running it with old gtx 650 1gb, its allready 6 hours and still running without crash. is anyone have an experience (and a fix of course) with this kind issues?
ps:sorry for my bad english, im indonesian

Hello,

a crash in the ucrtbase.dll module is indeed a graphic issue. I’ve seen quite a few with integrated cards…
We usually recommend to install a very recent WHQL driver in custom mode (no AMD Settings, etc.).
The problem persisted for half-a-dozen users I dealt with, but sadly after investigation, most of those cases ended up being ‘not resolutive’ or a driver issue.

The GTX 650 is a tad older and has no Studio Driver, but you can still install the GRD following this procedure: https://helpcenter.steinberg.de/hc/en-us/articles/206463164--Recording-Error-Too-many-tracks-recording-error-message-
If you’re not running a very high resolution, multiple screens and a lot GPU-accelerated stuff, that card is going to be supported for a while.

You could try and use ProcDump to get a crash dump and send it over to me.

P.S. Your English is perfectly fine!

I’ve experienced a similar problem recently on a new PC running Cubase Pro 10.40. The PC is an HP EliteDesk 705 G4 Mini and is based on a Ryzen 5 2400G CPU and Radeon RX Vega 11 integrated graphics. The symptoms are similar - Cubase may suddenly close, sometimes with a “buzzing” sound for 3-5 seconds or so. There is no crash dump file created. The Windows 10 (v1903) Application log will indicate a fault in the ucrtbase.dll module and occasionally will indicate a fault in the ntdll.dll module.

I thought I had resolved the issue by repairing the sll of the Visual C++ Redistributable modules and updating BIOS and AMD video drivers to the latest, however the issue still occurs. It can be an hour or more without happening, but is unpredictable, so the practice for now is th SAVE OFTEN. Based on other threads besides this one, I’m concerned that this could be a “fatal flaw” for this particular hardware and Cubase.

I’m curious about other’s experiences or solutions.

Ron Volkman

Hello Ron,

good call on repairing the Redistributables, often worth a try. Did you also install the graphic driver only?
If you could create a crash file using Microsoft’s ProcDump and send it over to me, I’d like to check it out.
Feel free to also send an NFO file.

Buzzing is strange, though. I’ve seen this only connected to serious UI/GPU misbehaviour.

Hello Fabio,

I’m not familiar with ProcDump, but can download and execute it. The crashes have been fairly rare, glad to say. Last night was the first time in a few days. The buzz is just a hum through the monitors for a few seconds as everything freezes, then Cubase closes. The are no Cubase crash dumps generated. Today I did remove old versions of the VC++ redistrib files and installed the current 2015-2019 version - looks like the same ucrtbase.dll file version. (10.0.18362.387) I also did a clean install of the Radeon drivers using V 17.7, which is about 18 months old. I WAS using the current 19.9 version but thought it might be worth using an older driver as a test.

RonV

Windows Application Log
-----------------------------------
og Name:      Application
Source:        Windows Error Reporting
Date:          9/30/2019 8:56:28 PM
Event ID:      1001
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      HP705-DAW.ats.local
Description:
Fault bucket 1940042202637804001, type 5
Event Name: BEX64
Response: Not available
Cab Id: 0

Problem signature:
P1: Cubase10.exe
P2: 10.0.40.284
P3: 5d5e8df6
P4: ucrtbase.dll
P5: 10.0.18362.387
P6: 4361b720
P7: 000000000006db8e
P8: c0000409
P9: 0000000000000007
P10: 

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB3AC.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB821.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB841.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB83F.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB86F.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Cubase10.exe_f37ce6a06edbb9a4c65ba0306a97d7b6b89743a_f36fca56_284efbf7-3b04-47be-850d-60ba2691ab74

Analysis symbol: 
Rechecking for solution: 0
Report Id: d9dbb7ad-0408-4625-b398-aab4fc73f242
Report Status: 268435456
Hashed bucket: f600dc22d7a61b503aec6a1ac17e21e1
Cab Guid: 0
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-10-01T00:56:28.236750000Z" />
    <EventRecordID>4086</EventRecordID>
    <Channel>Application</Channel>
    <Computer>HP705-DAW.ats.local</Computer>
    <Security />
  </System>
  <EventData>
    <Data>1940042202637804001</Data>
    <Data>5</Data>
    <Data>BEX64</Data>
    <Data>Not available</Data>
    <Data>0</Data>
    <Data>Cubase10.exe</Data>
    <Data>10.0.40.284</Data>
    <Data>5d5e8df6</Data>
    <Data>ucrtbase.dll</Data>
    <Data>10.0.18362.387</Data>
    <Data>4361b720</Data>
    <Data>000000000006db8e</Data>
    <Data>c0000409</Data>
    <Data>0000000000000007</Data>
    <Data>
    </Data>
    <Data>
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB3AC.tmp.mdmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB821.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB841.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB83F.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERB86F.tmp.txt</Data>
    <Data>\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Cubase10.exe_f37ce6a06edbb9a4c65ba0306a97d7b6b89743a_f36fca56_284efbf7-3b04-47be-850d-60ba2691ab74</Data>
    <Data>
    </Data>
    <Data>0</Data>
    <Data>d9dbb7ad-0408-4625-b398-aab4fc73f242</Data>
    <Data>268435456</Data>
    <Data>f600dc22d7a61b503aec6a1ac17e21e1</Data>
    <Data>0</Data>
  </EventData>
</Event>

Hello Ron,

thanks, I have modified your post to include the data in a code box. Going to send you a PM later today.
I’d definitely recommend to re-install the Redistributables you have removed, many of these are installed by software that needs it, possibly plugins too - older versions are not cumulative like 2015, 2017 and 2019 and need to stay on the system.
I have plugins that install versions back to 2005 and 2008 and currently have all versions from 2005 to 2015-2019: all have been automatically installed by plugins.

There is a solution, but it is not good if you also game on your system. deinstall the radeon driver and use the “microsoft basic display adapter”.

I had the exact problem with the same hardware, Cubase 9. I tried all the different Radeon drivers but no better. Eventually I removed the Radeon driver and used the Microsoft one and now only an occasional crash when Cubase is running ( a few a week rather than 3 an hour!). I still do have an issue with Cubase hanging on the Hub screen quite often. I have to restart PC and it usually works fine then for some bizarre reason.

Hi everyone, I have met this very hard issue nad I fought like 2 months with Cubase closing unexpectly. I have cubase 10 pro, windows 10 pro, Gigabyte a320m s2h, Ryzen 3 processor, 16gb ram ddr4 and none of the above solutions result for me, finally I bought a very cheap pci-e card and finally ucrtbase.dll error seems to be gone and I have still cubase opened since 5 hour ago working perfectly! I hope I could help someone because It was very hard to me too.

Any luck finding the solution other than changing hardware or without AMD graphics drivers? (I have a slightly upgraded setup than OP through). I’ve tried most of the suggested things on the forums. I also recorded similar errors with procdump because there is no dump files generated and Cubase just vanishes. I haven’t found any specific action that causes the crash and it might be working well for couple of hours or just couple of minutes. It gives me alot of headache and sounds like there is indeed something fatal with AMD vs. Cubase… I upgraded my desktop to AMD basically on Black friday and I am tired of fighting with this.

Some of the things i tried:

  • Update newest drivers for all hardware and Windows
  • Run “sfc /scannow”
  • Reinstalling Pace / iLok with newest software
  • Removing Waves plugins
  • Reinstalling eLicenser with newest software
  • Disabling soundcard from GPU (not from bios yet but from Windows hardware manager)
  • Disable motherboard soundcard

Setup:

Cubase Elements 10.0.40
Ryzen 3700x
MSI Radeon RX 5700 MECH OC
MSI Gaming Edge WiFi X570 motherboard
Win 10 Pro
Focusrite Scarlett 2i2

I don’t know what to do next because I don’t feel good about changing my expensive graphics card because I also do other things than record audio. Tried Cakewalk since it was free and it works perfectly but Its very hard to use because I’ve been working with cubase for years. And the version 10 is absolutely great if it works.

I have the exact same issue here. Constant crashing 6 to 10 times per hour. Freezing my entire machine

AMD Ryzen 2600,
Cubase 10 pro
GTX 650 ti boost
Asus prim b350-plus Motherboard

Source
Cubase 10

Summary
Stopped working

Date
‎23/‎04/‎2020 23:10

Status
Report sent

Description
Faulting Application Path: C:\Program Files\Steinberg\Cubase 10\Cubase10.exe

Problem signature
Problem Event Name: BEX64
Application Name: Cubase10.exe
Application Version: 10.0.20.187
Application Timestamp: 5c935e03
Fault Module Name: ucrtbase.dll
Fault Module Version: 10.0.18362.387
Fault Module Timestamp: 4361b720
Exception Offset: 000000000006db8e
Exception Code: c0000409
Exception Data: 0000000000000007
OS Version: 10.0.18362.2.0.0.256.48
Locale ID: 2057
Additional Information 1: 8e59
Additional Information 2: 8e59388f9b7d6c34acae2cde7c53bbe2
Additional Information 3: c38f
Additional Information 4: c38fe18025288cea90ab3743c6996983

Extra information about the problem
Bucket ID: 387090af7e7e1465e73abb59dfdc994a (1673856206203820362)

I have had a rock solid Cubase 10.5 for months now. The game changer ( having tried every tweak on the net) was to install a separate basic video card. A simple procedure, it automatically stops the integrated graphics which I believe is the problem. Not sure why but having installed the card it was like night and day difference. A link to my solved post on Facebook group
https://m.facebook.com/groups/238809986890692?view=permalink&id=641043730000647

Hope this helps you.

This is exactly my problem. Ryzen 5 With Vega 8 graphics. There is apparantly no solution and Steinberg are unable to fix it. It should be advertised that Cubase will not work on these machines.

Lots of posts on forums say they have no problems with Ryzen and Cubase. Not sure what the problem is but installing a basic video card solved it 100% for me.

What is your memory configuration? Integrated graphic do steal a lot of memory bandwidth so it usually important to have all memory channels “open”. You need to check the manual, and the easy way is to have same memory modules in all slots. Most likely 4 if it not a itx or a other mini format.

hmmm my Nuendo just works on my Ryzen 2500G based notebook

Has anyone tried them yet with long and heavy projects?

Chipset:
https://www.amd.com/en/support/chipsets/amd-socket-am4/b450

Graphics:
https://www.amd.com/en/support/apu/amd-ryzen-processors/amd-ryzen-5-desktop-processors-radeon-vega-graphics/amd-ryzen-5-0


AMD developers team are always open to work in a patch conjointly with brands, they have fast response, did Steinberg tried to contact to them for solve any of the issues? tech.support@amd.com

I hope don’t take this as spam, I think it’s important that Steinberg can approach AMD to work on a patch, AMD tech support have told me in the past that Steinberg can easily contact to AMD developers to work on a patch together, however recently in 2020 new drivers appeared for AMD specifically for this processor but pretty sure for the rest too, maybe this will solve the problems? if anyone can confirm, it would be appreciated.