Cubase 10 upgrade from Cubase 5 - can I still use 5?

Hi all,

I’ve just upgraded from Cubase 5 to Cubase 10. In doing so, I’ve lost access to a lot of my older 32-bit VSTs & effects. I had hoped that I would still be able to run Cubase 5 alongside 10 so that I could access old songs etc, but now I can’t seem to open Cubase 5 at all. Does anyone know if there is a workaround for this? I don’t want to totally lose all the work done, even if it just means converting VST tracks to audio to carry them over into the new version of Cubase.

All help much appreciated!

Most likely yes but… what versions of CB 5 and CB 10 do you have?

Regards :sunglasses:

Thanks. Both are the ‘full’ versions. Cubase 5 and Cubase 10 Pro. I get an error message now when I try to open Cubase 5 (which unfortunately I don’t have in front of me) but it may be something to do with the licence, as this was an upgrade.

If it is different computers you are running the two versions on - you need to update the Elicenser Software on the computer running Cubase 5. If that´s not it, post some useful information.

Both are on the same PC.

Can you open a C5 project in C10? If so you should be able to go from there. You might have to check that all the content and plugin paths are the same. Also it might be that you will need to update the eLicenser software as it has changed quite a lot since C10 - however, I am assuming that you have already done this.

Well… the Cubase Pro 10 license will allow you to use the Cubase 5 software. So I suppose you need to explain or post a few screenshots of the error. And add any other details you think might help us help you… like Computer OS, etc.

Regards :sunglasses:

If everything fails you could install 8.5 which still has 32bit support.
Did you have the 32 or 64 bit version of 5. And was there ever anything as artist or pro back then?

Cubase error.jpg
Just tried a C5 project in C10 and that opened fine apart from all the missing 32-bit plugins, of course. But it worked. I’ve attached a screenshot of the error I got when trying to open C5. It seems it might be related to ‘GUI resources’ in some way. I had to change to ‘Aero’ to get C10 working. Could that be causing a problem? OS is Windows 7 - professional.

Switch off AERO and try…!? :unamused:

Tried it. Unfortunately didn’t work. Error happens when C5 is loading GUI resources and it says it can’t load them. Was working before so only changes are install of C10 and change to Aero so that C10 would run.

If it is for 32 bit plugins only you need C5, get jbridge. It will bridge 32 bit plugins to 64 bit very reliably and they will still load old projects. There is a demo available so give it a try plus it is cheap and has great support. It does require some work to get your head around but easiest is to leave the 32 bit plugs where they are and the bridged files in you 64 bit vst folder. Try with one plugin first. Also try to get as many 64 bit versions of your plugs as you can.

Looks like something got corrupted…

I would try going to the Windows Programs and Apps menu and try repairing CB 5 from there (can’t remember in Win 7 but, the button name might be “Modify” then “Repair”).

Regards :sunglasses:

Thanks! I’d seen a link to Jbridge so it is great to also see a recommendation. I’ll definitely give that a try as I don’t want to lose so many plugins (even if they are a bit old). Things like Vienna Instruments, Korg Legacy, a whole load Amplitube effects, T-RackS, BfD. A big list in the end.

Thanks. I’ll give that try now.

You know that you can also install and use any version before 10. So also the latest that supported 32bit plugs. (8.5 I think. full installer is on the steinberg site under downloads)

Great advice! The repair worked. Many thanks!