Cubase 11 Activation Code - Possible solution, please read!

Since Steinberg doesn’t seem to provide any info here on the forum about the new way you have to activate your product (Cubase),
I hope, maybe this will help:

If you are getting the error “e-Licenser version too old” you are probably trying to activate using the Download Code, which won’t work! The new undocumented?? way of activating Cubase, is to paste the Download Code in the Steinberg Download Assistant’s “Enter Your Download Access Code” -field, in the top left corner, and it will then return the Activation Code, which you then will use to Activate your licence in the e-Licenser, or directly from the Download Assistant, as shown in this video https://www.youtube.com/watch?v=_Zre7x9P5Ek

So the confusion, (at least for me it was), seems to be that people are trying to activate their product using the Dowload code (which you got in your purchase confirmation e-mail), instead of the actual Activation code.

PS. Here’s a video about using the Steinberg Download Assistant. If you’re already familiar with the new Download Assistant, You can skip to around 3:00… https://www.youtube.com/watch?v=_Zre7x9P5Ek

Yeah I was so confused. There is no instructions how to use the code. I tried using the code in the eLicenser Control Center but the number spacing was all wrong. Then I thought okay maybe I put this code in the MySteinberg. So I went there, clicked Enter Download Access Code and pasted the code. Then it said I have successfully registered and gave me the Activation Code for Cubase 11 to which I am trying to use in eLCC but seems like the servers are jam packed.

One thing I have to ask… What is Cubase Pro 11 UD 1? This is how my license is named. Weird.

sorry this doesnt fix it…thats the first thing i did yesterday and it didnt work tried it today stil not working download assistance says need new version of control center it then gives you download link you install it but then it still says you need new version…its broke

Had a similar problem.

I had to uninstall Download Assistant and re-install latest download from Steinberg. Then I had to Re-install e-licenser as it was crashing out. frustrating but I got there in the end.

Did you use the Activation Code, NOT the Download code in e-Licenser?
Also make sure you are using the Latest version of the Download Assistant and e-Licenser manager software!

Except that currently you cannot access the server to update the elicenser. Plus I have also had issues with passwords, partly because the shop has a different password to the id and the forum. I changed my id password and not my Steinberg id does not work with the changed password. I don’t think I will get C11 installed for a while. There really is no excuse for Steinberg not to have anticipated demand and to have made sure the server could cope.

So the Steinberg servers seems to be overloaded again. :frowning: I was lucky enough to get my C11 license activated early this morning.

Thanks for the note. The email has a confusing title of download/activation code so I’m pleased I saw this note - especially as the read me download didn’t work for me.